Mobile internet not working - Nexus S 4GSupport


Last Updated: 2012-07-21 19:38:41
  1. Dannydtheman

    Dannydtheman New Member

    I recently got my Nexus S hooked back up with Sprint, and since then the mobile network bars have been grey. Internet will not work, and I don't know why. The bars turn blue as if everything is connected again when I have wifi turned on and a network is active. Can still send and receive calls and texts, but anything related to internet or similar data transfer will not work.

    Advertisement
  2. AntimonyER

    AntimonyER AF Addict VIP Member

    Hey, welcome to AF! I moved this into the Nexus S 4G forum for you. (You had it in the Galaxy Nexus forum, different phone from yours ;) ) Thanks for joining up! :)
  3. Polish Prince

    Polish Prince Well-Known Member

    From what I understand, if your bars are Grey, you have Internet but you are not syncing with Google servers. When your bars are blue, then you have Internet & your Google services are active.. eg Talk, maps, Latitude, etc.

    If your bars are Grey & still don't have plain old Internet then something is very wrong. Not sure what to tell you.
  4. innoculator

    innoculator New Member

    So after rooting and updating my Nexus S 4G is running AOKP with Matr1x Kernel and Android v4.0.4. I have what I think is the same problem. I have 4G access and Wi-fi access but if neither are available my 3G data won't work. I have blue bars on everything EXCEPT when I'm on 3G. When I am on 3G I get gray bars and no internet even though I have the upload and download arrows. Anyone have any idea?

    Thanks!

Share This Page