Mobile Network DISCONNECTED when Wi-Fi Is CONNECTEDSupport


Last Updated:

  1. BiggShooter

    BiggShooter Active Member This Topic's Starter

    Joined:
    May 4, 2010
    Messages:
    38
    Likes Received:
    2
    I recently switched from a Blackberry Storm to my first smartphone....the HTC Incredible. So far, I'm very happy with the switch and enjoy everything about the HTC Incredible.

    I'm having a problem with the MOBILE NETWORK being disabled when I'm connected to WI-FI (my home network or any other WI-FI hot spot). Is this suppose to happen? Is there any way to allow this not to happen?? Why does this happen???

    The problem I'm running in to is when receiving or sending MMS / SMS text messages with pics, I am getting a "MESSAGE NOT DOWNLOADED - GENERIC NETWORK FAILURE" message in my status bar.

    Thanks for the replies :)
     

    Advertisement
  2. emmalina

    emmalina Well-Known Member

    Joined:
    Apr 22, 2010
    Messages:
    234
    Likes Received:
    24

    do you have "enable always-on mobile data" marked or not?
     
  3. BiggShooter

    BiggShooter Active Member This Topic's Starter

    Joined:
    May 4, 2010
    Messages:
    38
    Likes Received:
    2
    Yep...I do have "enable always-on mobile data" on (green check mark).

    I disconnected from my WI-FI (home network) and it automatically connected to the MOBILE NETWORK. When i connected back to my WI-FI (home network), it disconnected the MOBILE NETWORK and displayed the following message under the MOBILE NETWORK setting: Use phone for data connection when WI-FI is unavailable.

    Can anyone else confirm that this happens when they are connected to WI-FI??

    Thanks for the replies :)
     
  4. howarmat

    howarmat Well-Known Member

    Joined:
    Apr 8, 2010
    Messages:
    1,580
    Likes Received:
    229
    Same thing happens to me. There is another message i get when i have both 3G and WIFI connected at the same time but i cant remember what it is
     
  5. appleaj

    appleaj Well-Known Member

    Joined:
    Apr 12, 2010
    Messages:
    440
    Likes Received:
    55
    Same thing happens to me. It's really annoying because then I can't use Skype while on WiFi. . .
     
  6. Todd M

    Todd M Well-Known Member

    Joined:
    Apr 7, 2010
    Messages:
    271
    Likes Received:
    39
    Are you by chance using Y5 battery saver, or any app that saves the battery by switching to Wi-Fi when in range of a known AP?
     
  7. BiggShooter

    BiggShooter Active Member This Topic's Starter

    Joined:
    May 4, 2010
    Messages:
    38
    Likes Received:
    2
    I'm not using any battery saver application or an application that switches to Wi-Fi to save battery power. I'm beginning to wonder if this is a *bug* in the Android OS.

    I'm hoping someone can give some insight on this issue.
     
  8. mozetti

    mozetti Well-Known Member

    Joined:
    Apr 28, 2010
    Messages:
    82
    Likes Received:
    20
    Just for an FYI - I was home and had my Inc connected to the WiFi. I sent a SMS message and it was delivered. I don't know a whole lot about the technological details of SMS, but I assumed it went over 3G. So, mine appears to use both simultaneously.
     
  9. kyler13

    kyler13 Well-Known Member

    Joined:
    Nov 17, 2009
    Messages:
    1,638
    Likes Received:
    284
    I'm not sure about MMS with pics or videos, but SMS is sent over 1xRTT so you don't need need be connected to 3G when you're on wifi for simple texting (battery saver). I'll test a picture message when i get home.

    Edit: I confirmed it at home. 3G shuts off when in range of my wifi. Sent an MMS picture message from my wife's phone and I got it no problem. SMS/MMS doesn't require 3G.
     
  10. ejkeebler

    ejkeebler Well-Known Member

    Joined:
    Apr 1, 2010
    Messages:
    147
    Likes Received:
    27
    I'm pretty sure this is by design. Why would you need 3G if you were on WIFI? SMS and MMS don't need it to send or there would be very few people able to text. Also, WIFI uses way less power than the 3G radio,i could be completely wrong so hopefully someone chimes in more definitively.
     
  11. shh

    shh Well-Known Member

    Joined:
    Feb 3, 2010
    Messages:
    83
    Likes Received:
    20
    This is correct. To disable WiFi just install HTC settings widget and turn off/on WiFi.
     
  12. Brian_83

    Brian_83 Well-Known Member

    Joined:
    Mar 29, 2010
    Messages:
    211
    Likes Received:
    30
    Skype actually won't work over Wifi. When you run Skype and Wifi in on it will tell you that you must disable it to use Skype.
     
  13. Tabster

    Tabster Active Member

    Joined:
    Mar 4, 2010
    Messages:
    31
    Likes Received:
    11
    I am getting the MESSAGE NOT DOWNLOADED - GENERIC NETWORK FAILURE everytime someone sends me a picture message.
    Changing wi-fi and other options I can think of do not help.

    Has anyone had this issue and found a good solution?

    thx
     
  14. necosino

    necosino Well-Known Member

    Joined:
    Apr 14, 2010
    Messages:
    1,962
    Likes Received:
    338
    Other people having this issue either uninstalled handcent if the were using it or hard resetted.
     
  15. Tabster

    Tabster Active Member

    Joined:
    Mar 4, 2010
    Messages:
    31
    Likes Received:
    11
    I have not used handcent.
    If I were to hard reset, what should I avoid settings wise during the initial setup?
     
  16. TokedUp

    TokedUp Well-Known Member

    Joined:
    May 1, 2010
    Messages:
    377
    Likes Received:
    38
    I dont think it has to do with the WiFi/MN I think its an App blocking it. Do you have Antivirus? or ATK? get rid of em. NO Need On Droid!
     
  17. Bundy

    Bundy Well-Known Member

    Joined:
    Mar 31, 2010
    Messages:
    250
    Likes Received:
    44
    I have this same problem and have no idea how to fix it. The only app that I have that may be involved in the problem is the Quick Settings widget that shows som sort of APN control error: No APN configured. Could that have anything to do with it?
     
  18. AGWednesday

    AGWednesday Well-Known Member

    Joined:
    Apr 2, 2010
    Messages:
    263
    Likes Received:
    64
    Yes, that's supposed to happen. Wi-Fi and your Mobile Network Connection both provide you with ways to send and receive data, the primary difference being that Wi-Fi is faster than your Mobile Network's 3G connection. When your phone connects to a Wi-Fi network, it drops the Mobile Network Connection since having both on wouldn't be optimal.

    If you want to switch back, just turn off your Wi-Fi and turn on your Mobile Network Connection. That'll put you back onto Verizon's 3G network.

    I've had this problem too. Seems that it depends on what Wi-Fi network I'm connected to. If I'm at home and on my secured private network, everything works fine. If I'm on the Wi-Fi network at work, some functions don't work. I just figured that some networks are setup to prevent certain "abuses."

    The best thing might be to take that Wi-Fi network off your list, since it won't allow you to do certain basic tasks.
     
  19. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,067
    Likes Received:
    8,534
    I've noticed this same thing for weeks and just figured it was viewed as normal by everyone. Surprised somebody hadn't mentioned it by now actually. I like this feature because it uses WiFi when available which is easier on the battery. I did have one time where I ran into a fail to send issue which required toggling WiFi off and toggling 3G on. Kinda seemed like a worthwhile tradeoff in my case but special circumstances might make it more of a pain for some.
     
  20. iowabowtech

    iowabowtech root@android:/ #

    Joined:
    May 2, 2010
    Messages:
    12,067
    Likes Received:
    8,534
    Same here. I made the same assumption. Haven't had any issues on my home network.
     
  21. Eng320

    Eng320 New Member

    Joined:
    May 2, 2010
    Messages:
    3
    Likes Received:
    0

Share This Page

Loading...