Modaco 2.3 update problems


Last Updated:

  1. t3monkey boy

    t3monkey boy Member This Topic's Starter

    Joined:
    Sep 3, 2009
    Messages:
    22
    Likes Received:
    0
    Hi There

    Im having a few problems with the Modaco 2.3 update.
    I flashed the 2.3 rom after wiping the data, but when i started to use it i realised i had lost the APN's and also was getting a process com.android.mms message and have to force close when looking at some of my old messages(but not all) i had restored these using mybackup pro, i got round the APN issue by restoring to my old nandroid backup and using
    an APN back up program from the market to reinsatall them after flashing the 2.3 update again, but im still getting the process com.android.mms message.
    Has anyone had similar problems and how did they sort it.
    Thanks
     

    Advertisement
  2. Slug

    Slug Check six! Moderator

    Joined:
    Aug 1, 2009
    Messages:
    20,378
    Likes Received:
    16,472
    It's restoring the old message db that has caused it. There are instructions here (posted on the @MoDaCo web site) for editing the db if you feel up to it....
     
  3. t3monkey boy

    t3monkey boy Member This Topic's Starter

    Joined:
    Sep 3, 2009
    Messages:
    22
    Likes Received:
    0
    Thanks for the reply slug, it sounds a bit much for me to be honest, so am i right in saying it will only effect my old messages? if thats the case i can live with that. will it cause me any problems going forward?

    Thanks
     
  4. Slug

    Slug Check six! Moderator

    Joined:
    Aug 1, 2009
    Messages:
    20,378
    Likes Received:
    16,472
    That I'm not sure about. I've a feeling that it might, as a new field was added to the db with 2.73.xxx.x which will be lacking in your restored version. The software however will presumably be expecting to write to this field. The 'safest' course of action might be to wipe and then restore from backup, this time excluding messages.

    I'd recommend you check that thread for further info; I'm pretty sure not everyone edited the db so there's probably solid advice over there.
     
  5. t3monkey boy

    t3monkey boy Member This Topic's Starter

    Joined:
    Sep 3, 2009
    Messages:
    22
    Likes Received:
    0

    Sorted now, restored back to last saved backup re-flashed 2.3 without wiping and did not bother trying to restore any of my old messages etc.. an all seems fine.
    Thanks for your help, should be getting my new SD card shortly so will probably have more questions re saving apps to SD.
    cheers
     

Share This Page

Loading...