MoDaCo Custom Rom Based on IH8


  1. pegasus21

    pegasus21 Well-Known Member


    Advertisement
    :
  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    sick
    my mate runs this on his hero and its very quick indeed.
    cant wait for the ii5 version. i dont want to go back to h8, since flashing to ii5 my device is even better on battery and the transitions/screen feels more responsive
  3. tisti

    tisti Well-Known Member

    I installed this just today after finding it :D

    It runs pretty snappy, will need more time to see.
  4. Xenon

    Xenon Well-Known Member

    Awsome!

    This is the only thing I don't like about Galaxy, the way the community
    is dispersed over all sorts of forums and blogs and it's so hard to keep
    track of everything.

    Thanks for the link.
  5. GalaxyMeh

    GalaxyMeh Well-Known Member

    I've installed the MoDaCo ROM (v1.1) and now whenever I search for something in Google Maps (v3.1.2), it enters a force close loop. Also, it can't display directions.

    Has anyone else run into this?

    As for the community being spread over various forums, I've seen the same problem. While AndroidForums is the largest, there are a few other important forums. I've listed them at Samsung Galaxy community forums on my Galaxy wiki.

    I think one major problem is that people are more comfortable with talking in Italian (hdblog.it) or French or whatever language but English. IMO this splits up the community for a silly reason. Just use English, even if broken, and go with the program. Most terms in Android development, cellular technology and computers in general are English anyway.
  6. carthesis

    carthesis Well-Known Member

    OK. I'm no computer dummy, but I'm a bit lost here.

    I'm trying to get the custom recovery image installed prior to installing the MoDoCo ROM, as per the instructions here:

    http://android.modaco.com/content/s...ed-recovery-image-on-your-device-permanently/

    I followed the instructions to the letter for installing the ROM on a 'virgin' i7500, but hit a snag in that whenever I launched into FASTBOOT mode, Windows had a fit trying to find the driver for an 'Android 1.0 device', and by the time it had decided that it couldn't find one, the phone had just continued booting into the normal OS which effectively removes the Android 1.0 device from the system.

    I've had a Galaxy for about a month now, it's on firmware H6, and it's hacking me right off that I can't update it, either 'legally' or 'illegally'! It's in Debug mode, as required, and the horrid horrid horrid waste-of-drive-space Samsung NPS software is installed. I can connect to the phone via USB and see the memory cards, but that's about it. As far as I can tell, that's all I SHOULD be able to see, correct?

    I tried pointing Windows at the drivers from the Android SDK, but it told me that there were no drivers compatible with the device. This was on my Vista laptop.

    Can anyone help me?

    Please?

    Before this phone goes through the window, and I start hunting down O2 and Samsung technical staff with a hunting rifle?

    EDIT:

    I've just tried this entire process again on a WinXP PC that has never had any of the Samsung software installed on it previously. Downloaded NPS (IH4 build) from the Samsung website, installed it. Plugged in phone and it found most of the drivers but was still left with an unknown device. Booted into FASTBOOT, got the Windows driver request for an Android 1.0 Device. Told Windows to look for it, no joy. Installed the 'USB drivers' from the CD that came with the phone, tried again. Same problem.

    Help?

    Before this phone goes through the window, and I start hunting down O2 and Samsung technical staff with a hunting rifle?

    EDIT 2:

    Tried it again, still no joy. Again tried forcing Windows XP to pick up the generic 'Android 1.0' device drivers from the SDK (android-sdk-windows-1.0_r2.zip), and again told that Windows can't find any suitable drivers for that device.

    The biggest problem I'm having seems to be that because Windows can't find drivers, it can't find the phone in FASTBOOT, hence nothing else works.
  7. Rastaman-FB

    Rastaman-FB Well-Known Member

    download the 1.5 android sdk
    point the drivers manually to the android usb files and select adb/android test interface

    or try using the drivers from odin
  8. carthesis

    carthesis Well-Known Member

    Ah, so it's just the wrong SDK i got then?

    I stupidly made the incorrect assumption that as it came up as 'Android 1.0' rather than 'Android 1.5' that I'd need the v1.0 SDK. I realise now that this was particularly daft - why make it so obvious? ;)

    So it's just a case of when the 'Android 1.0' device turns up and Windows asks you for drivers, point it to the relevant folder in the SDK, and go from there?

    Wish I'd brought my laptop to work now - I could have tried this.
  9. Rastaman-FB

    Rastaman-FB Well-Known Member

    yeah, you have about 15 seconds to go to manual select and "have disk" point it to the folder and select adb test interface.

    it took me a good 3-5 device reboots the get it right in time but once done just power into fastboot again and do the recovery flash

    its hard work lol but i got there in the end
  10. carthesis

    carthesis Well-Known Member

    Rasta - I think I might love you just a little bit!

    Thanks mate. Appreciate the help - they do like to make this hard, don't they?

    Now all we need to do is wander round to the Samsung UK HQ and give them a good solid kicking!

    Is there any improvement in the keyboard responsiveness of the MoDoCo build does anyone know? As I mentioned, I'm on H6 and the keyboard can't keep up with me - I was significantly faster on a T9 keyboard with my old N95. MoDoCo is H7 right?

    I'm just torn between this, and going with II5 at the moment.
  11. Rastaman-FB

    Rastaman-FB Well-Known Member

    modoco is h8, i havent tried it as im currently on an i5 build that i have rooted with recovery v3
    im looking at the compcache glaxo/glaxhero roms that are using i5 atm

    might grow some balls and dive in for that one. was scared enough rooting my phone cos of the similar issues you had only it was even worse as i have windows7 pro x64
  12. carthesis

    carthesis Well-Known Member

    Yeah. I was annoyed more than anything. Bloody phone nearly went across the room last night. How hard is it to have 'drivers'? I mean, I'll grant getting NPS working might be a bit trickier, but drivers? C'mon.

    I think I might use the Recovery v3 from the glaxo/glaxhero setup, and try the MoDoCo ROM. Least I can always just flash it up to the glaxo build after that if the responsiveness is still lagging.

    Suppose it depends how long it is until the MoDoCo build is updated. A more responsive keyboard would be nice though.
  13. hagi

    hagi Active Member

    Heres a daft question:

    If you flash the recovery image, will that be overwritten if you use odin to flash another firmware version?
  14. Rastaman-FB

    Rastaman-FB Well-Known Member

    part of the rom flash is the recovery image
  15. kam187

    kam187 Well-Known Member

  16. carthesis

    carthesis Well-Known Member

    Kam - is that the driver to use for the 'Android 1.0' device that comes up in FASTBOOT mode then?
  17. kam187

    kam187 Well-Known Member

  18. carthesis

    carthesis Well-Known Member

    Ah-hah. These forums are finally back online!

    So i got the software updated - for anyone having similar problems, I found that the 1.5 SDK drivers didn't work, so best thing is to use the modified driver file that Kam187 provided.

    My only remaining problem is that for some reason, even after the update, the phone is still reporting the baseband version as H6 and not H8, and I've no idea why. :confused:
  19. kam187

    kam187 Well-Known Member

    The script he's using to update the baseband doesn work :(

    You're best bet is to update to H8 with odin, and then install the Modoco rom afterwards.
  20. carthesis

    carthesis Well-Known Member

    Oh-ho.

    That explains it.

    Well, I was thinking about installing the GALAXO ROM tonight to try that anyway.
  21. Rastaman-FB

    Rastaman-FB Well-Known Member

    if you are meaning the beta2 its been taken down for a bit
  22. tisti

    tisti Well-Known Member

    II5 Modaco rom is up.

    Sadly it is his last build :(
  23. Rastaman-FB

    Rastaman-FB Well-Known Member

    link

    did he say why he was stopping?

    EDIT sorry top of thread
  24. tisti

    tisti Well-Known Member

    he's probably selling his galaxy.
  25. kam187

    kam187 Well-Known Member

    Yeah he said he is. The hdblog.it one has alot more customisations tho. He's incorporating modded apps from xda-developers.
Loading...

Share This Page