Motorola Droid Bionic - All Things Root Guide


Last Updated:

  1. rovrhys

    rovrhys Well-Known Member

    ok im doing the manual root method and at the #15 it tells me that the update failed....what would that mean? the only thing i can think of is when I did step 11 i got this.


    C:\AndroidSDK\platform-tools>adb push '/home/user/location/su' /system/bin
    cannot stat ''/home/user/location/su'': No such file or directory

    C:\AndroidSDK\platform-tools>adb shell
    root@cdma_targa:/# chmod 4755 /system/bin/su
    chmod 4755 /system/bin/su
    Unable to chmod /system/bin/su: No such file or directory
    root@cdma_targa:/# reboot
    reboot


    no such file or directory found.... normal or no?

    re opened the command prompt and got this....
    C:\AndroidSDK\platform-tools>adb shell
    shell@cdma_targa:/$
    that $ should be a # if i was rooted correct?

    Advertisement
  2. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    My apologies. So, you're in fastboot mode by rebooting and holding the volume key, right? You open a terminal window, and then you change to the directory where the fastboot-osx file is located, right?

    Verify this for me - type
    Code (Text):
    1.  ls -l
    and see if that file is there. I have a hunch that
    Code (Text):
    1. ./fasboot
    in the commands needs to be the application specific
    Code (Text):
    1. ./fastboot-osx
    Rovrhys, you need to push from your computer to the BIONIC. So, the adb push command should be {directory where you extracted that su.zip file on your computer} to /system/bin
  3. rovrhys

    rovrhys Well-Known Member

    thanks... i feel ******ed for just copying that and not putting in my own path haha
    everything worked out great SU and busybox installed.... now what shall i do
  4. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Lol - the rest is up to you.

    Be sure to grab the Superuser app from market Superuser as well as the Busybox installer app (there are two, one by stericson, Busybox and one by jrummy Busybox installer, both which have donate / pro versions as well as the free one). I used jrummy's pro installer.

    Superuser, after running it, will tell you that there is an updated version of su, so update, then install superuser.

    Busybox (installer) installs busybox - I recommend v1.18.x or higher (I think jrummy's app allows you to install 1.19.x)

    At this point, though, I'd get ROM Manager and then use it to install the Clockwork Mod Recovery, so you can do backups of the ROM natively, without having to use the bootstrap app. (I bought the Premium version).

    HTH
  5. rovrhys

    rovrhys Well-Known Member

    just downloaded Clockwork mod. glad to have it back i was missing the OG droid
  6. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    I feel you. I was jonesing to have it running again on my phone - I installed it but it did me no good just sitting there in my app drawer lol....

    Be sure to get the other two first before running ROM Manager, if you haven't already.

    Note to self: update procedure to give market links to superuser and busybox (installer) apps
  7. rovrhys

    rovrhys Well-Known Member

    yeah i go the other 2 thanks
  8. the dmg

    the dmg Member

    Sooo...I'm rooted and everything with the Bionic, and I can't seem to mount as r/w.
    I use the following steps:
    Code (Text):
    1. $ adb shell
    2. $ [FONT=courier new]su[/FONT]
    3. # mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
    After that I get:
    Code (Text):
    1. mount -o rw,remount -t yaffs2 /dev/block/mtdblock3 /system
    Which is just a repeat. What am I doing wrong?

    EDIT:
    I searched for a long time with no luck. I'm also using ES File Explorer, and can't rename files.
  9. tehsusenoh

    tehsusenoh Well-Known Member

    If you install ROM Toolbox from the market you can just check a box to mount as read/write.
    the dmg likes this.
  10. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    First of all, use the [ code] and [ /code] tags (do an advanced post and use the # button to make the code tags) instead of quotes - when I quote you, the things you quoted will not come through, so it makes the reply confusing.

    Now, from Android Tricks: Mount a filesystem read-write we get:

    So, running
    Code (Text):
    1. cat /proc/mounts
    gives you
    Code (Text):
    1. rootfs / rootfs ro,relatime 0 0
    2. tmpfs /dev tmpfs rw,relatime,mode=755 0 0
    3. devpts /dev/pts devpts rw,relatime,mode=600 0 0
    4. proc /proc proc rw,relatime 0 0
    5. sysfs /sys sysfs rw,relatime 0 0
    6. none /acct cgroup rw,relatime,cpuacct 0 0
    7. tmpfs /mnt/asec tmpfs rw,relatime,mode=755,gid=1000 0 0
    8. tmpfs /mnt/obb tmpfs rw,relatime,mode=755,gid=1000 0 0
    9. none /dev/cpuctl cgroup rw,relatime,cpu 0 0
    10. [B][COLOR="Red"]/dev/block/system /system ext3[/COLOR] [/B]
    11. ro,noatime,nodiratime,barrier=1,data=ordered 0 0
    12. /dev/block/userdata /data ext3 rw,relatime,errors=continue,barrier=0,data=ordered 0 0
    13. /dev/block/cache /cache ext3 rw,nosuid,nodev,noatime,nodiratime,errors=continue,barrier=1,data=ordered 0 0
    14. /dev/block/webtop /osh ext3 rw,relatime,errors=continue,barrier=0,data=ordered 0 0
    15. /dev/block/pds /pds ext3 rw,nosuid,nodev,noatime,nodiratime,errors=continue,barrier=1,data=ordered 0 0
    16. /dev/block/preinstall /preinstall ext3 rw,nosuid,nodev,noatime,nodiratime,barrier=1,data=ordered 0 0
    17. /data/data /data/data ecryptfs rw,nosuid,nodev,noatime,nodiratime,ecryptfs_sig=fcb4de13e51102ca,ecryptfs_cipher=aes,ecryptfs_key_bytes=32,ecryptfs_passthrough 0 0
    18. /data/home /data/home ecryptfs rw,nosuid,nodev,noatime,nodiratime,ecryptfs_sig=fcb4de13e51102ca,ecryptfs_cipher=aes,ecryptfs_key_bytes=32,ecryptfs_passthrough 0 0
    19. securityfs /sys/kernel/security securityfs rw,relatime 0 0
    20. /proc /osh/proc proc rw,relatime 0 0
    21. /dev/block/vold/179:1 /mnt/sdcard-ext vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
    22. /mnt/sdcard-ext /mnt/sdcard-ext ecryptfs rw,dirsync,nosuid,nodev,noexec,relatime,ecryptfs_sig=fcb4de13e51102ca,ecryptfs_cipher=aes,ecryptfs_key_bytes=32,ecryptfs_passthrough,no_new_encrypted 0 0
    23. /dev/block/vold/179:58 /mnt/sdcard vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
    24. /dev/block/vold/179:58 /mnt/secure/asec vfat rw,dirsync,nosuid,nodev,noexec,relatime,uid=1000,gid=1015,fmask=0702,dmask=0702,allow_utime=0020,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
    25. tmpfs /mnt/sdcard/.android_secure tmpfs ro,relatime,size=0k,mode=000 0 0
    26. /mnt/sdcard /mnt/sdcard ecryptfs rw,dirsync,nosuid,nodev,noexec,relatime,ecryptfs_sig=fcb4de13e51102ca,ecryptfs_cipher=aes,ecryptfs_key_bytes=32,ecryptfs_passthrough,no_new_encrypted 0 0
    27. /dev/block/dm-0 /mnt/asec/com.bitcoinandroid-1 vfat ro,dirsync,nosuid,nodev,relatime,uid=1000,fmask=0222,dmask=0222,codepage=cp437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro 0 0
    28.  
    So, change your command to:

    Code (Text):
    1. mount -o rw,remount -t yaffs2 /dev/block/system /system
    and when you run it you will get the repeated command - but system is now r/w

    HTH
    the dmg likes this.
  11. the dmg

    the dmg Member

    Thanks. I'll give it a try and see if that will allow me to mount as r/w. If it works, it might just be ES Explorer that's giving me issues.
  12. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    Read my post - you just need to change the mount point - you're using the file structure for the older versions of Android and not the current.
  13. the dmg

    the dmg Member

    Just refreshed and saw your post. I didn't realize I was using the file structure for the older version.
  14. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    I didn't either, until I read that link I posted - as soon as I ran the cat on /proc/mounts I was like 'WTF? - they changed it! lol'
  15. Theshape

    Theshape Well-Known Member

    Started fresh from factory all over.......good to go all rooted and rom'd.
    Thanks johnlgalt
  16. dscottjr81

    dscottjr81 Well-Known Member

    Yes fastboot-osx is there and so is fastboot and fastboot-mac these that I downloaded from xda and another website trying to figure if something was happening during the download. I dont know if you own a Mac or just know the commands but here is question, when I download the fastboot-osx its icon is just plain white. I found a fastboot-mac file in another folder from sometime ago for my HTC Desire I think and its icon is grey and has exe in the top corner of it. I say this because it seems something is missing from the fastboot file im downloading now because it doesnt look the same or give the same action and its plain white. When I try the fastboot-mac from the HTC Desire folder it takes the ./fastboot-osx flash system system.img command but then it just says, 'waiting on the device', for a while but im not sure how long I should wait or if it will even work being it was meant for another phone. Its still a fastboot file so why not be universal for any phone when using fastboot? This is why I asked about you having a Mac and the way fastboot-osx looks when downloaded. Maybe it has nothing to do with but the fact that the fastboot-mac file gives more action than the one im downloading has me curious. Unfortunately Im still on the ground with this and havent had progress. At last Im not sure what you mean by application specific? Thanks for continuing to try and help me as this frustrating because I have rooted many phones before by following command lines so its not my first time. I just dont what to do when my phone doesnt take them.
  17. johnlgalt

    johnlgalt Antidisestablishmentarian VIP Member

    You probably will not be able to run the executable using the
    Code (Text):
    1. ./fastboot
    because, IIRC, that may be a specific version for your old phone, an may not work here.

    Use the file from the post above, and note that the file that you download is called fastboot-osx. Then you can either:

    • Change all of the commands to run
      Code (Text):
      1. ./fastboot-osx
      , or
    • Change the filename from fastboot-osx to fastboot using a file manager (there is one built into the BIONIC called Files that you can use to rename a file - long press the file an it will give you a popup with options including rename)
    tehsusenoh likes this.
  18. longball10

    longball10 Well-Known Member

    So this is a little off topic from the current convo but I ran into a problem today flashing to 1.7.. Flashed it, wiped ALL data and cache.. Rebooted and got to the intro screen. The phone shows no signal and the little "x" is next to the signal bars.. I tried to wire a few more times and swapped LTE sim cards already. Obviouly the phone wont go past this screen because ut needs the data line to re-load everything... The only thing I can do next would be to SBF but this seems to be a little different problem than the usual... Any ideas?
  19. tehsusenoh

    tehsusenoh Well-Known Member

    I'd try starting from scratch, and make sure you format /system, /data factory reset, + cache, and dalvik.

    I'd ask over at rootz to th3ory first though.
    longball10 likes this.
  20. longball10

    longball10 Well-Known Member

    Wow.. I just re-read my post and was apparently typing fast.. I can only boot into the stock bootloader so i can only wipe data/cache.. IS there a way for me to boot into CWR when the power is off and I cant load anything else on the phone?? I have a backup ready and on the SD card but need to be able to access CWR to use it.. I have wiped data/cache probably 5 times now with no success.
  21. tehsusenoh

    tehsusenoh Well-Known Member

    Nope, you have to FXZ restore, rebootstrap, boot into CWR, then you can either restore that nandroid or install 1.7.
  22. longball10

    longball10 Well-Known Member

    I figured out my problem.. Missed the sentence in the instructions that tells us to install the 2 .zip files seperate from each other.. Im a bonehead.. All is well.
  23. thatguy188

    thatguy188 Well-Known Member

    This problem also happens if you do it right, and then do a nandroid backup.

    Upon restoring the nandroid backup of 1.7 you will experience the same problem you just described.

    I guess that's because a nandroid restore will install both files at once, causing the issue. Just a heads up if you're planning on doing a nandroid backup/restore with 1.7
  24. YankeeDudeL

    YankeeDudeL Well-Known Member

    Thanks tehsusenoh for the thread. Made rooting a breeze.
  25. OutOfPhase

    OutOfPhase Premium Member

    johnlgalt and YankeeDudeL like this.

Share This Page