Motorola triumph will not turn on


Last Updated:

  1. Hey guys, I was wondering if someone here can help me with this problem I am having. I have recently switched to the galaxy s2 on VM and my Triumph no longer works. The battery drained and now it wont turn on. I should also mention that I was running mtdev cm 7 on it and did not revert to the stock os before the battery drained. Is there any way to get the phone to work again? Thanks in advance for any help with this situation.

    Advertisement
  2. thIsgUy20

    thIsgUy20 Well-Known Member

    From my experience you gotta just leave it on charged it'll turn on. When I had the triumph my phone died and when I put it on charge there was no light. So I just let it stay and then it finally showed the charged light. Idk why but its like if the phone is 100% dead and u put it on charge it won't even show the charging light but just keep it on charge for awhile it should start working
  3. ben1122a

    ben1122a Well-Known Member

    Any more information you can give us?
    Does the phone's light show that it is charging?
    Can you get into recovery mode?
    Does it show the boot screen, but not fully turn on?

    More information will help us help you.
  4. dsmryder

    dsmryder Well-Known Member Developer

    I had sonething like this on another phone. What I had to do was wire a charged battery up to the other battery to give it enough charge to turn on the phone.
  5. No there is no light indicating a charge (I tried leaving the phone to charge for a day and still nothing). No the phone will not turn on period, as in no vibration to notify me that the phone is turning on and the screen stays black. That is about all I can say. I tried going into recovery mode, but the same thing. The phone just doesnt turn on. Could it be that since the phone is no longer active, CM9 wont let it turn on?
  6. bob-st

    bob-st Well-Known Member

    I agree with dsmryder. Your battery is probably completely dead. And no this i NOT a rom issue.
    Steelberserker likes this.
  7. Are you sure that this isnt because I disconnected the phone from service and still had a custom rom on?
  8. ben1122a

    ben1122a Well-Known Member

    I had this problem with my first phone. I think it just has to do with the battery. You could try what dsmryder said, or, if you are still under warranty, call virgin mobile and request a replacement. They generally just throw refurbished phones all over the place if you need one.

    I would try the hooking up another battery, or even buying another battery, first, because the refurbished phones they send you can be pretty messed up. I had to get 4 refurbished phones from them before I got a working one. And it has a kinda messed up screen too.
    Steelberserker likes this.
  9. Unfortunately my phone is more than a year old and warranty is probably up. I intend to sell the phone as soon as I whipe all my data from it out so I guess getting a battery is my next best option.
  10. dsmryder

    dsmryder Well-Known Member Developer

    That's what I would do. I just picked up a battery from eBay then found the better I lost and was trying to replace. I work on electrical components all of the time so I feel comfortable in what I do. It's not for the faint of heart as a bad move can burn up a battery.
    Steelberserker likes this.
  11. g01851

    g01851 Well-Known Member

    Try checking the battery contacts on the phone and battery... clean them off with a cotton swab and a bit of rubbing alcohol...
  12. OverByter

    OverByter Resident Slide Rule Guru

    You can also get a replacement battery and external charger from eBay for under $5, it would take care of the problem whether it was caused by the battery, charging port or charger/cable. Cover all your bases in one shot. :p

Share This Page