Motorola Triumph won't charge?Support

Last Updated:

  1. momo951

    momo951 Member

    This just started today. I plugged in my phone to charge and at first the red light would come on that it was charging but a few seconds after, it would turn off even though it was plugged in. I disconnected the charger and plugged it back in, rebooted the phone and still same problem. I managed to leave it still once and it actually charged but other times it says it's charging but the battery percentage keeps going lower. What is the deal here? I haven't dropped the phone or anything that could break it. It just happened.

  2. Harry2

    Harry2 Well-Known Member

    Maybe the charger is defect.

    Does the phone charge when it is connected to the PC?

  3. momo951

    momo951 Member

    I think it might be the actual charger because my phone charger if I use an iPod wall charger with the USB cable. But I'm still wondering how the charger just randomly stopped working?
  4. melissapugs

    melissapugs Well-Known Member

    I lost chargers and cables galore...until I realized the outlet I was plugging into had some electrical problem (maintenance man fixed whatever it was, way above my head).
    Shortly thereafter, I lost first iPad to a power surge in a wall socket in a motel room. Long story short: anything that gets plugged into the wall goes into a surge protector :) Hope you get it sorted out
  5. Steeltooth493

    Steeltooth493 Active Member

    I've been having difficulty with getting the Triumph to charge for months :confused:.
  6. Steeltooth493

    Steeltooth493 Active Member

    Hey everyone,

    I'm not sure if anyone can exactly help me troubleshoot this, but I would appreciate it. Back in December I successfully rooted my Motorola Triumph to TinkerGuy's final Gingerbread rom release, and my triumph was working great until early January. Then out of nowhere I began to have battery issues. It would drain relatively quickly and have difficulty charging. I plug it into a wall outlet or my computer and nothing happens, no red LED charging light, nothing. It's been almost three months since then and it is still having problems, to the point where it is completely unable to charge. I was able once in February to charge enough to reset the phone to factory settings and then update the rom to one of Wyzor's TG Reloaded Gingerbread releases, but it worked for a day and then died after that and has stayed that way. I've tried various things to fix it, such as buying a replacement battery and getting a completely different charger from Virgin Mobile customer service, but no dice. I have no idea why this is happening, or if it is a Triumph, rom, or application issue. I don't think that I have any battery intensive applications or settings set to run. However, even if I do I can't change it anyway because I can't get the Triumph to even regularly charge in the first place, and my Triumph is only at least 6 months old.

    What are your thoughts on the issue? Is there any way that you can help me or anything that I can do to fix it?
  7. millenium

    millenium Well-Known Member

    i replied to this in the battery have to get a replacement, the unit is damaged it is either a damaged port or the phone has had serious hardware failure. You should get a new unit before your 1 year warranty is up!
  8. Steeltooth493

    Steeltooth493 Active Member

    Okay, then would it be best to contact vm customer support about it and tell them the usb port or hardware on the phone is broken in order to get it replaced?
  9. thangfish

    thangfish Well-Known Member

    Just tell them it won't charge, even with the new charger they sent you.
    When the new one comes in, use that one to charge it so you can revert it to stock before you send it back.
  10. scary alien

    scary alien not really so scary Moderator


    I've merged your new thread into this one since the issues seem to be the same.

    Thanks and good luck with the charging issue.
  11. frdmspoplr

    frdmspoplr Well-Known Member

    Steeltooth, I hate to ask a stupidly obvious question, but have you tried different cords? I'd assume you have, but it wasn't mentioned in your post, so just thought I'd make sure. Not saying it isn't the phone itself, but I've had trouble with different cords, so there's always that possibility as well, of you haven't looked into it.
  12. Steeltooth493

    Steeltooth493 Active Member

    Yes, I did get and try multiple usb cords along with the new AC charger vm sent me, but none of them worked. At this point I agree with Millenium that it is either a broken usb port or a serious failing hardware issue. I have since contacted vm customer support about getting a replacement triumph. What should I do if I can't get the broken triumph to charge in order to put a stock rom on it after I get a replacement triumph from vm? Would it be likely that they would be able to discover that the broken one was rooted after they get it back?
  13. Ish_fish

    Ish_fish Member

    My phone has the same issue i concluded that the USB port on the phone is flimsy and is easily messed up by the slightest wrong move, your best bet is to get a replacement from VM if still under warranty. If not buy a port off ebay and replace it yourself. Im planning on replacing mine, just have to figure out the disassembly first.
  14. lou61166

    lou61166 Well-Known Member

    Would not worry about sending VM back a rooted truimph,i am starting to think even VM is realizing the Truimp is a POS,seeing they are sending new in the box replacements,i would be more concerned when the warranty period is up.
  15. BlurryEyed

    BlurryEyed Member

    I'm a little late to the party, but my Triumph has problems charging with CERTAIN chargers as well.

    I have my original Triumph that worked with all chargers I had in the house. I dropped/cracked the screen, VM replaced with a new unit, but the new one only works with Motorola Chargers...frickin weird man...

    My girlfriend's LG charger won't work with my Triumph, but charges her Optimus V just fine. When she plugs into my Moto charger, her phone charges as well. I guess some Triumphs just have finicky micro USB ports...

    MEBLESSED Member

    i am having the same problems you guys are having with the MT, i believe Motorola made a defective device and VM and motorola knows it! if we the consumers follow-up with a class action lawsuit it would send a loud message tp the cell phone mftgs that we're not going to played any more. the consumer is the backbone of these companies. If we dont speak up, we might as well shut up!
    send your thoughts..........
  17. batvette

    batvette Well-Known Member

    Try this, As I posted in a similar thread:

    Squeeze the shell (closed) on the charger end (male) plug just a bit. Now with a magnifying glass and a sewing needle gently and slighly pry up the 2 pairs of outer tensioning devices on that charger cable male plug to restore and even augment their original spring action.
    Guarantee if your phone port is worn this will help noticeably if not fix it altogether for awhile. Then do it again as necessary.

    (PS don't forget to clean the phone port contacts removing the battery first of course)

    Now I can wiggle it around at will light stays on, and lights up first time every time when you plug it in.
    This has solved all my charging problems as you are also experiencing.

    To the person who bought a battery and charger:
    Can you charge the battery and use the phone and recharge it in your charger? If so it's probably still just a worn/dirty USB port.

    Most electronics problems are like Occam's Razor and adding the word mechanical. The simplest mechanical variable possible is usually the source of the trouble. In this case it's the USB port.

    Both the Female (phone) and Male (charger) side of this connection are experiencing wear. Thus from a troubleshooting point of view simply trying another (possibly worn) charger plug is bad logic, it may be worn too. Prying up the 4 springs (2 on each side) on the charger plug compensates for the wear on the phone plug, squeezing the plug shell ensures it has not expanded also (it's essentially a female inside of a male connector, the phone side a male inside a female)

    Most people I've seen who sent their phone in simply got a refurbished phone, you don't know what the previous user did with it, for all we know it was smuggled into prison or something. :eek: :eek: :eek:
    scary alien likes this.
  18. gpjavan

    gpjavan Member

    Mine does the same thing its not the cord as my wife has same phone and it works well. However if i shut the phone off it seems to charge just fine. Im on CM 7 it seems to be ither the drivers or the Port as it does not seem to do it on the stock rom. hope this helps.

    scary alien likes this.
  19. JokaLo

    JokaLo Well-Known Member

    I have a triumph that will charge 10% normally, the other 90% nothing. If I turn it off it will charge, only with one certain charger but 98% when its off it charges, I need a problem fixer =O I'm dyin
  20. lanceg

    lanceg Well-Known Member

    After extensive poking and examination of my charging port from both me and from two repair companies, I know why this happns (or at least why it happened on mine)

    If you look inside the port, you will see a small plastic tab. What you can't see is on one side of that tab are little copper strips. These are what make the connection to the cord that allows charging and USB connections.

    Usually, these strips are covered with a protective material, like a lacquer for electronics, that keeps them in place and protects them. The port in the Triumph does not have this layer. I don't know why it doesn't, but without that layer of protection, over time the constant friction of the cable being inserted and removed wears down those contact points, it and even catch and bend them, the can break, etc. Any of which will render the port inoperable.

    I don't know if all Triumphs are like that, but mine was, and both repair shops told me the same thing. Originally I thought it was bad soldering and micro fractures in the solder joints were the problem, but both places said the solder joints were just fine, it was the cheap port that wore out.

    Unfortunately there is no repairing the port either. So if the charging port goes, you are stuck either getting a new phone or charging your battery with an external charger.
  21. gutterrat74

    gutterrat74 Member

    this is the secound time replacing the phone because of the defective charging nport on the phone,,will they give me a different phone instead of getting the triumph and having the solder or whatever keeps breaking off inside there happen again and my years almost up
  22. chucksaysblah

    chucksaysblah Well-Known Member

  23. OverByter

    OverByter Resident Slide Rule Guru

    Problem is because of this pos phone Virgin specifically changed their TOS preventing anyone from bringing a class action, you're limited to arbitration and no award exceeding the actual cost of the phone even if they knowingly sell you a defective product.
  24. alexandrians

    alexandrians New Member

    I have the same problem! However, I was naive with my insurance and trusted RadioShack.... big mistake. They "fixed" my phone and I just got it back, but the red LED will show up on my friend's charger, not the original Triumph charger and on my Laptop so maybe it's the outlet, but I doubt it because it wasn't before I sent it in for repairs. But now I have a new battery, I'm afraid that they didn't fix my charging problems at all. :/ an Iphone is beginning to sound so much better.

Share This Page