mount as mass storageSupport


Last Updated: 2013-09-12 17:52:57
  1. admob

    admob Well-Known Member

    Finally, got mounted on my old pc laptop, took ages looking for the drivers.... So much easier tho to use my work mac.. why did HTC even think they had to do anything, it worked perfectly on ics.
  2. m3man

    m3man Member

    my response from HTC;

    My name is Jonathan and I am a Technical Support Agent for the HTC Written Team.

    I’m sorry to hear that you are experiencing difficulties with not being able to set the connection type on your phone since updating to Jelly Bean.

    I apologise but the Jelly Bean update was designed by Google automatically set the connection type dependent on what function the user was try to use, so there are no options to set the connection type.

    I am sorry if this has meant that you are no longer able to connect your device to your car stereo, but this is a feature of the update, and cannot be changed at present. I will forward your feedback on to our developers to look at for future updates.

    As a software developer, I am fully aware of using the word "feature".

    What a load of shit.
  3. ike2112

    ike2112 New Member

    Have tried 3 times, including today after there was a further update. Every time it connects, it seems to try and find 5 drivers, and fails to find 'Android Phone'... which is strange considering the last 3 phones I've had were Android - I guess it's not as generic as the name sounds.

    I've downloaded the Driverpack Solution 12.3 on your link. I searched for 'HTC One X' but it found nothing. So then I tried to connect the phone whilst the driverpack solution was open, thinking it would auto-download the driver. But it was just the normal windows attempt, with the attached result.

    Can I just downgrade back to ICS?

    Attached Files:

  4. anoniemouse

    anoniemouse Well-Known Member

    Try this with your phone connected, go to control panel & get to the device manager screen.
    Locate your phone which should be the only unknown device & click to delete it.
    Now go to control panel & select add a device, see if you can get it to pick it up properly there.
    Good luck.
  5. TarekElsakka

    TarekElsakka Well-Known Member

    I installed ARHD 18 today and the device still mounts as a Portable Media Player. I guess I could live with that.
  6. anoniemouse

    anoniemouse Well-Known Member

    At least when you are rooted there are endless possibilities, i dare say the devs will come out with a workaround in a rom at some point.
    Just got my fingers crossed a good method to root comes out that doesn't require htc dev :D
  7. jemlang

    jemlang Member

    I still can't get it to work on my Mac. I have managed to install HTC Sync but I really don't like it. Would rather go back to how it was before with ICS.
    Anyone got any tips?
  8. TarekElsakka

    TarekElsakka Well-Known Member

    It doesn't work on my Mac either. I have yet to find a solution for it.
  9. anoniemouse

    anoniemouse Well-Known Member

    Be nice for you if an app was available on the play store that gave this function back to those who want/need it

    Just found this on the play store, not sure if it will work for you or not MountUSB Widget.
    Costs
    TarekElsakka likes this.
  10. TarekElsakka

    TarekElsakka Well-Known Member

    Thank you, mate. I have tried using a similar application before on a JB ROM and it said something like "No USB Storage found". I am going to give this a shot, though, I hope they have a trial or demo version or something.
  11. anoniemouse

    anoniemouse Well-Known Member

    Hope it works for you m8, it does look promising though.
  12. siliconglen

    siliconglen Member

    1. I want to bring back the "charge only" mode. I realise this has been "disabled" but this is a fail on Google's part. The charge only mode was a simple and easy way for me to charge the phone and do nothing else. It was particularly useful if I didn't want lots of pops going on with the computer asking me what I wanted to do with the new drive I'd just mounted and it was absolutely essential in a workplace setting where it was OK to connect a phone in charge mode to a workplace computer but NOT OK to connect a phone as a disk drive for security reasons. I want Google to fix this "feature" and I also want details of any apps that can force the USB connection to charge only.

    2. I want the USB debugging permanently disabled. I go to developer options and turn them OFF and on doing so there is an option to say "Allow usb debugging Cancel OK". If i press cancel, they get turned on anyway. Surely this is a bug especially as it says this is for development purposes only. If you are simple home user trying to transfer photos to a PC, the last thing you need is an option warning you you've just turned on developer options you probably don't need.

    Fail on both counts.
  13. JamBon87

    JamBon87 Active Member

    Mine is showing up under Other, on My Computer, then as HTC One X. Soon as you click on it it comes up internal storage and then back in like it used to.

    I used to be able to just flick through pictures on there with it but now it will only detect a picture that you have already clicked on.
  14. josamaphine

    josamaphine New Member

    Please help!!

    I apoligise if this has already been raised however I am new to forums!!

    I have a HTC one X - it has just been sent back to me from having the main board & battery replaced & now I find when I plug into PC it won't mount as a desk drive. It doesn't give you the option to mount as disk drive from the settings screen & doesn't have the option from the lock screen like it used to.
    P.C doesn't recognise & when I plug in just runs HTC sync. Just want to add some tunes!!

    Cheers
  15. James_Bond

    James_Bond Well-Known Member

    There are no USB options that pop up? Not even when you pull the status bar down from the top? You said that when you plug it in it pulls up HTC Sync? So the computer does recognize the phone?

    When you plug your phone into the computer (I
    ocnbrze likes this.
  16. Silver Surfer

    Silver Surfer Well-Known Member

    If your phone is now running the Jelly Bean OS, then you will no longer have the option to mount it as a disk drive (one of the "features" of Jelly Bean).

    There may be other ways to do it but I managed to sync my iTunes music library wirelessly to my phone using a combination of Doubletwist and Airsync (very time consuming but effective).
  17. admob

    admob Well-Known Member

    read the 'mount as mass storage' thread... big debate there about what to do.. etc
  18. deltaforce

    deltaforce Well-Known Member

    Could you link it please? I suspect that I am on that thread too.

    It is extraordinarily frustrating. In my case, nothing works, No USB, No AirDroid. I just connect and restart the phone by holding power button for 10 seconds. HTC went to develop something similar to Samsung Kies or iTunes and totally fcuked it up. Thanks HTC, this will be my second and last HTC phones (because there is no support from HTC)
  19. shackfan

    shackfan Active Member

    Just come on here as first time since update that I have needed to transfer some photos to my laptop. How tf do I do it now without going via my nearly full dropbox? This is ridiculous. Is it HTCs fault? What are they doing about it? Phones should be getting easier and better to use each time an update comes through. Seriously going to have to consider Samsung, Sony or iphone next time after the problems with the Desire and now this.
  20. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    Have you tried AirDroid or MyPhoneExplorer? It will mount, you just need to give it a few minutes to install the drivers.

    It's also a Google thing, so any Samsung/Sony etc on JB and above will behave the same way.
    shackfan likes this.
  21. clio197

    clio197 Member

    I downloaded Airdroid yesterday to get some video onto my iMac and I have to say, I would happily pay for it, its that good!
  22. deltaforce

    deltaforce Well-Known Member

    What HTC is doing? Its sitting with a finger in its butt. I totally understand how frustrating it is and on the top of that due to some kind of configuration AirDroid and similar programs do not work. I reset my phone to factory setting hoping that I messed up something but no, its HTC that messed up everything in an attempt to control everything like iPhone and iTunes. The only problem is, iTunes is tons refined program (although I hate it) than their poorly written HTC Sync Manager.

    Now how do you solve this problem? Uninstall HTC Sync Manager using good uninstaller like Revo Uninstaller. Get rid of all registry entries that Revo tells you, then perform regular cleaning operations like CCleaner, PrivaZer or programs of your choice. Restart the computer.

    Install HTC Driver. Restart the computer.
    Connect your phone and wait for a while. It goes through a process of identifying device and blah blah. Depending on your computer, it could take as long as 15 minutes. At the same time, HTC Sync Manager drive may become visible and depending on your autorun settings, it may even show you HTC Sync Manager installer first screen. DO NOT CONTINUE PAST AGREEING TO THE USER AGREEMENT. At around that time, it will update your previously installed HTC drivers and then quit the installer. Restart the computer and now you should be able to use your phone as USB disk.

    This is almost what I did. Actually, I went way more than agreeing to the user agreement but by then noticed the USB disk available in Windows Explorer so quit installer in between. If you are watchful, you will avoid what I did. Just be patient. Let me know if this works for you.

    And yes, I too share your sentiment of moving to Samsung (but not iPhone). May be just Nexus 4.
  23. El Presidente

    El Presidente Beware The Milky Pirate! Moderator

    It's not a HTC thing, the SGS3, Nexus 4 etc all will not mount as USB storage either. Google changed the way internal SD Cards are handled with JellyBean.
  24. deltaforce

    deltaforce Well-Known Member

    If this is true, then I have to say Google did a poor job. If internal SD cards are not to be mounted as USB storage then there must be some other equally good option to be able to access internal SD cards. I would like to understand why even AirDroid and similar programs won't work either.
  25. shackfan

    shackfan Active Member

    Thankyou thankyou thankyou!!! Airdroid is brilliant and so easy to use:)

Share This Page