Mount The LG SPIRIT 4G on ubuntu 12.04 & 12.10Tips


  1. GameTheory

    GameTheory Well-Known Member

    This guide is for mounting your Spirit to ubuntu 12.04 & 12.10.
    I'm not responsible for your devices.

    Screenshots below

    Open terminal and copy/paste each line 1 by 1 hitting enter after each.

    Agree to any prompts you get.

    sudo add-apt-repository ppa:webupd8team/unstable
    sudo apt-get update
    sudo apt-get install go-mtpfs

    sudo apt-get install go-mtpfs-unity

    Once everything is installed:

    • Open dash and drag the mount android device app to unity launcher.
    • Now on your phone go to settings/pc connection/usb connection type/select mtp
    • Plug phone to pc and ensure mtp is on
    • Right click on unity launcher app and select mount android device and wait for notification on the upper right hand side of your screen.
    • Open nautilus and click on MyAndroid... now your in.

    *****Important*****
    -- Before mounting phone as indicated in step 4... You must unlock your phone screen or It will not mount properly.
    -- To unmount right click unity launcher app and select unmount android device... Do not eject device from nautilus it will not unmount properly.
    -- After mounting or unmounting always wait for bubble notification on the upper right hand side.
    -- The unity launcher app does not open like an app. It is only a mount point for android devices.

    **Note**
    This may work with any android phone that has MTP Media Sync

    Attached Files:


    Advertisement
  2. alfick3

    alfick3 Well-Known Member

    Thanks for this. I have it all set up now, for when I do get the Spirit.
    GameTheory likes this.
  3. alfick3

    alfick3 Well-Known Member



    Apparently, my Optimus M+ doesn't have media transfer protocol. :) When I connect it I get the options for mass storage or internet connection. I thought that maybe the mass storage option could double as mtp, but I get an error saying that no device is connected. Oh well. I can wait until I get my Spirit.
  4. GameTheory

    GameTheory Well-Known Member

    Thanks
    Once you get your Spirit, You'll be good to go. This works flawlessly with it. ;)

    Attached Files:

  5. isaacj87

    isaacj87 Well-Known Member

    Thank you for this. I was wondering why MTP wasn't working when I had mtpfs installed from the repos. Apparently, mtpfs is really unstable (useless).

    I should note that I'm running KDE, so if you're running a different DE on-top of Ubuntu, you'll probably need to use these commands to mount:

    Code:
    go-mtpfs /media/MyAndroid
    and to unmount:

    Code:
    fusermount -u /media/MyAndroid


    You don't need superuser perms for the previous commands.
    Sepero, alfick3 and GameTheory like this.
  6. GameTheory

    GameTheory Well-Known Member

    Just want to clarify...
    The repo is listed as unstable, but as long as you are using ubuntu 12.04 or 12.10 with the unity desktop, this method works flawlessly. I use this all the time.
    If you do not meet these requirements this will be unstable and probably not work.

    If you are using ubuntu 12.04 or 12.10 with a different desktop environment like KDE or LXDE and others, then use the commands listed in the post above by isaacj87... Thanks dude.
    alfick3 likes this.
  7. twogbsd

    twogbsd Well-Known Member

    And for 10.04 you do what?
    sammyz likes this.
  8. GameTheory

    GameTheory Well-Known Member

    I'm not sure if this is possible on 10.04 with any device other than the galaxy nexus. Might have to do some serious googling for that, or use ADB.

    I don't have 10.04 so I probably won't be much help. Sorry dude :(
    twogbsd likes this.
  9. twogbsd

    twogbsd Well-Known Member

    D: Guess I should upgrade soon....
  10. Scuttlebug

    Scuttlebug Active Member

    Im new to this forum..i would like to get the best out of my phone, problem is, i didnt understand anything u said! Can you put the instructions in a way an "idiot" can understand? I love these forums, keep up the good work, and thanks for helping me out!!
  11. sammyz

    sammyz LG Whiz Kid Guide

    I'm on the same boat since my windows no longer wants to boot :captain:
  12. twogbsd

    twogbsd Well-Known Member

    Don't go to 12.04... Its total crap....
  13. alfick3

    alfick3 Well-Known Member


    I'm using it on my computer. I tried to upgrade it to 12.10 and the video driver failed. Afterwards and some Google research, I figured out that there was a video driver problem. I reloaded 12.04 and have been quite happy with it. I've gotten used to the Unity desktop and like it now. I could install KDE or Gnome and do the upgrade again so I have a desktop to fall back on, but I'm content.
  14. twogbsd

    twogbsd Well-Known Member

    It was nothing but bugs bugs bugs for me... First I tried through the update-manager on 10.04, and it said it finished and that I would need to reboot, so I did, and GRUB got messed up and I couldn't select anything so I had to go off memory of what to select, and I booted back into ubuntu and it was just a blue screen with a mouse pointer... :( So, after trial and error with GRUB, I booted into windows and dl'ed the iso, burned it, booted from CD and formatted my old 10.04 partition, installed on that partition, rebooted and everything seemed fine, until xserver crashed while opening Nautilus, then xserver crashed two more times while opening Firefox. Then my wifi stopped working, then my thumbnails for pictures stopped showing, and after deleting ~/.thumbnails and installing numerous packages, they still wouldn't show up. I finally said f**k it and went back to 10.04 :)
  15. sammyz

    sammyz LG Whiz Kid Guide

  16. sammyz

    sammyz LG Whiz Kid Guide

    Woot, I fixed it :D

    config file asked for same version it was trying to install.....stupid :rolleyes:
  17. GameTheory

    GameTheory Well-Known Member

    +1
    12.04 works flawlessly for me. It's been Canonical's best release to date.

    I don't recommend 12.10 since it's a short term release thus only supported for 18 months unlike 12.04 which is a Long Term Support (LTS) good for 5 years... April 2012 to April 2017

    Unity is my favorite but KDE is great and would be my next choice.
  18. GameTheory

    GameTheory Well-Known Member

    If Grub ever gets messed up for you follow these steps....

    1. Boot from a live cd or usb flash drive and run these commands 1 by 1:
    sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update
    sudo apt-get install -y boot-repair && boot-repair


    2. Remaining in the live cd go to dash & click on Boot Repair and run the program.
    Alternatively you can open it by entering boot-repair in terminal

    3. Now reboot into your ubuntu installation

    If your using windows MBR instead of Grub, after completing the previous steps from your ubuntu installation... Run these commands 1 by 1:
    sudo apt-get install lilo
    sudo lilo -M /dev/sda mbr
    sammyz likes this.
  19. twogbsd

    twogbsd Well-Known Member

    Thank you :) I learned that though shyt loads of Googling on that fateful day. :rolleyes: Is Mint any better?
  20. GameTheory

    GameTheory Well-Known Member

    Mint is great, it's based on ubuntu but a little less resource hungry I recommend running a live usb flash to see if it plays well with your hardware. Go with Mint 14 KDE, or XFCE if your looking for speed.

    I had Mint 13 installed but no matter what distro I try over the years, I always end up back with ubuntu.
    twogbsd likes this.
  21. jvillejoe

    jvillejoe Well-Known Member

    XFCE is super fast, that's what I'm running. ;)
  22. PlayfulGod

    PlayfulGod Well-Known Member

    I run Mint14 w/ XFCE. ;) Unity can kiss my ( ! )
  23. GameTheory

    GameTheory Well-Known Member

    XFCE reminds me of Windows XP with that old style cascading menus. It's mainly for machines with old hardware that can't handle Unity lol. :p Ubuntu/Unity rules!!! :p

    I have XFCE on one of my old crappy machines lol... It's aight, nothing special. ;)
  24. PlayfulGod

    PlayfulGod Well-Known Member

    unity SUX!!! lol

    I have cairo-dock. I can never get anything gnome based to look the way I want it to. ;)

    [​IMG]
  25. PlayfulGod

    PlayfulGod Well-Known Member

    oh and I didnt have to do anything special for my devices to mount, it all just works. ;)

Share This Page