.mp3 files not playing as ringtones from system files.Support

Last Updated:

  1. CptDanger88

    CptDanger88 New Member

    I have a rooted Epic. I was trying to get into and view my system folders and write ringtones to the system media files, as well as notification tones, etc. I found File Expert, a free app in the marketplace, and was successfully able to copy ringtone and notification .mp3 files to the phones system designated files (system/media/audio/"ringtones" or "notifications"). My plan is to not have to worry about keeping these files on my SD Card, especially since my SD Card has an issue with unmounting itself, and my ringtones disappearing. I've missed a few important calls because of this, and it drives me crazy.

    The problem is, once my files were added into system directory, and I rebooted my phone, the files show up in my system ringtones when I go to change them, but will not play. The ringtones are in .mp3 format, but that was never an issue coming from the SD Card. also, all of the original ringtones (the .oog files) still play perfectly fine. Any idea as to why this is, and what I need to do to get the .mp3's to play as system ringtones?

    Screenshot of my system file with the ringtones in place.

  2. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Can't really answer why they won't play, but have you tried converting them to .ogg files?
    You can use a program like Audacity to convert them and then see if they will play properly.
  3. CptDanger88

    CptDanger88 New Member

    Good idea, thanks. I had forgotten all about Audacity. I'll try that now.
  4. CptDanger88

    CptDanger88 New Member

    Unfortunately, even after making one of my notifications in .ogg format, it will not play through the sound menu on the settings. It still plays the .ogg files that came with the phone, but not the .ogg file that I put there myself. Might it have something to do the the File Expert app being lame and free? Because I don't really want to buy the Root Explorer app if I don't have to.
  5. lunatic59

    lunatic59 Moderati ergo sum Moderator

    Might have to do with permissions. If it is important that they reside in the system folders, then root explorer may be your best bet.
    CptDanger88 likes this.
  6. CptDanger88

    CptDanger88 New Member

    Good news! It WAS the app, AND I found another free app that did the job. I removed File Expert and tried ES File Explorer and it worked beautifully. Everything is set up in my system files, and I won't be using the SD card for ringtones anymore.
  7. Thyce

    Thyce New Member

    File Expert does work. The problem with the File Expert app is that you need to set the permissions of your custom ringtones to match the stock system ringtones. I use File Expert to move all of my custom ringtones and notifications back into the system folder after system updates wipe them out. All you have to do after moving custom ringtones to the system is change the permissions of each one to: Owner=Read+Write, Group=Read, All=Read.

  8. calebgoesbig

    calebgoesbig New Member

    THANK YOU Thyce!! I had been playing with this all weekend, until I saw your reply. The permission setting was the exact thing I was missing. Now every time someone calls when I have my phone in disk drive mode over USB, hopefully my ringer won't reset to the lame standard one!
  9. Thyce

    Thyce New Member

    Here is an update on setting permissions with the File Expert app. I found when I was trying to set the permissions of all my custom ringers in an original Droid that File Expert will only update one file at a time. You need to change the permissions of one single file to: Owner=Read+Write, Group=Read, All=Read. Then you need to exit File Expert and do it again for every custom ringtone you have placed in the ringtone folder, exiting after each one. Kind of tedious if you have a lot of custom ringtones.


Share This Page