MPT Driver issue - tried all fixes...Support


  1. feelsoreal

    feelsoreal New Member

    Hello

    I flashed my phone from Orange firmware to stock firmware last weekend, and since then, I've not been able to connect my phone to my PC via USB.

    I installed Odin on the day I flashed the stock firmware, and Odin picked the phone up ok.

    I usually only connect my phone to my pc to manage files etc, and don't use Kies, although I did try to use Kies after I flashed the new firmware, to check for updates. It was then that I started to have problems.... I couldn't connect, and Kies tried to install new drivers, which failed.

    I then tried to connect to my pc in the usual way, without Kies, and my PC didn't pick my phone up. The same "installing driver device software" message came up, which again failed.

    I tried to connect to another pc, and the same happened. Kies is not installed on that pc in case that's relevant. No previous problems with my phone being recognised on that pc for file management purposes, and other phones are connecting fine.

    My phone is showing as being connected to my PC as a media device, but just not being picked up by my PC.

    I've tried the following fixes, such as:

    i) uninstalling all USB drivers, and then installing Samsung USB drivers. The same "installing driver device software" message came up, and the Samsung drivers installed fine, but the MPT drivers still failed.

    ii) updating the drivers by browsing my pc and chosing the "let me pick" option. It failed to update, and gave a code 10 error.

    ii) installing the MPT porting kit - made no difference at all.

    At first, I thought it may have something to so with Kies or Odin, but the problem must be with my phone, because the same thing is happening whatever PC I'm trying to connect to, and the other pc's don't have either of those installed.

    The firmware I flashed is the UK stock firmware; could that have affected anything on my phone itself?

    Thanks for reading. Please let me know if you have any suggestions.

    P.S. I did search before I posted, and couldn't find anything that exactly matched my problem, and seemed to be from people having a problem with Kies, which I don't think this is.

    Advertisement
    :
  2. question729

    question729 Well-Known Member

    Sorry I don't have a solution for you, but I've been experiencing the same problems with the MTP driver. My Transformer with ICS is picked up just fine. Before getting Jelly Bean with the Verizon update it worked fine, but admittedly I didn't hook up my phone via USB for a week or two before that. I could very well have lost functionality before then; who knows. I'm guessing something in the phone is not allowing the MTP process to start. I can't believe this isn't a more widespread problem.
  3. feelsoreal

    feelsoreal New Member

    Thanks - I'm glad I'm not the only one! I agree it's definitely the phone, but not sure what has happened.
  4. feelsoreal

    feelsoreal New Member

    I connected my phone via Odin (before flashing Jelly Bean 4.1.2), and the drivers installed successfully! I could access my files as usual. I tested it again when Odin was closed, and it was back to normal. Hurrah!

    I now have a different problem since updating to 4.1.2 (Harware Id not recognised), but connecting via Odin fixed the MTP issue. I now have to find a fix for the hardware id problem.
  5. question729

    question729 Well-Known Member

    I was only trying to charge my phone via USB just now, but the mtp driver actually installed this time. I haven't done anything special to the phone, but I'm glad I'm able to access the phone through my PC again. Weird problem...
Loading...

Share This Page