MTP Device driver Error (FIX)Tips


Last Updated:

  1. jsalva10

    jsalva10 Member

    Just wanna share how I'd fixed the USB issue dilemma...

    :: With the latest Kies the USB driver (v1.5.6.0) that comes with it is the culprit and we need to remove that and here's how i did it...

    1. uninstall KIES and USB driver
    2. Download latest KIES
    3. Download USB driver (v1.4.6.0) from Samsung site (sorry can't get the link up)
    4. REBOOT
    NOTE: pretty same idea from here: http://forum.xda-developers.com/showthread.php?t=1844400&page=2
    5. when PC is up (do not connect phone yet)
    6. Install KIES (Note: when almost at the end of install KIES tryin to install the new USB driver (v1.5.6.0) which we DONT want or causing the issue! BUT just ignore it...
    7. Open
    NOTE: (Unplug your Internet)
    a. Start
    b. Control Panel
    c. Uninstall Program
    d. Locate Samsung USB driver for mobile phone Highlight it and click Uninstall (you'll see this v1.5.6.0 far right)
    8. Then Install this USB version (v1.4.6.0) Get it here: Support - AT&T Cell Phones SGH-I747 | Samsung Cell Phones
    9. Open
    a. Start
    b. Computer
    c. System Files (drive: C)
    d. Program files
    e. Double click on SAMSUNG
    f. Double click on Kies
    g. Open the USB driver folder (Delete what's in that folder)
    h. Replace it with (v1.4.6.0) just drag and drop!
    10. Connect your phone bam! Enjoy!!!
    NOTE: (Now you can plug back in your internet)

    Hope this Help!!!

    Advertisement
  2. CConti

    CConti New Member

    Been there, done that. Does not resolve the issue. Tried on three seperate PCs. All have Win 7 64 bit. Wonder if i need a 32 bit PC for the MTP driver to actually work.
  3. muzician

    muzician New Member

    After hours of troubleshooting and several calls to Samsung, I finally got this to work. BTW... there is a Tier 2 tech support at Samsung but they don't tell you about it unless you ask. The Tier 1 tech support person basically said "I give up" and suggested I return the phone.

    The incredibly easy solution is this:

    1) Update your Windows Media Player to the latest version
    2) Install Kies

    According to the rep, Kies installs 2 out of the 3 drivers that it needs. It assumes that you have the latest MTP driver that is installed with WMP and does not reinstall it. WTF??? They couldn't just install the friggin' driver? I never use WMP so I never updated it from version 8. Once I updated, it worked like a charm. For good measure, I installed all the critical Windows updates.

    I'm running XP, SP3 and this solved the problem.

    Hope this helps.
    stabesh likes this.
  4. Max_Headroom

    Max_Headroom Well-Known Member

    Since getting JB my phone has connected as a media device more times than it has not, if it fails i switch it from Media Device MPT to Camera PTP and back again (in settings) and this cures it. ;)
  5. bmoliver

    bmoliver Well-Known Member

    Yep, that solution worked for me as well a few days ago. Turns out the phone was giving me that message but I was ignoring it. Once I installed Media Center 11, both Kies and the USB worked fined.
  6. cmcole101

    cmcole101 New Member

    Unfortunately none of these solutions work for me. My Galaxy Note 2 will not install MTP no matter what I do. I've uninstalled all Samsung USB Mobile Phone drivers, Kies, installed Samsung USB Mobile Phone drivers 1.4.6.0, forced those drivers to be used, reinstalled Kies, ran FixIT from Microsoft on my Windows Media Player 12, did the *#7284# USSD code and zippo...nada. MTP will NOT install on my Windows 7 Professional x64 system.

    I'm at a total loss why this can't be fixed.
  7. Heath51

    Heath51 New Member

    After a never ending search, this solved my problem. Had to reboot the PC for changes to take effect. I am running XP w/ SP3 as well. Sighs, what fun! Thanks again.
  8. wkm001

    wkm001 New Member

    On XP Pro SP3 installing Windows Media Player 11 worked for me too. I also had the Samsung USB drivers installed. Honestly the USB drivers should require WMP 11 before it lets you install them.
  9. science_junior

    science_junior New Member

    thank you sir very very much
    you did realy save me.i've tried all tricks i've already found ,still nothing worked for me
    thank you for your solution "tout est parfait"
  10. Papakus

    Papakus New Member

    Thank you, Thank you!!! jsalva10 solution worked for me. The USB Driver v1.4.6.0 was the saving grace. Thank you so very much. I just got a Galaxy Tab Pro and USB was not a problem for 8 days, then suddenly yesterday it would not connect. Spent all night trying to figure it out including rolling back registries and anything thing else with no solution. You would think with this type of problem going on so long and the infinite number of solutions available that something would be done. It is indeed very frustrating. Thanks again!
    Mikestony likes this.
  11. biz_kid1

    biz_kid1 Member

    I just did this, but seems to be working for me, too. This driver caused me all kinds of issues, so THANK YOU! I'm running Windows 7 Home Premium 64-bit, and am on WMP 12, so don't think I needed to update that one, but definitely installing Kies on the PC is a better idea!

    You can download Kies here!
  12. Camedia

    Camedia New Member

    The solution is very easy: install Media Center and everything is ok.

Share This Page