1. Welcome to the newer, better version of Android Forums! Be sure to see the announcement and enjoy checking it out!

    Some of you have been having login issues. - Please try now. Sorry for the trouble!
  2. All attachments uploaded on the first day of this new look need to be re-uploaded, or will appear broken. All prior to that, and all going forward, should work fine. We apologize for the inconvenience!

Support MTP driver issue


  1. AndroidxGuy

    AndroidxGuy Well-Known Member

    I have been trying to connect my GS3 to my computer for 2 weeks now an have failed miserably. Every time i connect it kies starts up and the MTP drivers start installing but always fail so the phone is definitely recognized. Im using a 32GB model and interestingly enough my brothers 16GB GS3 had no issues when i hooked it up to my computer, it is recognized and the MTP drivers installed for it. I have tried uninstalling kies, samsung drivers and MTP drivers from my computer and restarting and even reset my phone only to have the same results. I already have all my apps setup and i dont want to return it unless i really have to, can anybody help me figure this out?

    Advertisement
  2. MachineGunnWilly

    MachineGunnWilly Well-Known Member

    I couldnt get mine working either...Go to settings ->Developer options -> then click USB debugging

    Worked for me
  3. AndroidxGuy

    AndroidxGuy Well-Known Member

    i have tried that along with every usb cable i have and every usb port on my pc and nothing seems to work.
  4. craighwk

    craighwk Well-Known Member

    Try using PdaNet drivers? They seem to work the best for me.
  5. AndroidxGuy

    AndroidxGuy Well-Known Member

    I'm trying to transfer files between my pc and phone not share web access.
  6. craighwk

    craighwk Well-Known Member

    Understood, but it also includes drivers to mount your phone and have it recognized. It installs two packages. The application for what you just mentioned and then the actual drivers for the phone. You can uninstall the application after its done, leaving the drivers installed.
  7. AndroidxGuy

    AndroidxGuy Well-Known Member

    That did not work either :confused:
  8. AndroidxGuy

    AndroidxGuy Well-Known Member

    Anyone else have any ideas as to what the problem might be?
  9. biggles

    biggles Active Member

    Has this problem been solved yet? I can't believe Samsung would release this phone without testing such an obviously important function. I have tried uninstalling and reinstalling both the samsung usb driver and the kies software and it fails every time.

    Also, can someone provide a link to the pdanet drivers? I do not know what this is. I urgently need to transfer files from pc to phone for my job.
  10. AndroidxGuy

    AndroidxGuy Well-Known Member

    The MTP driver issue is not entirely samsungs fault because over the past few years i have heard of this problem from different devices. For the pdanet just google it or try using kies air if possible.
  11. metnix1

    metnix1 Member

    You have to completely delete every driver you have installed thus far. If Windows tried to automatically find then driver, and its still there, even if you have updated it, you're going to be crap out of luck.

    Follow these directions to remove all Samsung Mobile drivers:
    Uninstall Drivers from Vista & Windows 7

    After you do that, restart the PC, then run the Kies troubleshoot Connection software. It will automatically install the correct drivers. Only after that is done, plug in your phone. Windows will again attempt to install the drivers, but this time it's using Samsung's drivers ONLY.
    trentini likes this.
  12. AndroidxGuy

    AndroidxGuy Well-Known Member

    Just used drivecleanup to do that automagically for me and it still crapped out. :mad: Maybe ill have to reinstall windows....


    USB drive or flash problems? How to cleanup and remove old USB storage drivers - TechSpot Forums
  13. AndroidxGuy

    AndroidxGuy Well-Known Member

    Just keep getting a damned "Code 10" error
  14. davidmanvell

    davidmanvell Well-Known Member

    Plugged my 32g in and windows 7 had no issues with it.
  15. AndroidxGuy

    AndroidxGuy Well-Known Member

    I'm jelly.... :pcguru:
  16. biggles

    biggles Active Member

    I spoke with elevated tech support at Samsung today. They currently have no solution to this problem. They have known about the problem for one week thus far. I am expecting a driver update in the future to solve it.
  17. metnix1

    metnix1 Member

  18. davoid

    davoid Well-Known Member

    I know this doesn't address the problem, but it's a solution... could you not use your free dropbox storage to transfer between phone and pc and vice versa?

    As I said, it doesn't fix the driver problem, but as you say it is urgent for your work, it would be a temporary workaround.
  19. davoid

    davoid Well-Known Member

    That's the best typo I've ever seen. I like that word. Automagically. Nice. :)
  20. AndroidxGuy

    AndroidxGuy Well-Known Member

    I dont think so since my pc is only about 3 months old and only about 6 usb devices have been connected to it. After drivecleanup they all had to reinstall the drivers again. Of course i tried my S3 first to make sure. I did read somewhere that iTunes installs some usb filters that can interfere with other usb device driver installations.


    Its not a typo, i got it from a commercial about some website that can "automagically" fill in the missing info of your music files but ill take credit if you want. :D
  21. NovaCove

    NovaCove Active Member

    same issue with my wifes 32g white s3, when plugging it up via supplied usb onto kies it just sets there saying connecting with the little circle spinning and wont connect.. connect my 32g blue in and it quickly says unsupported connection method

    usb debugging didnt work for either phone, neither did switching between kies stock drivers or samsungs verizon version

    i do get the windows autoplay popup on both phones and am able to swap files that way, just sucks cant use kies
  22. ebonybranch

    ebonybranch Well-Known Member

    I opened Kies on my four year old windoze 7 laptop a couple of days ago and it downloaded an update that replaced all the Samsung drivers. Hooked up my S3 and got the latest firmware upgrade to 4.04; no problems. Only drama I'm having at present is connecting the S3 to my MacBook. It doesn't mount as an external drive any more, I had to install something called Android Transfer, and it mounts as a camera!
  23. biggles

    biggles Active Member

    Which version of Windows 7, 32-bit or 64-bit?
  24. dfran1

    dfran1 Well-Known Member

    I cant get my 32 gig siii to work with this driver either

    I tried uninstalling rebooting and reloading the driver nothing
    I called samsung and they passed me to escalated tech support with no help and them telling me hopefully it gets fixed in a future update

    winblows 7 64bit ultimate

    now on my Mac it works absolutely fine with kies, actually perfect.
  25. biggles

    biggles Active Member

    For the people who got it to work perhaps they are using 32-bit Windows 7. I am on 64-bit win7.

Share This Page