MTP driver issueSupport

Last Updated:

  1. dwjrdto2000

    dwjrdto2000 New Member

    I too had this problem; Winxp, SP3, ATT Galaxy S3; Kies had worked the first time I tried it, then after some updates quit working; Tried all the usual things people have suggested like uninstalling, reinstalling, rebooting, turning phone off and back on, changing cables, changing ports, nothing worked. Finally booted pc in safe mode to see if I could find the driver that was causing issues, couldn't find any driver at all for the phone under system, device manager. rebooted pc again into normal mode and tried again just for kicks, it then recognized my phone as new software and installed all the drivers and everything works again. So only thing different I did was boot into safe mode, and then reboot into regular mode.

  2. laptopquestion

    laptopquestion Well-Known Member

    Don't know if this will help anyone, but I finally got the USB drivers working on Windows 7 64 bit for my Samsung Galaxy 3.

    For me, it boiled down to getting a clean install of the USB drivers and using the supplied USB cable.

    In the end however, there are no guarantees since the USB connection with this phone can be particularly finicky. With my luck I will be back to square one tomorrow ;)

    1) [Win 7] Boot into Windows 7 safe mode and delete and previous SAMSUNG USB drivers without phone attached

    Start -> Control Panel -> Uninstall a program
    SAMSUNG USB Driver for Mobile Phones

    2) [Win 7] Reboot PC

    3) [Win 7] Remove any previous Samsung Kies or Allshare software

    4) [Win 7] Clean the registry using Auslogics Free Registry Cleaner

    5) [Win 7] Re-install the latest Samsung USB driver (

    This is the latest version without having to install Samsung Kies

    6) [Galaxy S3] Enable USB debugging

    Menu -> Settings -> Developer options -> USB debugging option checked

    7) [Galaxy S3] Turn off phone

    8) [Win 7/Galaxy S3] Hook up USB cable (had better luck with one shipped with phone)

    9) [Galaxy S3] Turn on phone

    Had the following installed (Ready to use) on Win 7:

    SAMSUNG Mobile USB Composite Device
    SAMSUNG Mobile USB Modem
    SAMSUNG Android ADB interface

    10) [Win 7] See the following SCH-I535 directories on my Windows 7 64-bit desktop:

  3. Zoandroid

    Zoandroid Well-Known Member

    Also remember that you can unmount the S3's external SD card and plug that into your PC to transfer files, if all else fails USB-wise.
  4. AndroidxGuy

    AndroidxGuy Well-Known Member

    Luckily my pc has a microSD card slot but most dont have it unless they have an adaptor. What i still fail to understand is why my 32GB S3 doesnt connect properly with my pc and my brothers 16GB S3 works every time. Anyways having to remove the SD card every time to transfer a file is a pain.
  5. Zoandroid

    Zoandroid Well-Known Member

    There are other non-USB options that will work too. I don't use cloud storage, so I won't mention stuff like Dropbox. But if the file is small, you can email it to yourself ( I do that a lot), or you could look into apps like CheetahSync, which will use your home wifi to synchronize files between a PC and Android device. ESFile Explorer also has some LAN access options that can let you transfer PC files to your S3. But you can get into "permissions" issues if dealing with Windows 7.

    I wasn't able to get my 16GB S3 to reliably connect to my Win7x64 PC at first, until I remembered I had not yet installed the USB driver (downloadable from the Samsung support site). Once I installed that driver, I can access the phone no problem. And even though it doesn't offer "USB Mass Storage" connection as an option, it DOES allow me to copy every non-system file from the S3's internal memory (Phone), or SD Card (Card).
  6. davidmanvell

    davidmanvell Well-Known Member

    I received a notification today on my Windows 7 X64 PC that a new version of the Samsung MTP driver is available. Got it installed. Found out by the way that you have to install it with the phone plugged in or windows update gives you an error.

    It is according to windows a Samsung driver. dated 5/11/2012. Version 2.9.319.511.

    I am on Verizon if that makes a difference. it says my phone is a SCH-I535.
  7. Zoandroid

    Zoandroid Well-Known Member

    So is it working OK with the updated MTP driver?
  8. davidmanvell

    davidmanvell Well-Known Member

    I had no issues with it with the original or the new driver. Never not worked for me.
    Zoandroid likes this.
  9. skramblr

    skramblr Well-Known Member

    On my system - The MTP driver from Samsung/Kies does not work. I had spotted the 'updated' driver on Windows Update and let it install it. Still no difference. And I have drive installing the driver with and without the phone connected. It just doesn't work.

    I tried using the S3 on my Laptop as well. Same issue. MTP driver fails install. So it seems to be a Phone problem.
  10. Zoandroid

    Zoandroid Well-Known Member

    If you have not yet tried it, reboot the phone. Sometimes that helps with this kind of issue. Make sure you have USB debugging turned on in the phone's settings, and use the cable that shipped with the S3. Also, plug the cable directly into your PC's USB port, don't use a hub.
  11. AndroidxGuy

    AndroidxGuy Well-Known Member

    Just spent another hour watching the MTP driver installation fail miserably. Sigh.......
  12. laptopquestion

    laptopquestion Well-Known Member

    In the end, Samsung's MTP implementation is a POS for the Galaxy S3. Never ever had a problem with with my Omnia 2.

    Got it to work a couple of times, then it just degrades to driver issues again.

    Kies no better....

    Sad when you have to resort to third party solutions to get things transferred :(
  13. nestorrg

    nestorrg New Member

    Hello guys.
    I got my SG3 yesterday and I have the same issue. I work on WXP SP3. I tried all procedures I found on the internet but I failed. I hoped that 'laptopquestion's metohd would work but...
    Maybe it's time to move to W7 and see what happens...
    Thanx for your support.
  14. dfran1

    dfran1 Well-Known Member

    I went into safe mode win 7 ultimate 64 bit
    And the driver seemed to load fine according to device manager
    But when I came out of safe into normal back to the same problem
  15. Zoandroid

    Zoandroid Well-Known Member

    These are more long shots, but it looks like some of you are at that stage to solve this. You may want to try checking to see if you have the latest chipset/USB drivers installed for your motherboard. Those of you who built their own PC will be familiar. For a retail PC you may be at the mercy of the support website for obtaining those drivers. Personally, I've hated USB since day one because it is so flaky. Always causing problems. This may be one solution. Plugging directly into a motherboard USB jack (not front, top case mounted or any kind of hub) on the back of the PC is often another solution. If your Windows OS installation is getting long in the tooth (over 1 year) a new HD format/clean install may also help. "Windows rots" over time.
  16. AndroidxGuy

    AndroidxGuy Well-Known Member

    What we need is for the almighty MTP driver gods to grant us out wish of connecting out S3's to out computers. trolololol
  17. Zoandroid

    Zoandroid Well-Known Member

    Or....for the Google gods not to have made the asinine decision to opt out of USB Mass Storage mode support when they developed ICS. I never had any kind of file access problems (aside from USB issues in general) on any Android devices until I started using ICS.
  18. AndroidxGuy

    AndroidxGuy Well-Known Member

    Same here, i have over a dozen USB devices on my desk right now including an old sony MTP music player and they all connect just fine except my S3. Even my brothers S3 connects to my computer and that ticks me off :mad:. I've tried just about everything in every forum everywhere and nothing works. I did try to connect it to my old laptop that i upgraded to a free win7 copy i got and it worked. The problem with that is that the laptop takes 10 minutes just to startup :p and is all but unusable.
  19. ebonybranch

    ebonybranch Well-Known Member

    Does anyone know whether jelly bean is expected to continue the trend? It's rapidly becoming a deal-breaker for me. My S2 had no such problems.
  20. Zoandroid

    Zoandroid Well-Known Member

    Well, if you finally got the S3 to connect and work on the laptop, that seems to rule out the S3 hardware as the culprit. Sorry to say, that only seems to leave your PC's Windows installation as the remaining suspect. You might need to reinstall Windows to fix it.
  21. Zoandroid

    Zoandroid Well-Known Member

    When I first started researching this USB Mass Storage (UMS) issue after flashing an ICS ROM on my tablet and encountering it, (the internet is FULL of people complaining about it) I ran across a support forum somewhere in which a Samsung tech rep was explaining the reason that ICS developers no longer wanted to support USM, and wanted to adopt the Windows Media Transfer (MTP) and Picture Transfer (PTP) protocols instead. In the post he explained the end goal was that ALL Android devices no longer even HAVE a removable SD card, and only have internal memory. He claimed it would make it easier for developers to program across the many different devices this way. Personally, I don't buy that BS.

    Abandoning SD Cards is a huge leap backwards in technology, taking us back to when the initial smartphones had only what the cell carriers deemed suitable to put on them. To me it looks very much more like the cell carriers being in total control of smartphones and their software than a move to help app developers. And of course it would also be somewhat of a cash cow. Look at the S3 as a prime example. If you want the added 16GB of internal memory (over the 16GB model) to get 32GB fine, but it costs you $100. That's easily 3X the price of even a Class 10 16GB SD card. By using SD Cards, we can add as much as 64GB of memory. If the phone had no SD card, we would be stuck with however much internal memory it contained.

    So if all this is any indication of where the technology is headed, I think the answer is obvious. You won't likely be seeing UMS ever brought back in a future Android OS version.

    Now, there have been some devs, on XDA for sure and perhaps others, who have been trying to write an app to re-enable UMS for ICS, but the results have been very hit or miss. I know it doesn't work on my tablet. I haven't tried it on my VZW S3 yet, because the file transfer gods have smiled upon me and allowed me to transfer both "Phone" and "Card" files to my PC using MTP. So I'm satisfied with that. On the tablet I use Cheetah Sync to work around the problem.
  22. mark847

    mark847 New Member

    I think some of the Galaxy S3's might have a hardware problem.
    I have two(2) 32GB S3's. One works with MTP, and one does not work.
    I have tried swapping the external memory, still does not work. I have tried with no external memory, still does not work. Tried swapping the machine, second one still does not work.

    Then today, first one stops working until I load new Samsung S3 drivers. Still only one S3 is working. All of this on Windows XP.

  23. Zoandroid

    Zoandroid Well-Known Member

    After having USB file transfer working nicely with the Samsung USB driver last weekend, I ran into problems again last night. The S3 kept dropping the USB connection, even using the provided USB cable. I had to reboot both my Win7 PC and the S3 (both of which had just recently been rebooted that day) and then it started working. I later had the same problems trying to copy files to the PC from my ICS tablet, and ended up having to use the Samsung USB cable to make it work. I'm now suspecting my other USB cable is intermittently bad.
  24. EarlyMon

    EarlyMon The PearlyMon Moderator

    A wifi alternative until this is sorted might be SwiFTP, set it to mount / instead of the /sdcard default if you want to get to everything. A nice app with a good interface and easy to use is Airdroid.

    Not the speed of a wire, but may help until this is all sorted out for everyone.
  25. skramblr

    skramblr Well-Known Member

    Played with it some more today. All I've figured out is if I boot into safe mode, the installing drivers box pops up and it installs the MTP driver successfully. Then I do a normal reboot and the installing drivers box pops up again, but the MTP driver install falls. Now I'm puzzled.

Share This Page