1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

MTP driver issueSupport


  1. nestorrg

    nestorrg New Member

    I finally moved from WXP to W7 and I got my S3 to work in USB mode.
  2. laptopquestion

    laptopquestion Well-Known Member

    Looks like the Samsung S3 is *really* picky about the micro usb cable used........

    As it turns out in my case, I tried a couple, including the Samsung one supplied with the phone.......

    Got it to connect once fine, then all kinds of issues (e.g. code 43, device not present, half installed devices).

    Then on a whim, I tried some *more* micro usb cables I had around......

    I finally found one that would consistently work (no, not the one supplied by Samsung) with the Developer Options USB Debugging mode turned on.

    I could then toggle between Media device (MTP) and Camera (PTP) mode by dropping down the notification bar (that had the USB icon on it).

    As I switched modes, different Windows 7 (64 bit in my case) drivers installed:

    Media Device (MTP)
    SCH-I535
    SAMSUNG Mobile USB Modem
    SAMSUNG Andriod ADB Interface

    Camera (PTP)
    SAMSUNG Mobile USB Composite Device
    SCH-I535
    SAMSUNG Android ADB Interface

    This is the *actual* USB device (often marked as unrecognized with warning triangle):
    SAMSUNG Mobile USB Composite Device

    Also attached some screen shots.....

    BTW, if your still having problems, Air Droid (via WIFI) might be a viable alternative. That was what I was using until I found the magic cable :)

    For reference, I am using a Pebble Blue 32 GB Samsung Galaxy S3 and Windows 7 Ultimate 64-bit on a HP i7 desktop.

    Attached Files:

  3. laptopquestion

    laptopquestion Well-Known Member

    There is still hope.... At least in my case, it was finding a good cable, i.e. one that the Galaxy S3 actually liked :pound: In my case it was the cable that I used for my Logitech Harmony 600 remote.... Go figure.
  4. AndroidxGuy

    AndroidxGuy Well-Known Member

    How did you get it to work in USB mode?
  5. Zoandroid

    Zoandroid Well-Known Member

    Of course we wouldn't be dealing with all this if Google had just continued to support USB Mass Storage Mode in ICS.
  6. vzwuser76

    vzwuser76 Well-Known Member

    That's what really puzzles me about this. They apparently made the switch to make it easier for the software writers. So they made it easier for the guys working on it, but more difficult for the end users, you know, the ones who paid MONEY for the phones!:mad:
  7. Zoandroid

    Zoandroid Well-Known Member

    I suspect the "real" motive here in stripping the most commonly used USB connection method had more to do with cell carrier pressure (and probably money........) to work toward eliminating the free tethering many folks are known to do with rooted phones. According to things I have read, they ultimately plan to eliminate the USB connection entirely, as well as eliminating SD Cards, on future smartphones. I think it is about regaining ultimate control over what we can do with the phones, like it began decades ago. Only being able to run whatever apps THEY provide, and stream whatever media through only THEM (something like iTunes,........but for an added price). Caring about customers was never in the equation.
  8. EarlyMon

    EarlyMon The PearlyMon Moderator

    That seems like a stretch, just my opinion. The claimed advantage of MTP is that two devices, phone and PC, can access the storage at the same time and it eliminates corruption caused by not properly ejecting/unmounting before pulling the cable. (Those have been common complaints here for two years.) As far as tethering, a great many do that via Bluetooth or wifi, so these changes won't stop them.

    In any case, I agree, MTP has caused a lot of trouble and Samsung doesn't have a good track record with it.

    If you don't mind using a command line interface, adb ought to remain a possibility. This is for an HTC, so the /sdcard mount point needs confirming but -

    http://androidforums.com/evo-4g-lte-all-things-root/567529-how-make-full-sd-card-backup-via-usb.html

    PS - agree, removing the sd card is all about them, not us.
    Zoandroid likes this.
  9. Zoandroid

    Zoandroid Well-Known Member

    Thanks, Earlymon. I had not considered the other connection options for tethering. The problem for some in using ADB seems to me that it isn't as user friendly as the other ways to accomplish the same goal. Someone should make a GUI for PCs that handles the command line interface in the background. That might take the stigma off using it. One of the easiest ways around the USB connection for me is to use a wifi app like Cheetah Sync. It works well, and also is able to determine which files are unchanged since last copied, so it can skip those if they still reside in the target folder, speeding up the operation nicely.
    EarlyMon likes this.
  10. Zoandroid

    Zoandroid Well-Known Member

    So, after the above dialog I bought a tune I wanted on my S3, and downloaded it to my PC (couldn't download it to the phone for some reason). I then went through 7 levels of hell trying to transfer this simple 10MB MP3 file from my PC to my S3. The USB connection, with the OEM Samsung cable, which has been working flawlessly up until now, decided it wanted to keep dropping out. I could NOT get the file to copy from the PC. I finally, in desperation, zipped it and emailed to myself.

    THEN, I went through 7 MORE levels of hell trying to get the file to unzip and go where I wanted it to be, on the REAL SD card. This inane practice of naming an Android device's INTERNAL memory "sdcard" causes no end of grief! Apps want to store things there by default which were clearly meant to go on the REAL SD Card. So for the apps that do allow changing the target location, that must be done when setting up the app. But most apps I use do not have that feature, so one must move the file into the proper position on the real SD card, lest they fill up the internal memory with downloads, attachments, extracted files, etc.

    The aforementioned information I had read, which talked of the intent of the eventual abandoning of real SD cards, said that this naming of the internal memory "sdcard" is a step in that direction, so that apps which WILL EXPECT there to be an external SD card will simply be directed to (the sometimes measly amount of) internal memory provided by the device manufacturer.
  11. Zoandroid

    Zoandroid Well-Known Member

    OK, after ranting above (thanks for enduring) :) I have discovered that apparently the USB port I have relied upon since I built this PC over 2 years ago is suddenly defective. If I apply slight lateral pressure in any direction on the cord plug while in this port, the PC will intermittently engage and disengage the connection. This port is in a bank of 4 ports. I've kept the other 3 covered with port dust covers I got online. So when I moved to an adjacent port, the S3 instantly settled down and allowed me to copy the same music file over to it very quickly.

    I've seen bad cables before, but other than physically damaged ports from cables being yanked sideways from tripping on them, etc. on some PCs I have repaired I am unaccustomed to seeing an apparently pristine port suddenly get intermittent or fail. However, I offer this unexpected discovery as a possible cause for some of the unexplained connection problems others have posted about.

    When in doubt, connect directly to the motherboard ports. But testing had revealed this port seemed reliable with all my earlier devices, and indeed had pretty much worked fine with the S3 until now. I'll bet the suspected bad cable I recently posted is in fact OK, and it was the beginning of this port failing. Yep.... I just tested that cable again in this different port and it works just fine. I am noticing there is slightly more resistance plugging into this port, probably because it had not been used yet.

    I hope this info helps someone else who has trouble with USB connections on their S3. :)
    EarlyMon likes this.
  12. laptopquestion

    laptopquestion Well-Known Member

    In my case, it was *definitely* related to the resistance I had on the *phone* end.... My logitech cable was a lot more snug that the others I tried (including the samsung one). In fact, it felt like it almost snapped in when plugged into the phone. This cable has subsequently worked on 2 separate desktops and one laptop where the previous cables didn't, including multiple ports.

    That said, I have never had a usb device be so temperamental.
  13. Zoandroid

    Zoandroid Well-Known Member

    Personally, "I never met a USB device I liked". I've hated the technology since its inception, because it has always been flaky here. I'll be glad when something that actually is reliable finally replaces it. I suspect it will be wireless when it does. Over the years I've built several PCs with various motherboards which sometimes had a tendency to not recognize USB peripherals as Windows boots, requiring me to have to toggle both their USB cable connection AND their power connection to get them "detected". Luckily Windows 7 seems a little better at USB peripheral detection booting than Windows XP had always been. I suppose it has something to do with the peripherals themselves, as it is usually the same ones that fail to detect over the years as I upgrade the PC hardware while keeping the peripherals.

    Edit - In this post I had originally said only the Samsung cable had the little retention teeth on the bottom of the micro USB plug. I was mistaken. All the micro USB cables I own have them too. I guess I hadn't noticed before.
  14. laptopquestion

    laptopquestion Well-Known Member

    Personally never had a USB issue until this phone.........

    Never had a problem with the connection, just the throughput.

    USB, firewire, eSata, USB 3.x......

    The micro USB worked flawlessly on my Samsung Omnia 2 (WM 6.5).

    In the end, I just have a connection issue (based on cable) with my S3, not a charging issue (any cable will work).

    Ultimately, I suspect that the S3 has a marginal micro USB connector.
  15. Zoandroid

    Zoandroid Well-Known Member

    That's very possible. And I actually saw a Youtube video once of a guy "snugging up" his micro USB port's metal shield on an LG Ally. They were known to loosen up over time. If you are brave and have the tools for the task, you might try doing that to see if it helps. But in the case with the Ally, the plug would visibly wobble in the jack. If your S3 isn't doing that, it might be something else. Maybe a cold or cracked solder joint on one of its pins. Or maybe just a defective contact within the jack.
  16. EarlyMon

    EarlyMon The PearlyMon Moderator

    No clue about the Sammy, but some Android phones are known to not work consistently in USB 3.0 ports.

    Just a suggestion.
  17. laptopquestion

    laptopquestion Well-Known Member


    In my case USB 2.0/3.0 wasn't an issue..... The cable was :(, or should I say the S3 port...
    EarlyMon likes this.
  18. EarlyMon

    EarlyMon The PearlyMon Moderator

    Yep, I did notice that as well. :(

    Hopefully someone with an SGS3 will notice and chime in here - almost ready to suggest this needs its own thread for feedback on the USB connector - but anyways - if a snug cable does the job, then the ones sold by monoprice.com just might do the trick.

    If unfamiliar, monoprice.com seemed to make its name for high-quality, mega-inexpensive cables back in the early-adoption days of HDTV.

    And you may have inadvertently explained something a lot of us have been trying to figure out - why the MHL/HDMI adapter sold there, completely standard, doesn't work with the SGS3. People are claiming pinout differences, but that is a loose connector, unlike the rest of their gear.

    Again - just trying to brainstorm, hope it helps somewhat.

    PS - I just bought a brace of them (can always use USB cables) within the last month, so I know that their current stock fits quite snug - more snug that HTC cables, and those are notoriously snug.
  19. jfunk

    jfunk Well-Known Member

    Obviously this is frustrating because of the problems you guys are experiencing, but this isn't really an issue caused by the MTP decision. MTP works just fine, there just appears to be some flakiness with either the physical connector Samsung used here or the driver software.

    That being said, I personally couldn't be happier about the MTP decision. Partitioned app storage space was a PAIN that I am thrilled to be done with. After constantly having to clear my texts and app storage despite having gigs of unused storage on my original Incredible,this to me is well worth it.
  20. Zoandroid

    Zoandroid Well-Known Member

    It does appear now that when all the necessary drivers are working and there is not a hardware issue and it is the 4th Thursday of the Lunar Equinox that transferring "any" files by MTP and PTP seems to work OK.

    I agree that having an EXT partition back when Android OS began was a nuisance, but once Froyo came along that was no longer required. I was quite happy with the way UMS worked, and see no reason to abandon it. Judging by the dialog (read 'complaints') about it all over the net I think I am in good company there. But at the end of the day, as long as I am not being 'prohibited' from copying my own creation content files between my smartphone and PCs I am satisfied.
  21. AndroidxGuy

    AndroidxGuy Well-Known Member

    I second that motion! Just got my S3 to install the MTP driver and transferred over a video. Knowing it was too good to be true i decided to disconnect it and to my dismay the results were not repeatable. :mad:
  22. Zoandroid

    Zoandroid Well-Known Member

    The second of the one-two punch that had been causing my problems is that I have now verified the specific USB cable I had been using for both Droid X my phone and tablet is in fact defective. Saturday night I ran into an inability to copy files again, whole using the different USB port on my PC, so I set the cable I had relied upon aside and used only the cable that came with my S3 (because it is my newest cable). No problem after that copying anything I wanted, to or from the S3 or my ICS tablet.

    Funny how a cable can seem to be reliable for months and then suddenly just stop being reliable, while sitting on a desk. It's not like it sees any kind of stress. So it was probably poorly made from the start, and a time bomb waiting to happen.

    This info may come in handy for those seeking solutions in the future - when the cable decided to act up, what would happen is that it would copy a folder from my phone or tablet to my PC, but none of the folder's contents. From Windows standpoint, the copy was simply 'finished'. No error or anything. It just did not display the "file copy" popup window for more than an instant, where normally it would show the files copying and list an estimated time to completion in Win7. The folders I was copying varied from 500MB to 2GB in content.
    EarlyMon likes this.
  23. m3talc0re

    m3talc0re New Member

    I came across this thread in a google search trying to figure out wtf was wrong with my phone. I think I've found a solution. I couldn't get USB to work at all for my PC (running Win7 64bit). Finally figured out to install this:

    Media Transfer Protocol Porting Kit
    http ://www. microsoft. com/en-us/download/details.aspx?id=19153

    After installed and restarting, I hook up my phone, the USB option actually comes up on my phone and windows actually recognizes it and lets me transfer files and all. I actually registered here just to add this XD Hope this helps someone!

    Edit: Okay, I can't post the url thanks to anti-spam crap -_- Just remove the spaces... Someone else wanna post the actual link or maybe a mod fix my post to display it?
  24. Zoandroid

    Zoandroid Well-Known Member

    This is interesting. I went there to check it out, and found this listed in the specifications. There is no mention of Windows 7??

    System requirements

    Supported operating systems: Windows Vista, Windows XP
    Windows XP or Windows Vista, Visual Studio 2005 SP1


    Also, the description of what this does sounds more like a software developer kit than any kind of update to make Win7 properly deal with MTP. But if you got it to work, more power to it! I did look around on the download site, but did not find a version recommended for Win7.


    For me, once I made sure my USB cable is good, it seems to be all about having the right USB driver installed for the device I am connecting to my Win7x64 PC.
  25. biggles

    biggles Active Member

    I went to this link and tried to download and install. It asked to run a validation tool. Then a window popped up saying, "This version of the Windows Genuine Advantage validation tool is no longer supported. Please download the newest version and ensure that your system clock is accurate."

    So, it is not possible to complete the install.
Loading...

Share This Page