MTP not workingSupport


Last Updated:

  1. in2uition

    in2uition Well-Known Member This Topic's Starter

    Joined:
    Aug 13, 2010
    Messages:
    443
    Likes Received:
    214
    I don't know if anyone else is having an issue with this as well, but whenever I plug my tablet to my PC the MTP drivers are not loading. Instead I get the ADB and fastboot drivers to load instead. On my GNex I resolved this by installing Samsung drivers, but I can't find any specifically for the Nexus 10.

    Any suggestions?
     

    Advertisement
  2. Atma

    Atma Well-Known Member

    Joined:
    Dec 26, 2011
    Messages:
    6,069
    Likes Received:
    2,900
    Try looking in your device manager for windows. If there is an exclamation point beside one try telling it to update or search for drivers. Mine worked the first time with the Samsung drivers I already had but I had to do a lot to get adb and fast boot working. Search for Samsung driver for mobile devices if you need it.
     
  3. in2uition

    in2uition Well-Known Member This Topic's Starter

    Joined:
    Aug 13, 2010
    Messages:
    443
    Likes Received:
    214
    No exclamation point shows up in Device Manager. Once I connect the tablet is automatically loads the ADB drivers. I'll give the Samsung mobile device drivers a try tho.
     
  4. Atma

    Atma Well-Known Member

    Joined:
    Dec 26, 2011
    Messages:
    6,069
    Likes Received:
    2,900
    Try checking usb debugging if you haven't already.
     
  5. chiph411

    chiph411 Well-Known Member

    Joined:
    Dec 10, 2011
    Messages:
    67
    Likes Received:
    38
    I must be stupid as I cannot find Usb debugging on my Nexus 10. There are no "Developer Options " in Settings:confused:
     
  6. Droid_Junky

    Droid_Junky Well-Known Member

    Joined:
    Nov 6, 2009
    Messages:
    317
    Likes Received:
    91
    I read that you have to rapidly tap "about tablet" to enable developer options.
     
    chiph411 likes this.
  7. bd177

    bd177 Member

    Joined:
    Apr 16, 2012
    Messages:
    12
    Likes Received:
    5
    You have to go into "About tablet" then tap "Build number" repeatedly.
     
    djdecibal, chiph411 and Atma like this.
  8. Atma

    Atma Well-Known Member

    Joined:
    Dec 26, 2011
    Messages:
    6,069
    Likes Received:
    2,900
    You're not stupid. That was driving me nuts trying to find it. :D

    Do like BD177 said and it will show up.
     
    chiph411 likes this.
  9. in2uition

    in2uition Well-Known Member This Topic's Starter

    Joined:
    Aug 13, 2010
    Messages:
    443
    Likes Received:
    214
    lol yea its a bit odd that they hide the option like that. Anyways, I tired USB debugging and still no luck. Guess I'm just stuck using Airdroid to transfer files. :/
     
  10. Atma

    Atma Well-Known Member

    Joined:
    Dec 26, 2011
    Messages:
    6,069
    Likes Received:
    2,900

    In2uitiv, try these drivers and see if it helps.
     
    in2uition likes this.
  11. in2uition

    in2uition Well-Known Member This Topic's Starter

    Joined:
    Aug 13, 2010
    Messages:
    443
    Likes Received:
    214
    I figured out what my issue was. The USB drivers from the Android SDK were preventing the MTP connection. I uninstalled these drivers, connected the tablet and now the MTP connection works.

    I really appreciate the link, the drivers from that source allows MTP to work, along with the ADB and bootloader interface.
     
    Atma likes this.
  12. djdecibal

    djdecibal New Member

    Joined:
    Dec 29, 2013
    Messages:
    1
    Likes Received:
    0
    i've always thought of myself as better than most with pc's but behold, the nexus gave me trouble. thank you for the thread. i needed to go to "system settings", "about tablet" then tap on "build number" a number of times before i was told i had opened "developer options." this is above the "about tablet." from there, click on "usb debugging" so it IS checked. do this while the tablet is connected and it should automatically begin checking drivers and correct itself. thanks again bd177 and everyone else.
     

Share This Page

Loading...