1. Introducing Channels - a new way to chat with other Android users!
    Dismiss Notice

Music player won't stop starting on it's ownSupport


Last Updated:

  1. Davii

    Davii Member This Topic's Starter

    Joined:
    Apr 17, 2010
    Messages:
    13
    Likes Received:
    0
    Hey all,

    I use the bluetooth audio in my truck on my drive to and from every work every day with Iheartradio on. Every time I receive a call when I hang up my phone automatically starts the music player and just starts playing songs.

    It's extremely annoying. I even deleted all my music off the phone hoping this would stop it, and now it just plays ring tones. I've used an app killer, etc. and it still does it.

    Please help me make the music player stop starting whenever the hell it wants too!
     

    Advertisement
  2. treborcj

    treborcj Well-Known Member

    Joined:
    Dec 11, 2009
    Messages:
    646
    Likes Received:
    33
    Is this the music player that came with the phone, if not then uninstall the app. If it is then I would try a factory reset.
     
  3. SeanFL

    SeanFL Member

    Joined:
    Nov 25, 2009
    Messages:
    16
    Likes Received:
    1
    I have bluetooth in the car and have the exact same issue with the player. Then when I get out of the car, it sometimes keeps playing through the speaker of the phone.

    I wish there was a way to turn off auto-play when it connects with a bluetooth audio player.


    Sean
     
  4. Davii

    Davii Member This Topic's Starter

    Joined:
    Apr 17, 2010
    Messages:
    13
    Likes Received:
    0
    It's the stock music player. This is the second Hero i've had with the same issue and I have reset to factory settings and still no change.

    For some reason it defaults to automatically use the music player for something when I hook up bluetooth audio.
     
  5. DFRESH

    DFRESH Well-Known Member

    Joined:
    Dec 26, 2009
    Messages:
    559
    Likes Received:
    39
    never had that problem...... odd..
     
  6. dpeeps74

    dpeeps74 Well-Known Member

    Joined:
    Dec 18, 2009
    Messages:
    138
    Likes Received:
    5
    i had a similar problem when using the cube? music player (i dunno, it has the little 3 like cubed?). anyways, if i got a call while listening to music with it, it would end up popping up the native music player when the call ended. Also, if i pressed the button on my wired htc headset while listening to music through it, it would bring up the native music player. i haven't looked because i just stopped using other players other than pandora and last.fm but perhaps if in the application manager you can "clear defaults" for the music player? sort of the same way you do for Sense to reprogram what "home" is. Like i said i just stopped using other players, but that's the only thought of something sort of simple and straight forward that comes to mind.

    nope, doesn't look like you can clear defaults for the music application..hmm that's all i got.
     
  7. joschell

    joschell New Member

    Joined:
    Apr 18, 2010
    Messages:
    4
    Likes Received:
    0
    I have experienced the same problem with the default media player. Recently, Google Listen joined the party and auto played when it connected to my car stereo. I am happy with Google Listen doing this, but I don't use the base media player for anything and would like it to stop playing ringtones when I connect.

    Any help would be greatly appreciated.

    This was a problem before AND after the 2.1 upgrade.

    Thanks!
     
  8. physans

    physans New Member

    Joined:
    Jun 24, 2010
    Messages:
    4
    Likes Received:
    0
    Same problem with my Hero 1.5, my Hero 2.1 custom rom, my Hero 2.1 official, and now my Evo 2.1...
    can't shake this problem... damn bluetooth auto play!

    When it connects to my car (which has bluetooth streaming audio), it just starts playing mp3 files. I want to use pandora / slacker radio, but even if I bear through the horrible mp3 playing, and start pandora, they both play at once! the only way to stop it is to go into the music app and hit "pause"

    There is no option to disable the auto-play upon bluetooth audio connection feature. :( :( :(

    Bad android music app!
     
  9. gubatron

    gubatron Member

    Joined:
    Jun 5, 2010
    Messages:
    13
    Likes Received:
    0
    Everytime I hook up my regular 3.5mm jack headsets it will start playing.
    Its extremely annoying if you started another app like pandora because you end up having 2 audio streams. It sucks the most when you hook up the phone to the car which is also dangerous if you don't have a co-pilot to solve the issue while you drive.

    I'm running 2.1 on a Motorola Droid (verizon)
     
  10. Kelmar

    Kelmar Done by choice VIP Member

    Joined:
    Nov 28, 2009
    Messages:
    11,815
    Likes Received:
    4,750
    ^ Welcome aboard gubatron!

    I'm not sure what to suggest as this portion of the forum is used by those who own the Sprint Hero. Try posting your question/concern HERE and see if they can help you out more than us Hero users can :)
     
  11. getsome831

    getsome831 New Member

    Joined:
    Sep 9, 2011
    Messages:
    4
    Likes Received:
    2
    Try this app, it's working well for me so far, at least with a 3.5mm plugin, not sure about bluetooth, no chance to test yet.

    It's called Headset Blocker by Roadkill, make sure you toggle the widget on for it to work. I'd link to it but these forum admins don't let new users apparently. Good luck.
     
    TNhemmaw likes this.
  12. ebaum

    ebaum Member

    Joined:
    Oct 8, 2010
    Messages:
    12
    Likes Received:
    0
    I'm having this problem too after flashing to Gingerbread on my Samsung Captivate via Bluetooth w/Microsoft Sync in my Ford. Anyone find any good options? I've cleared my defaults for the "Music Player" and made sure Winamp is the default program for mp3 file types, but it's still happening *bump*
     
  13. Lenji

    Lenji New Member

    Joined:
    Nov 24, 2011
    Messages:
    1
    Likes Received:
    1
    With Bluetooth Turned on
    1. Press Menu
    2. Press Settings
    3. Press Wireless & Networks
    4. Press Bluetooth Settings
    5. Press/Hold your finger over the bluetooth device that's causing the issue for a couple of seconds - the car connection
    6. Press Options in the pop-up menu
    7. De-select the Media checkbox.

     
    HikariKAiko likes this.
  14. vincentp

    vincentp Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    1,640
    Likes Received:
    59
    I've been experiencing this problem as well, it is not phone specific but appears to be operating system specific (never happened when I was on 2.1 and I don't think it happened on 2.2).

    From what I can tell there is absolutely no way to turn this off on your phone. Thus far I have only been able to find 3 solutions to this.

    - Remove all of your audio files from the default music folders, including ringtones. This is a very poor solution.

    - If your car itself happens to have an auto-play upon Bluetooth connection option (some do), turn it off at the car level.

    - If you use the app Tasker (or want to buy it), set a task to kill the music app upon Bluetooth connection. This is what I'm currently doing.

    Granted, none of these solutions are great, but it's all I've been able to figure out so far. It was driving me nuts having the same 1 song that I use as a ringtone playing every time I got in the car.

    The other thing that really is unfortunate (and I can't find a fix for it) is that when I try to use the forward/back buttons on the car interface, it re-opens the default music player. In older Android versions, it used to work for Pandora, Grooveshark, etc. Now it always assumes that by "next track" I actually mean "open the music player and play something stupid". It's killing me. I hope it doesn't happen with ICS.
     
  15. HikariKAiko

    HikariKAiko New Member

    Joined:
    Jan 5, 2012
    Messages:
    1
    Likes Received:
    1
    thank you so much lenji!!! This worked!!!! :) happy new year!
     
    crolinto likes this.
  16. quddus702

    quddus702 Member

    Joined:
    May 10, 2010
    Messages:
    8
    Likes Received:
    0
    Did anyone find a fix that actually works
     
  17. crimsondiva

    crimsondiva New Member

    Joined:
    Apr 1, 2010
    Messages:
    1
    Likes Received:
    0
    I have the SAME problem with My Ford Sync and my HTC Thunderbolt and it's very irritating. Any suggestions are welcome.

     
  18. keithd

    keithd New Member

    Joined:
    Jan 19, 2012
    Messages:
    2
    Likes Received:
    0
    just needed to add my name to the list of frustrated users. I wonder if we could arrange a boycott for a day or two? I know this maybe impossible for some, but can we chose a day to use Yahoo search or Bing and if possible do not use the Andorid phone? Just simply shut it down? Like the website blackout? Anything Google or Android? I mean, it must be simple to recode the stupid app and put a stop button on it at the very least. Then give us the option to chose to disable that music service completely? Maybe that could light a fire under their you-know-what!! This is very annoying to say the least! Aggravating more likely.
     
  19. quddus702

    quddus702 Member

    Joined:
    May 10, 2010
    Messages:
    8
    Likes Received:
    0
    Ok I had this problem hated it. But thank you too the person who posted headset blocked it works.
     
  20. crolinto

    crolinto New Member

    Joined:
    May 11, 2011
    Messages:
    2
    Likes Received:
    0
    Thank you Lenji! It had the same issue and it was driving me crazy!
     
  21. TimSmooth

    TimSmooth Member

    Joined:
    Jul 24, 2011
    Messages:
    14
    Likes Received:
    1
    Same problem on GS 2 and GS Infuse 4g. Does not happen on the gs note exynos. It is random apps that auto play audio. 1) Stock Music app, 2) Pandor , 3) google listen, 4) stitcher and more.

    On my car stereo on BT audio it is very annoying. After calls music starts, and on connect music starts. Lenji solution does not work for me becuse at times I want to hear music via BT and his solution totally disables music via bt. My work around is media button router from the market. Shuts it up real good. An app still starts, but you can select one that does not play any audio. This way you are just a tap away from the home screen.
     
  22. TimSmooth

    TimSmooth Member

    Joined:
    Jul 24, 2011
    Messages:
    14
    Likes Received:
    1
    My solution was media button router, but HeadsetBlock works much better. You dont even notice it. GREAT!
     
  23. bjmurrell57

    bjmurrell57 New Member

    Joined:
    Aug 6, 2012
    Messages:
    1
    Likes Received:
    0
    I am having problem turning off music player on android tablet..Impressions.anyone know what to do Im not computer savy so need easy fix with normal language!!!!!
     
  24. TNhemmaw

    TNhemmaw New Member

    Joined:
    Oct 4, 2012
    Messages:
    1
    Likes Received:
    0
    I registered with this forum just so I could say a HUGE THANK YOU!!!!! This worked and I am so grateful for your suggestion. The Headset Blocker app by Roadkill worked. No more rogue music player taking over my Droid Razr Maxx.
     
  25. droidros

    droidros Well-Known Member

    Joined:
    Oct 10, 2010
    Messages:
    491
    Likes Received:
    22
    The same thing happened on my Droid X and now it is happening on my new Razr Maxx HD. I listen to Audible books a lot but every other time when I turned on BT, the damn music player would start instead of the book, even though the book was the last thing I listened to on the device. I've downloaded Headset Blocker and will see if that helps.
     

Share This Page

Loading...