My 2x cannot connect to PC via USBSupport


  1. lucowen

    lucowen New Member

    Hello,
    i'd like to know if somebody experienced same problems with me...
    my optimus2x can't connect to PC via USB... all it did is charging via USB.

    it should also be able to be detected for Mass storage drives... i don't know the cause of this because a week ago it was fine, everything is working.
    I reset to factory default, but still same problem.
    Also removed the LG program from my PC, tried to USB connect in other PC, not work either...
    Appreciate and thank you if any of you can help me with this problem.

    Advertisement
    :
  2. canisdirus

    canisdirus New Member

    Hi,

    I'd like to bump this post, because I have the same problem. A lot of people seem to, based on what I've seen from googling this.

    I have an Optimus 2x, Android 2.2. I was able to connect my phone to my laptop via USB (Vista 32), but that suddenly stopped working.

    When I plug my phone to my PC using the USB cable the phone lights up and starts charging, but nothing else happens. No nofication in the task bar, no sound indicating that a USB device has been connected.

    As long as it lights up and starts charging immediately that probably means that the USB cable (or the phone socket) is most likely not damaged, right?

    My laptop just doesn't discover my phone. Usb mass storage mode or not makes no difference.

    Nothing happens in Device Manager, under Universal Serial Bus controllers. I know that my USB ports are working properly, as they work for oher mobile devices (like my ipod).

    I've tried uninstalling and reinstalling the drivers and LG SW, rebooting the phone and PC with and without the USB chord plugged in, nothing.

    If I check "internet sharing via USB" (with the phone plugged in), my phone says that Internet is shared (this also worked up until two days ago). But no response from my PC.

    Could it be some SW conflict, some settings I'm missing?
  3. lucowen

    lucowen New Member

    still waiting for some input on this problem :)
    but apparently this is quite difficult...or maybe just you and me facing this same problems ....:D
  4. jackdsparker94

    jackdsparker94 Well-Known Member

    I would say delete all drivers and plug your phone in again or download them from the LG updater tool
  5. doctorjl

    doctorjl New Member

    Easy!
    Click on Settings, SD card & memory, & if usb storage mode is unchecked, check it.

    Odd thing is this: if already checked, uncheck then check it again & you'll be all set !

    One other thing: Make sure you are using the original genuine usb cable that came with the phone, & not a ''universal'' replacement; As odd as it sounds, some replacement USB cables will only charge the phone, but won't permit communication
  6. I have had the same problem and even solved this problem on a different post. Just google "optimus 2x driver" on google, download the latest onto your computer, and your windows will do the rest.

    Have a good time,
    -Android Advantage
  7. choccy

    choccy Well-Known Member

    My phone no longer even gives me option of selecting connect to mass storage anymore :-(

    Running CM Nightlies - it just vanish a week ago and now can't get any usb connection at all on 3 different pcs! :confused:
Loading...

Share This Page