my *611 "device awaiting activation" message disappeared!


Last Updated:

  1. neyel8r

    neyel8r Well-Known Member This Topic's Starter

    Joined:
    Jul 13, 2010
    Messages:
    88
    Likes Received:
    5
    i called *611 earlier today (well, yesterday, technically) & the message i used to hear at 1st about my device awaiting activation is gone! strangely, it's still there online.

    so i talked to a csr & she told me "we apologize, but it was a technical glitch" or some garbage like that. i had been getting my hopes up only to be crushed!

    then i asked when my Inc would be shipped & she told me by 08.02 or something, when up until now, they've always told me before 07.27! wth is going on? an extra delay of a week? what for?? she couldn't tell me anything aside from repeating back what i had already mentioned about knowing the phone was on backorder.

    anyway, has this happened to you? i think it's crap & i'm seriously considering dropping them & switching to Sprint!
     

    Advertisement
  2. ggp

    ggp Well-Known Member

    Joined:
    Oct 26, 2009
    Messages:
    264
    Likes Received:
    21
    unfortunately I think customer service really can't see exactly what day your device will ship by. I'm guessing she was just going by the current date showing online.

    As for the pending activation, I've heard that as much as a week AFTER activating a new line, so I wouldn't put any stock in that as an indicator.

    I'd put money on you getting your device by the 27th as was presumably stated on the website when you ordered.

    It'll be worth the wait! :D
     

Share This Page

Loading...