My Android Tablet Won't turn on


  1. iLoveTherese

    iLoveTherese New Member

    Hi , my Android tablet won't turn on
    as in when i pressed the Power Button nothing happens
    its full charged so the problem is definitely isnt the battery
    i think it started a few hours ago
    i tried to turn on my tablet but it wont
    it kept on going to recovery mode
    there was only an android avatar lying down with a red triangle on top of it.
    there wasn't any options just the avatar
    i turned my tablet off and on again
    but it still booted there
    after a few minutes i found that the volume up button was stuck
    making my tablet go on recovery mode.
    after i freed it
    i turned my tablet off then when i tried to power it on
    it wont start up
    what happened? and what will i do ?

    ~thank you


    my tablet is
    made by Onix
    Model number : TB512-16G

    Advertisement
    :
  2. mikedt

    mikedt 你好 Guide

    I believe the Onix tablet was sold by the Aldi supermarket around Christmas time. However the device itself is of unknown Chinese manufacture. Sounds like it's more than likely faulty based on what you describe, probably best to return it to Aldi for refund or replacement under warranty.
  3. Digital Controller

    Digital Controller The Real Bass Creator Guide

    I have moved this thread into the General Tablet Talk forums since you are talking about a tablet.

    Sounds like what Mikedt has suggested is your best option though.
  4. iLoveTherese

    iLoveTherese New Member

    [SOLVED] Please close the thread

    my tablet went to
    sleep(somehow) and it won't turn on back again
    a part of the back of the tablet was hot which means it was working
    what i did was i just left it
    and didn't touch it at all
    and waited for the heat to go away
    meaning the tablet is now out of battery
    then i charged it
    now it turned on
    Lucyloo likes this.
  5. hakides1

    hakides1 New Member

    Hello, my android tablet doesn't turn on it shows light on screen and the word Android. That is it. Can anybody help me?
  6. joanneday96

    joanneday96 New Member

    mines doing the same..
  7. Robmaize

    Robmaize New Member

    Mine does the same too, turns on shows Android word but never start on. Anyone knows whats the problem?
  8. pistolpete76

    pistolpete76 New Member

    Mine won't turn on just has android word on with light scrolling through it. anyone got fix for that

    thanks a bunch
  9. stumbows

    stumbows Member

    Hi guys,

    I have this cheap generic tablet which is making this hard to find a fix for but I get this logo coming up on it whenever I boot up.

    I would have posted but not allowed as it is my first post. But it is the little android robot guy laying on his back with the front opened up and an exclamation mark in red above him.

    Now I've found in the manual that if I press up and power button at the same time I can bring up the android system recovery screen. I've tried all of the options except for apply update from external storage so that is my next port of call. I need to know if there is somewhere I can find a generic image/update that I can download to try and apply to my system to fix up the errors that are occuring?
  10. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Welcome stumbows!
    Well, that image is of your stock recovery....is that the only image on the screen, or is there text also?
    If you can tell us as much info about your tablet as you can, we can try to find something to help:) Or perhaps find a forum here that can help;)
    You should be able to post images now, as the restriction for image posting is only on the first post (to combat spam-bots and the like)
    Your image should be akin to this?:
    [​IMG]
    BRAINZ2013 likes this.
  11. stumbows

    stumbows Member

    Hey Mikestony,

    Yea I see that logo on it's own at first but when I press power and up arrow I can get the recovery menu similar to the one you posted. I have tried the factory reset but it hasn't worked for me.

    I have also taken a shot of the model details from the back. But googling the model and even contacting their support team has really not yielded any real success.

    https://www.dropbox.com/s/h8j5xgu4uiiw29r/IMG_20140314_110759.jpg

    https://www.dropbox.com/s/1vq3jkd08i8unk5/IMG_20140314_110739.jpg
  12. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Hello and welcome to the forums. I see your having trouble with a tablet but a name would help out to help you out better . but every tablet has a reset button that will allow you to repair the errors . if u have this recovery up you can use this to wipe data and cache and also flash items from your SD card if you have one in the tablet .one problem don't wipe data or cache cause that will clear your download items and you will be stuck.
    Mikestony likes this.
  13. stumbows

    stumbows Member

    Yea I have used the physical reset button and I have cleared the cache etc and factory reset as I don't care about anything on the tablet. I also have no SD card inserted at the moment as I never have to be honest.

    None of these options are working for me at all which is surprising.
  14. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    When you reset what does the tablet do
  15. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Can u try and reload the photos
  16. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

  17. stumbows

    stumbows Member

    It shuts off. Turning it back on produces the same results as normal.

    That is exactly the model I am using.

    I have just posted the photos as links instead of embedded images.
  18. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Merged threads :)
  19. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Well its your lucky day I had to search high and low but found this and have to say hope it works

    http://public.tempoaustralia.com/fw/tb512-16gb/20121015/

    Now to flash this rar is what is our next problem is cause we have to change this to a zip file for it to be flashed into the android tablet .
    stumbows and Mikestony like this.
  20. Mikestony

    Mikestony ~30% Carbon Black ± Moderator

    Nice find brainz!!
    I don't have the slightest idea of how to change that file...if possible?
    If it can be done, would it be possible to install via the stock recovery I surmise?
  21. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Hey I am trying to figure this out myself unless it takes the rar as a flash file but nothing yet
    Mikestony likes this.
  22. stumbows

    stumbows Member

    Ahh that's awesome BRAINZ. I know how to repackage a rar into zip. I'll give that a go and report back on my findings.
  23. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    No problems .
  24. stumbows

    stumbows Member

    Well I managed to load the firmware and install it successfully to the tablet but can you believe it doesn't fix anything. I guess there is some hardware fault with it and it's not loading the OS properly. Thanks for all the help guys.
  25. BRAINZ2013

    BRAINZ2013 Well-Known Member Contributor

    Hmmmmm the only thing I can think of is try to reset from the reset button if the firmware works . try to hold the reset pin for about 25 second then release
Loading...

Share This Page