My computer doesn't connect with my Nook Color. "Can't find device drivers" etc..


  1. christy242

    christy242 Member

    Hi, I put gingerbread on my brand new NC (well not me personally, I'm not very techy) and it works great- apps, web browsing, "tablety" feel etc. I wanted to put an ebook on it from my pc and it's not working. PC can't find device drivers etc. What can I do to get my NC and PC connected?
    ps. Just reading through other forums, a lot of people talked about the sd card and such. I have been trying to do this without the sd card in my NC. Any help would be appreciated. Thank you:)

    Advertisement
  2. colchiro

    colchiro Well-Known Member

    What pc do you have, Windows? (XP, Vista, Windows7... which?)

    All you should have to do is plug it into your usb port, (assuming that works :D) and open the status bar on your NC and choose the usb connect option.

    When done, again change it from the status bar, then go to the "Safely remove hardware" icon by the clock in your computer and remove your Nook Color. Only after Windows says it's safe to remove should you pull the plug on it. That way you don't corrupt the file system on it. :D
    christy242 likes this.
  3. christy242

    christy242 Member

    I've got windows vista. I don't see a status bar anywhere on my nook. There is a notification and it says USB debugging connected, but nowhere to choose the usb connect option. I've looked into setting and preferences. I'm running go launcher if that helps anything. My PC just can't find the drivers or something. Maybe because it's rooted? IDK??
    (my computer knows it's there, it says "nook" on device manager)
  4. colchiro

    colchiro Well-Known Member

    You might try rebooting your NC and computer or use a different USB port (like one on the back of the computer).

    "Can't find the drivers" sounds like a problem with your NC or computer or cable. Something is wrong with one of them. You might also try a different computer to figure out which one isn't working correctly.

    Did it ever work? Once it connects properly, you should have an item next to the usb "debugging message" (that is the status bar :D) that you can tap to connect your NC as drive letters to your computer.
    christy242 likes this.
  5. christy242

    christy242 Member

    Tried another pc and same thing. Tried different ports, same thing. It's brand new, idk if the usb worked before rooting it. It charges with the usb cord fine, so could it still be the cord or is it because of cm7?
    Thanks you so much for your suggestions! :)
  6. colchiro

    colchiro Well-Known Member

    I just connected my NC to my wife's laptop (Vista), which has never had one connected before and I got the "new hardware" dialog and was also unsuccessful trying to install drivers.

    BUT, once I turned on USB storage in my NC, it was able to see it. (Tap "USB connected" message in status bar.) You'll see 1 or 2 driver letters show up in "My Computer" on your computer. One will be the sdcard, the other the internal storage on your Nook. Usually you copy files to the sdcard. :D

    If that doesn't work, maybe it's time to have the techy person who set it up for you, take a look at it. :D
    christy242 likes this.
  7. christy242

    christy242 Member

    Okay- In 'my computer' I do see 2 driver letters (removable disk g and removable disk h) show up shortly after I plug it into the usb. So what do I do now? (I don't have an sd card in it) If I try to do anything it says "Please insert a disk into removable drive.." With my NC running CM7 I don't have the same status stuff a stock NC has, status bars etc... It says "USB debugging connected" on my notification bar and if i tap on that it just has boxes to turn off the usb debugging and other stuff not related. IDK! My son is the techy one who rooted it and he's been gone all day to work and with it being Friday I wont see him until late! I just want to put a book on it! lol!
    Thanks!
  8. colchiro

    colchiro Well-Known Member

    Oh yeah, Friday night... nothing constructive will be done until at least noon tomorrow. :D

    I'm running essentially the same rom as you, tho maybe a slightly newer version. All the versions are the same tho, if your Nook can see the computer connection, it will throw message on the notification bar. Until that notice is tapped, those drive letters will be unusable.

    Can you unplug the sdcard from your NC and insert it into your computer and copy the book to it?
    christy242 likes this.
  9. christy242

    christy242 Member

    Thanks for your help! I'll have to try putting it on the sdcard and then onto the nc. :)
  10. colchiro

    colchiro Well-Known Member

    Keep me updated. :D
    christy242 likes this.
  11. christy242

    christy242 Member

    Hey- so I finally got it working! Ikd what happened I just plugged it in (usb) today and it then showed the usb thing that I had to tap in notifications. I have an sdcard in it and it now says mynook color in "my computer":) So thanks for taking the time to try and help me figure it out:)
  12. Podivin

    Podivin VIP Member VIP Member

    'My nookcolor' is probably the internal memory on your nook, at least that's theway it is on mine. Check for another drive that represents your SD card.
    christy242 likes this.
  13. christy242

    christy242 Member

    yep i realized that and have put the book file on the sdcard and finally (4 hours later) have a book on my nook!!
  14. colchiro

    colchiro Well-Known Member

    Glad you got it figured out. :D

    You could right-click on the 2nd drive and name it something like NookSdCard or something that makes sense to you.
    christy242 likes this.
  15. idsoftwar3

    idsoftwar3 New Member

    Hello folks, I just got my Nook Color today running CM7. I finally found this post and christy242's problems sounds very similar to mine. I hooked up my NC to my Mac and was was able to mount the drives perfectly, then I ejected and I haven't been able to hook it up to my computer (I also tried on PC) after numerous tries. I have tried different builds, restoring the settings, different cards, ect and the NC will only charge not connect. The status bar remains empty of any USB notifications except the "USB Debugging Connect" option.

    Will my NC eventually be found like christy's NC? Any suggestions would be greatly appreciated. Thanks.
  16. colchiro

    colchiro Well-Known Member

    What version of CM7 did you install?

    I use dropbox on my pc and 2 Nooks and my phone and use that to move little files around so haven't needed to connect to my pc for some time until I wanted to get some pics off my phone.

    Without the status bar notification, it's hard to say what's going on. Are you using the Nook cable? Is it in good condition?
    idsoftwar3 likes this.
  17. idsoftwar3

    idsoftwar3 New Member

    Hello, thank you colchiro for your quick reply, I appreciate your help on the forums. You were dead on, my cable I got today was bitten by my dog but was able to charge yet not hook up to the computer. I used my original Nook (e-ink) cord and realized my dog had gotten into that too. Then I used an undamaged mini-SD cord and it WORKED/ status bar popped up with usb storage.

    The condition of the cord was def. the problem even if it was charging the NC, I think Chrisy's NC cord was just positioned awkwardly. Thank you so much for your help.
  18. colchiro

    colchiro Well-Known Member

    Glad you got it figured out. I was under the impression they were fragile before you mentioned dogs. :D

    The NC cord is rated for 2 amps, the same as your charger, however most usb cables are only good for up to 1 amp on a good day.

    Your NC will charge a lot faster if you get another B&N cord, which I think they stock now. I wouldn't count on finding one anywhere else tho. I've seen chargers that said they were made for the NC and they were only 1 amp. They may work, but not as good as the one that came with your tablet.
Loading...

Share This Page