1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

My computer won't connect to my phone anymore but still charges battery????Support


  1. solo88

    solo88 Well-Known Member

    I have an epic 4g touch (Sprint) and it was working just fine yesterday! When I would plug in the phone it would give me the option of MTP or the other photo transfer option. I noticed the computer acted a little funny about it, though.

    I've scoured the net the past 24 hours searching for solutions and I've tried everything.
    I have tried 4 different usb cables (including stock), different computer, usb ports, rebooting, hard resetting, usb debugging unchecked, installed the samsung usb drivers, uninstalled the drivers and tried again as well as a full wiping and restore (tried that twice).

    It's not the cable because I connect my Moto Razr Maxx HD and it recognizes it immediately. So I know it's not my computer or the cable itself. There is something in the phone.
    I do remember checking for system updates and attempting to update the firmware, samsung software, profile and PRL.

    Only the profile and PRL options seemed to have updated. Is that what could've corrupted the phone?
    Is there anyway that I can restore the files on the phone to its original state through the phone itself (It still has 4g connection so I can go online with it)?

    I've checked online and everyone seems to say the same thing, "Try a different cable" but I've tried 5 already and my computer still won't acknowledge the phone.

    Also, when I check in the device manager of my pc (Windows 7 64-bit) I can actually see a new device called "Unknown device". So what I did was install the drivers to my computer then attempted to update the driver for that unknown device, which of course is the phone itself. When I tell it where to search for the drivers (in the installation folder for the drivers /SAMSUNG/usb drivers) it says it cannot find the driver for my device!

    So now I'm at the end of my rope and I'm hoping that someone on this forum knows what could possibly have changed between yesterday morning and yesterday early afternoon when all of a sudden it stopped recognizing my device.
    Thanks for any suggestions!

    Adding: I also tried to install the driver by clicking on "Let me pick from a lis of device drivers on my computer. I went to "portable devices" then there were two choices for SAMSUNG Mobile MTP Device. I tried both and they both said the same thing: "Windows found the driver software for your device but encountered an error while attempting to install it.

    This device cannot start. (Code 10)"

    Why does it say "cannot start"???? It's plugged in as I type this and it's charging the phone!

    I know the problem is somewhere with that message but I just can't figure out what it could be.

    Advertisement
    :
  2. Netcat

    Netcat Well-Known Member

    Since your device manager shows unknown device, it sounds like you don't have the correct drivers. But you said you've already reinstalled the Samsung USB drivers. Did you go to the control panel and uninstall the Samsung drivers before you reinstalled them? Have you tried installing Kies (not Kies Air) instead of the USB drivers ? I had the same problem you describe until I installed Kies. I don't really use Kies and only installed it for the drivers.

    Also if you've upgraded to ICS, then expect problems. I'm still on Gingerbread and I've constantly refused the ICS update because of all the problems I've read about.
    solo88 likes this.
  3. solo88

    solo88 Well-Known Member

    Interesting. I haven't tried Kies. Is there a particular version to download? How is it used? Is it where I simply install Kies to my computer and then just connect the phone and it will acknowledge it? You mentioned you only installed it for the drivers. Does that mean Kies is a separate set of drivers than the official Samsung ones or is Kies a program used to facilitate the installation of the official drivers? Thanks very much for your input! Maybe this is the answer I couldn't find all over google!
  4. Netcat

    Netcat Well-Known Member

    Kies is an official Samsung software program that is for syncing media and files. That's it's purpose but it needs to install drivers first because Samsung did NOT include them on the phone itself. The drivers it uses are from Samsung. Just go to Kies - Sync Media, Contacts & Calendars Across All Devices | Samsung and download it from the middle of that page, then install it on your PC. After it's installed, shut down Kies, then try plugging your phone into the USB port and see what happens. Kies does not need to be running.

    It is for any of the Samsung Android phones. You can read about how to use it there but you really don't need to use it. You only need it for the drivers it installs. Kies installed the drivers I needed for my PC to communicate with my phone. Before I did this my PC would not recognize my phone. I did not want to do any syncing but I DID want to drag and drop files. After installing Kies my PC would recognize my phone. Remember...you do not need to run Kies after it is installed. In fact I think you can uninstall it because it will leave the drivers behind on your PC anyway.
    solo88 likes this.
  5. solo88

    solo88 Well-Known Member

    Wanted to say thanks for the suggestion. Unfortunately, it's still not working. It's as if something happened to the phone itself. It charges......but just doesn't want to connect to the computer for file transfer.

    The only other thing I can think of is reformatting the phone into it's raw form. The factory data reset does nothing. Is there another program that will restore the phone completely throughout including old drivers?

    I know that my PC says that the device is not on. So there is something wrong with the phone itself but it only has so many options for me to fiddle with.

    I hope this phone isn't bricked.
  6. Netcat

    Netcat Well-Known Member

    Your welcome. Here are a few things to think about...

    -Did you go to control panel and uninstall any previous Samsung drivers first? Then reboot your computer? Then install Kies? Then plug your phone in?
    -Did you try plugging you phone in with Kies running?
    -Is your phone rooted? Home cooked ROMS can have many issues.
    -Did you recently accept the ICS update from Sprint? That update is causing people all kinds of headaches!

    I don't know about reformatting the phone into it's raw form. A factory reset will reset your phone to the current ROM, whether it's GB, ICS, or a custom ROM. If you have upgraded to ICS and want to go back to Gingerbread, you can do this with instructions from here...http://www.theandroidsoul.com/restore-epic-4g-touch-with-pre-rooted-stock-gingerbread-firmware-el29/

    Your phone might have a damaged pin inside the mini USB connector. I would try installing Kies on a different PC if possible and try one more time. If this doesn't work, go to a Sprint store (call first), and show them how it isn't working.
  7. solo88

    solo88 Well-Known Member

    Phone is full stock and I did try it with Kies running. I tried to downgrade back to gingerbread by using odin but it wouldn't turn yellow to acknowledge that the phone is connected.
    I actually still DO have the samsung drivers installed. I'm going to uninstall both and reboot and try it with only Kies installed. If it still doesn't work, it's gonna look like a pin problem.

    I appreciate all the help! I'll report back just in case someone with the same problem will catch on to this thread in the future.
  8. Netcat

    Netcat Well-Known Member

    Is looks like many people are having this issue with ICS. Your phone needs to be recognized before odin will work.

    Try installing Kies like this...
    -unplug phone from PC.
    -go to control panel and uninstall any previous Samsung drivers including Kies.
    -reboot your PC.
    -install Kies.
    -reboot your PC.
    -plug phone into PC.
    solo88 likes this.
  9. solo88

    solo88 Well-Known Member

    Yeah, same problem. I plug in the phone and it just says "charging" but it no longer gives me the option to choose the connection method.

    Is there a way to downgrade to gingerbread from the phone itself? As in, download the Gingerbread file and install it to the phone by downloading it WITH the phone itself? Also, I've used Kies Air and it works perfectly. Is there a way to downgrade to gingerbread using Kies Air? Or does it have to be while the phone is connected through a usb cable?
  10. Netcat

    Netcat Well-Known Member

    No you can't do that with Kies Air. You may be able to download a file with your computer and transfer it to the micro SD card on your phone then install it from there, but I don't know how to do that and I don't know if you can downgrade to GB that way.

    I read somewhere that if the ICS update borked your phone, you can take it to a corporate Sprint store and make them roll it back to Gingerbread. Your problem is easily reproducible so you can prove it to them and say that it started immediately after you accepted the update.

    Just to be sure you tried all possibilities, check out this web page...

    http://pinappu.hubpages.com/hub/How-to-Connect-Samsung-Galaxy-S2-to-PC
    solo88 likes this.
  11. solo88

    solo88 Well-Known Member

    What. The. Heck???

    It works now!! I JUST connected it again this morning and a box recognizing it popped up saying "Driver Software Installation.

    Generic USB Hub (check) Ready to use
    SAMSUNG Mobile USB Composite Device (check) Ready to use
    SPH-D710 (check) Ready to use
    SAMSUNG Mobile USB Modem (check) Ready to use



    I don't know what the heck happened but what I do know is that I uninstalled all the drivers and rebooted both my phone and pc and until today it worked again.

    Is it possible that ICS is that finicky???? As long as I'm connected now I better use Odin to downgrade.

    Hey Netcat I appreciate all your help that was pretty damn awesome of you taking your time to try out all these steps. I have a feeling that it was the uninstalling of the software and only having Kies is what did it. It just so happens that that's the only think installed on my computer at the moment.
    What a crazy phone this was! Thanks again! :beer:
  12. Netcat

    Netcat Well-Known Member

    That's great! I don't mind helping at all. I think by uninstalling the drivers first and rebooting both your phone and PC, that caused your PC to finally recognize your phone. Sometimes when you uninstall something with the control panel and it doesn't tell you to reboot your PC, you should reboot it anyway, especially if you're still using XP or Vista. I don't know if ICS is the problem but I've read a lot of bad things about it, enough to turn down the update every time I get it offered to me.

    If ICS is running fine then I wouldn't go back to GB, but if you are experiencing problems like the battery and rebooting and Wi-Fi issues that I've read about, then going back to GB might do the trick.
  13. Meruchan

    Meruchan New Member

    Thank you for sharing what you know. This is great. I just install Kies and it works. Big thanks :)
Loading...

Share This Page