"My Contacts" vs "All Contacts" in GMailSupport


Last Updated:

  1. SDscorch

    SDscorch Well-Known Member This Topic's Starter

    Joined:
    Aug 19, 2009
    Messages:
    568
    Likes Received:
    9
    ugh!! too many contacts!

    its BOGGING down my phone!!



    last night i went through and got rid of a TON of contacts - i went from ~2500 to inside of 1700

    but.. when i checked on my phone how many contacts it was looking at (go to People, menu, view - it totalizes how many are in which category: Google, Phone, Exch Active Sync)



    ??

    what happened with all my deleting?? didn't it take effect?? well, maybe by the morning it will be all synced up


    nope! all 2600 there!!





    so... i looked in my contacts in gmail - i have 1655 in "my contacts - and a LOT more in "all contacts"


    now.. HOW do i get rid of all those extra contacts that i don't need??

    also, there's no easy way to see what groups any given contact is a member of - you have to click on each one to look inside:(




    i'm thnking i could do this... export (and save) everyone in "my contacts" - then DELETE "my contacts" --- whatever is left over is "all contacts"

    then move those over to any particular group(s) that's appropriate - and delete the rest


    in the end, re-import all of my contacts that i had originally taken out (my contacts)





    can anyone else suggest a different way to do this??
     

    Advertisement
  2. romeosidvicious

    romeosidvicious Well-Known Member

    Joined:
    Oct 13, 2009
    Messages:
    270
    Likes Received:
    58
    Are you syncing only "My Contacts" because by default "All Contacts" is synced as well. You can choose to sync only specific groups of contacts and make some very small groups pretty easily.

    Yes the groups interface sucks on the phone and in gmail but perhaps it will get better.
     
  3. romeosidvicious

    romeosidvicious Well-Known Member

    Joined:
    Oct 13, 2009
    Messages:
    270
    Likes Received:
    58
    People -> Groups -> Menu -> Sync Groups will let you choose what groups to sync.
     
  4. SDscorch

    SDscorch Well-Known Member This Topic's Starter

    Joined:
    Aug 19, 2009
    Messages:
    568
    Likes Received:
    9
    thankyou-thankyou-thankyou-thankyou!

    i think that's just what i'm looking for!!
     
  5. t1jordan

    t1jordan Well-Known Member

    Joined:
    Oct 19, 2009
    Messages:
    586
    Likes Received:
    22
    Im having a problem with too many contacts aswell. im not sure what to do about it. I am syncing with outlook. I think im going to stop syncing contacts with outlook.
     
  6. SDscorch

    SDscorch Well-Known Member This Topic's Starter

    Joined:
    Aug 19, 2009
    Messages:
    568
    Likes Received:
    9
    well.. number one, go through your contacts in Gmail and get rid of ones you don't need (note: export and save all of your Gmail contacts first! it only takes a second!!)



    additionally, you can do what RSV just recommended...

    that means, you've got ppl in your contacts separated into groups, his method above indicates a means to sync only certain groups to your phone



    for me, these techniques work
     
  7. pdragon

    pdragon Well-Known Member

    Joined:
    Oct 15, 2009
    Messages:
    395
    Likes Received:
    19
    Thanks!
     
  8. abourne

    abourne Well-Known Member

    Joined:
    Nov 3, 2009
    Messages:
    155
    Likes Received:
    6
    Okay, the heart of this issue hasn't been answered.

    At Google's help forum here, it states the following:

    All Contacts vs My Contacts on iPhone - Google Mobile Help

    3) Google only syncs My Contacts because those are the contacts you've manually added to your contact list. If you look at your All Contacts, you'll see that some of those email addresses haven't been added to My Contacts.

    -----------------------

    I wish this was the case with my HTC Hero.

    On my Android device, it's syncing All Contacts.

    I only want it to sync My Contacts.

    Please help. I want my Android phone to stop syncing All Contacts, and only sync My Contacts.

    On the iPhone and iPod Touch, My Contacts, not All Contact, sync.

    For some reason, the HTC Hero isn't doing this properly.
     
  9. brandiem09

    brandiem09 Member

    Joined:
    Oct 17, 2009
    Messages:
    14
    Likes Received:
    6
    Go into Google Mail on your computer, remove all of the contacts that you don't want to sync with your phone from the "My Contacts" list.
    Your phone will only sync "My Contacts"

    In my Gmail, all of my contacts were in "My Contacts" for some odd reason.

    I had the same issue, removed what I didn't want, no more problems.
     
  10. SDscorch

    SDscorch Well-Known Member This Topic's Starter

    Joined:
    Aug 19, 2009
    Messages:
    568
    Likes Received:
    9


    so wait.. you're saying...


    ...doesn't work??





    because it does for me

    i see all my groups, and a check mark next to each one


    additionally, i see one of my choices that says.... "sync all contacts"

    (psst! its the TOP one!)



    and guess what - i UNchecked that one

    and guess what else - ALL of my contacts don't get synced


    just the ones that i want synced




    ??
     
  11. abourne

    abourne Well-Known Member

    Joined:
    Nov 3, 2009
    Messages:
    155
    Likes Received:
    6
    Yes, I do that. I do a manual clean-up from time to time. This is both tedious and cumbersome.

    However, the problem remains that every time I send or receive from a new email address, or one that's not currently in my contacts, it keeps getting added to "All Contacts", and the problem re-occurs.

    This is not true. My phone, HTC Hero, still syncs with "All Contacts". The cleanup we've discussed above does not change the sync path from "All Contacts" to "My Contacts".

    Probably because it's not picking up new ones.

    Yes, again, I remove them. But as I use Gmail frequently, these annoying email addresses keep popping into "All Contacts", and hence, creeping into my HTC Hero contact list.

    I'm still looking for a way to make this stop.

    .
     
  12. abourne

    abourne Well-Known Member

    Joined:
    Nov 3, 2009
    Messages:
    155
    Likes Received:
    6
    Now I think I've got it!

    "People" - I see you mean the picture of the people.

    "Groups" - Yes, I see it says "Groups" at the top of the screen.

    "Menu" - Yes, now when in this screen, I click on the "Menu" button.

    "Sync Groups" - Yes, now I click on the "Sync Groups" button.

    All list appears as follows:

    1) Sync All contacts
    2) My Contacts
    3) Group Name #1
    4) Group Name #2
    5) Group Name #3
    etc.

    Because "Sync All contacts" was checked, all below were checked.

    I de-selected "Sync All contacts"

    I selected "My Contacts" as the only one to be checked.

    Since "My contacts" has all the contacts I want to be sync'd, I left this one as the only one to be checked.

    I think the problem is now resolved.

    Mission Accomplished.

    Thank you SDscorch!
     
  13. abourne

    abourne Well-Known Member

    Joined:
    Nov 3, 2009
    Messages:
    155
    Likes Received:
    6
    Now that we've reached clarification on this matter, who here finds the "All Contacts" feature in Gmail annoying when they automatically add email addresses as you send/receive email with new email addresses and they automatically put them into "All Contacts".

    Personally, I wish there was an option to opt-out of this.
     
  14. MrBazar

    MrBazar Member

    Joined:
    Oct 27, 2009
    Messages:
    8
    Likes Received:
    0
    My Hero (Sprint) only displays two options under the menu in the groups section. Add or delete group...
     
  15. abourne

    abourne Well-Known Member

    Joined:
    Nov 3, 2009
    Messages:
    155
    Likes Received:
    6
    I have three:

    Add group | Delete Groups | Sync Groups
     
  16. SDscorch

    SDscorch Well-Known Member This Topic's Starter

    Joined:
    Aug 19, 2009
    Messages:
    568
    Likes Received:
    9
    abourne.. i think yeah, you might have a bug of some kind

    but its probably inside gmail - i would bring this up in the gmail area (look for "report gmail bug" in the upper right hand corner when you're in gmail)

    if you're doing all that and you still get all of your contacts (or, like it sounds like you're saying, as you email to contacts they get migrated into "My Contacts").. that's definitely a problem and somethings not working the way its supposed to

    !
     
  17. abourne

    abourne Well-Known Member

    Joined:
    Nov 3, 2009
    Messages:
    155
    Likes Received:
    6
    SDscorch, not a problem. The All contacts are not automatically transferring to My contacts in Gmail. Now that I've set the sync settings on my HTC, everything is good to go.

    My preference would be for an opt-out or way to prevent email addresses from automatically being added to All contacts.

    It would be nice if there was a way to list contacts in All contacts that are not in My contacts as a quick and easy way to delete them.
     
  18. SDscorch

    SDscorch Well-Known Member This Topic's Starter

    Joined:
    Aug 19, 2009
    Messages:
    568
    Likes Received:
    9


    yes! good point!!

    at one time - when they first came out with this, there was a way to see those "other" contacts that just automatically got saved

    you could look at that list and pick and choose (and also delete) from the list and move them to "My Contacts"

    not any more



    here's an idea... Google has a "product ideas" web page - i'm going to add it to the list - other ppl will vote on it

    i think its a good idea!




    direct link to Call Management / Contact Management area...

    Google Product Ideas
    :cool:
     
  19. abourne

    abourne Well-Known Member

    Joined:
    Nov 3, 2009
    Messages:
    155
    Likes Received:
    6
  20. sdague

    sdague Member

    Joined:
    Oct 13, 2009
    Messages:
    11
    Likes Received:
    0
    Thank you so much for sorting this out. The All Contacts sync thing was driving me nuts, now life is good.
     
  21. abourne

    abourne Well-Known Member

    Joined:
    Nov 3, 2009
    Messages:
    155
    Likes Received:
    6
  22. n8man1068

    n8man1068 Member

    Joined:
    Nov 5, 2009
    Messages:
    22
    Likes Received:
    0

    annoying. Especially when you have several years of various contacts. I had 4+ contact entries from some people on my phone. Came here/joined to figure out how to better my 'Google Experience'. haha
     
  23. klugg

    klugg New Member

    Joined:
    Jul 3, 2010
    Messages:
    2
    Likes Received:
    0
    The same on my Samsung Galaxy S. Any sollution for us on this annoying issue?
     
  24. whitesoxxx

    whitesoxxx New Member

    Joined:
    Oct 28, 2009
    Messages:
    2
    Likes Received:
    0
    this is the same on the EVO or any phone with HTC Sense UI I believe.

    I flashed my phone earlier and forgot how I got to the setting and stumbled upon this thread with no apparent solution.... but I figured it out :)

    Open People > Menu > View > Only contacts with phone numbers

    This will remove the erroneous email addresses that were previously synced to your phone. Doubt anyone in this thread cares anymore but I thought it would be best to give a solution for future google searchers
     

Share This Page

Loading...