My Data is BrokenTips


  1. k0nane

    k0nane Well-Known Member Developer

    There are far too many threads from users with data issues. It's time to put an end to the madness. This will be the place to go if you're having problems!

    The causes:

    There are many things that might cause broken data. There are also many things that cannot, or don't. The data loss and baseband version error has been going on since April of this year, if not before. What is not causing your issue includes:


    • Basix or Exodus. Neither custom ROM modifies anything related to data connections. Do not suggest either is the issue.
    • The app you just installed, unless you told it to, or it is designed to
    • Rooting
    • CWM
    • Assorted pieces of magic fail dust.

    What could cause your problem:


    • Bad Odin flash
    • You flashed something from another device, or that is not explicitly marked as being for the Indulge (R910 or R915)
    • Metro/Cricket is down in your area
    • Random failure (most common)
    • OTA update from Metro
    • The existing bug in Samsung's software that was alleviated, but not fixed

    The symptoms:


    The most obvious symptom, of course, is that you can't access mobile data. However, the signs that it's a little more than temporary include:


    • When WiFi is disconnected, there is no 1X/3G/4G icon
    • Your CDMA baseband in Settings > About Phone is "unknown"
    • Your LTE baseband in Settings > About Phone is "unknown"

    If you see these, you have a problem.

    The fixes:

    YOU MUST TRY THESE FIRST. Do these steps in order, one at a time - each may solve your problem. Note that if your problem seems to occur after you flash a ROM or restore a backup, do the ENTIRE PROCESS before flashing, and don't restore until you've tested.


    • Reboot your phone
    • Boot into CWM (or stock recovery) and wipe cache (main menu) and dalvik-cache (under Advanced)
    • Do a Factory Reset (three times!) in CWM, and reflash the ROM if applicable
    • Do the above, then Odin your device
    • Format your SD card, then do the above, and redownload your ROM of choice from a secondary mirror (if applicable) before flashing

    Only after you have done each and every one of the steps above should you post here or join the IRC channel!

    Advertisement
    :
  2. k0nane

    k0nane Well-Known Member Developer

    Reserved again. Thanks for another quick stick, mod.
  3. metroinphilly

    metroinphilly Well-Known Member

    Does the phone have to be rooted to do these steps?
  4. tiede

    tiede Well-Known Member

    For steps two onward, then yes.
    it's hard to "fix" it if you can modify key files. ;)
    I just wish we had the damn source code to analyze!
  5. k0nane

    k0nane Well-Known Member Developer

    Not quite. The factory recovery has the same reset options, and Odin works on any device.
  6. metroinphilly

    metroinphilly Well-Known Member

    Tiede if this works for you please post and than I will try
  7. polywood223

    polywood223 Well-Known Member

    There must be a tower outside my home because I'm getting speeds as fast as 7mbs down and 5up
  8. tiede

    tiede Well-Known Member

    Sorry. I've already tried all these (and many more) to no avail. I have tried everything i can think of so far, and have no 1x or 3G icon.
    The only thing is, if I turn off 4G using the LTE Functionality Test app when it is stuck in "sending" mode, the 1x icon will flash for less than a second (I don't want to write about 10ms, but that's what it feels like) and then it goes off. It's as if it tried and failed (?)
    :(
    So maybe something in the driver is erroring out, or it's genuinely fried. I may consider exchanging my phone, but I have NEVER done that yet, and I don't trust the replacement ones that much, since sometimes they just give you one that other metro customers have returned themselves...


    @k0nane, you said reset in CWM. I was pointing to the fact that CWM==>root ;)
  9. metroinphilly

    metroinphilly Well-Known Member

    Any luck yet tiede?
  10. k0nane

    k0nane Well-Known Member Developer

    Now which one of you mods changed my thread title? ;)
  11. tiede

    tiede Well-Known Member

    Unfortunately, no. When I get some time. I'm planning to test it after an Odin Flash to see if that works. If it doesn't, well, of to the corporate store with it! :(
    Sad thing is, I haven't even ONCE changed my phone before. I've grown attached to it's little imperceptible scratch...
  12. No 4g,3g,1x. im thinking there is an app conflict with just Basix. Cause with stock rom and the Exodus rom with the same apps have no issues. Basix rom from a fresh install no apps it works even after multiple resets. Any way to find the log to find out what app is causing the conflict? I love the Basix rom vs the Exodus rom. help in this issue is greatly appreciated.
  13. k0nane

    k0nane Well-Known Member Developer

    Not possible. The issue is bad data - if you backed up crap, and restore crap, you'll get crap. ;) Reinstall your apps manually from the Market, and go from there. You'll find it works just fine.

    Remember to perform ALL of the troubleshooting steps in the OP if you continue to have issues.
  14. if it is crap then why does my backup work with the other two roms? I first had the issue after installing apps manually from the market then from there things went down hill. so that was when i tried trouble shooting. I dont restore my app data only the apks. i have even went as far as factory wipe after install the stock theme (so i had atleast the twlauncher) and no go. If i do an install of the basix from from scratch without first restoring my stock rom i will not get any network data either. that part i do not understand.

    update: withe cdma only selected in the hidden menu i get complete data denial no icon at all after installing titanium backup but 4g restored after selecting global and rebooting. any idea?
  15. k0nane

    k0nane Well-Known Member Developer

    It sounds like you have a bad base to work with, or an issue beyond just the backup. Odin your device using the Option 2 TAR, format your SD card, and redownload the ROM from an alternate mirror. Then AIO and flash.
    theannihilator likes this.
  16. i did that yesterday and it worked for a while (for about most of today (around 5:00-5:30pm est)). It died again after i tried to d/l juice defender. I odined and aio like you said last night and formated my sd card (after backing it up). After it was all done last night i waited till this morning and restored my backup with titanium backup, excluding the amazon apps that i d/led and it worked with 4g. but i tried to re-odin my phone tonight and i think my 4g is fried cause now even under stock nvr touch rom flash it shows unknown under lte. i know its not an os bug cause i am on ee07. Thanks for your help k0nane. I am just happy that i found out it was a mix of a dieing lte radio and a bad rom install.
  17. dongemus

    dongemus Well-Known Member

    "My data is broken", No 4G for 2 days, I get no data on reboot, if I toggle airplane I get 3G/1X.
    MY LTE baseband is unknown (still have 3G/1X)
    I've done the following...
    Reboot (about 10 times)
    Batter pull for 10 minutes (twice)
    Wipe cache/dalvik-cache (CWM)
    Factory reset three times in CWM
    Then got a force close on androidwizard on reboot
    Rebooted again and got start up loop
    I went back into CWM and reflashed the Basix ROM and rebooted
    Got a force close on launcher pro on reboot
    I downgraded the PRL from 3025 to 3019, just to check, now I only get 1X
    Odin, it rebooted but came up still Basix
    Realized I didnt wait for the .tar to finish downloading, made some coffee....
    Odin again, failed but got the [phone].../!\...[comp] icon, stock/CWM gone?
    Odin again, back to stock this time (Tar2)

    Still LTE unknown, no 1X unless I toggle airplane mode. So what is best to do now? ...besides check out metro studio using Boingo wifi ;)

    UPDATE: Kept playing with phone (reboots, pulled SD, etc.) eventually pulled SIM card and used the phone for a bit w/o the Sim Card. Pulled the battery and and put it back in, reboot and 4G is back.

    4G stayed for 30 minutes then left.
    Reboot=LTE unknown
    battery pull, pull sim, reboot, power off, sim in, reboot and 4G is back.

    What should people in this situation do? Go to a Metro Store or try something else or wait??
  18. tiede

    tiede Well-Known Member

    Make sure the sim is clean of oily smudges, like those that can be left by fingerprints, and that it is properly seated. Clean battery terminals as well, while you're at it. Reboot and cross fingers.
    If all else fails, become the unofficial Guinea pig for the EG06 tar, if you know how to get out of trouble, that is ...
    Elsewise, a metropcs corporate store visit seems to be in your future. :(
  19. im getting warrantied through metro for 11$ and have to wait till Thursday. i would go through Samsung directly but don't want to wait two weeks to receive my replacement phone.
  20. dongemus

    dongemus Well-Known Member

    @tiede, has anyone tried EG06 tar? Has it fixed anything? Can you still Odin back to stock?

    @ theannihilator, How did you go about it? So far I am only talking to Metro about it through there Michigan twitter.

    I guess since there is enough of us, we could do a class action lawsuit if they refuse to fix/replace.
  21. I odin my phone and then when 4g still was not working i took it to my local metro corp store and said my 4g aint workin. Since my phone is still under warranty they told me ok it will be 10.70$ for shipping for me to order you a new one. they also told me that if i wanted to wait 14 business days i can do a warranty exchange directly through samsung.
    dongemus likes this.
  22. tiede

    tiede Well-Known Member

    I am not aware of anyone flashing the EG06 on their phones yet. However, this question is best addressed to k0nane, as his the lead developer and would have heard about it, somehow or another (even if someone just went to complain to him that they broke the phone trying to flash it on there ;) )
    Drop by the indulge's IRC channel and be on the lookout for him. I'm sure he'll answer you there if you ask!
  23. sgthawk

    sgthawk New Member

    I have been having the same problem and I noticed that 4G was working fine and as soon as I hit the airplane mode button the first time then the only thing that would work again was 1X, and LTE version was unknown. I will try and replicate this behavior and update here.

    Edit:
    After wiping to factory reset 3 times and applying a fresh basix flash, I turned on airplane mode a couple times and 4G came back after about 1min so that may have been an isolated problem before, lets see how long I will keep my 4g this time. I will keep my apps to a minimum and no data will be restored. I also formatted the SD card and will keep it clean for about a week

    Edit 2:
    After a day with 4G working fine, I toggled my airplane mode and got the stuck at 1x again. I looked at the "About" and still had an LTE info showing but then after a couple hours of no 4G I rebooted and LTE was Unknown. I formatted my SD once more, Factory reset a couple times, then I Odin the device and 4G still didn't work. This made me think my 4G radio was fried but after getting to my home pc and rooting and then applying my original back-up via clockworkmod 4G is back working with the Samsung Stock system. I dont know what to make of this but that it is a software related issue vs a hardware/burned radio as most people have experienced so I hope this information sheds some light of where to look in order to make this a even better mod or any future mods.
    Thanks
  24. dongemus

    dongemus Well-Known Member

    shthawk, it isn't the ROM (read all the "data not working" threads here on this forum). People are having the exact same issue as you and I who have stock, never touched phones. They have been having these issues for over 6 months, before we had root or roms.

    I noticed something new. Back when my 4G was working I would get 4 bars at my house, when I would turn off 4G I would get 1 bar (my house is a 3G dead zone). Now when I reboot my phone I get 4 bars but no data, when I toggle airplane mode I get 1X/3G but 1 bar, just like before. The "4G antenna" is on, but not receiving data.

    I do think this is a software/driver/SIM card issue and not the hardware.
  25. dongemus

    dongemus Well-Known Member

    OK, I decided to do some calling around before going to the MetroPCS store tomorrow. I did a web chat with Samsung support and MetroPCS support.
    (long boring chat log here --> iNDULGE SUPPORT - Pastebin.com )

    I was told to call the next level technical support by both. Since I didn't have another phone on me I called Samsung first, they tried to get me to call Metro. I insisted that this is a widespread problem and I had already done a battery pull, SD card format, soft reset with MetroPCS support and a factory reset on the phone. He put me on hold and then came back with an offer to RMA the phone. (Boring rules of the RMA --> http://pastebin.com/wasAyraW )

    So my questions are...
    1. Do you think I should RMA the phone? They might be able to find the problem and make a fix for everybody. Or should I just take it in to MetroPCS?

    2 They told me to take out my SD, battery, cover, chargers etc and do not ship it to them. Should I remove the SIM too? I though you need the SIM for LTE to work? Should I send them the SIM?

    3 I currently am running Basix 1.0. I know I should Odin the phone back to stock. I am also going to downgrade the PRL from 3025 to 3019. Is there anything else I should do before I RMA it?
Loading...

Share This Page