My Driod Inc 2 stuck on HTC screen after new ROMSupport

Last Updated:

  1. nilk007

    nilk007 Member

    HI friends,

    I got an verizon HTC Driod Inc 2 and unlocked to use on different network.

    I had installed ClockworkMod recovery v. and followed the steps given on following link youtubecom/watch?v=Wag3W3Hq2u4&feature=plcp
    to root the phone and before that I had unlocked bootloader from HTCDEV site by getting new token.

    then I tried some root explorer and file expert application installed on my phone and tried to remove verizon builtin apps. I am not succeeded so I thought of installing new rom and in a hurry I had downloaded CyanogenMod from clocckworkmod site under rom manager section. I had installed by copying the zip file on my sd card and gone to clockworkmod bootup screen and say install from sd card. Once it done, my phone never boots up - Its still on HTC screen :(

    Please help me in this to recover or to go back to original rom on phone. Bad thing is on hurry I haven't taken backup of system rom.

    HBoot screen details:

    Jul 18 2011,12:39:36



  2. TheAtheistReverend

    TheAtheistReverend Anybody want a peanut? VIP Member

    On that HBOOT screen, scroll down to RECOVERY and select it to get to your recovery. But first I would download a known good rom such as this one and flash it from recovery.
    I would recommend never installing anything from Rom manager as many people seem to have issues with it.
    Always do your homework before flashing something, by which I mean read the forums on the rom first and make sure it will work for you. Not all roms are fully functional.

    If this doesn't work, you can always download the back-to-stock and place it on the root of your sd card, then power up the device while holding the volume down key to boot into your bootloader/hboot and it will bring you back to factory stock.

    Next time you root, make that NAND backup BEFORE you do anything else. That way you can always return to it without all this hassle.
    nilk007 likes this.
  3. nilk007

    nilk007 Member

    You are the GOD, my mobile is up and running now.

    But the problem is I am not able to use wi-fi.

    first I installed GB Sense M 5.0.1 Ext4 Version w/ Drell's #21 Kernel but my phone stuck on HTC screen again. Then installed GingerBangSense 5.0 "M" - It was up and running now.

    What to do for wi-fi now and the search icon is not enabled. How can I install the sense 3.0 and other stuff apart from recovery mode. please share the link with me.
  4. scotty85

    scotty85 Guides Guide

    htcdev is not able to install kernels from recovery. as such,unlocked s-on is a PITA to deal with.

    your wifi is not working due to a kernel/module mismatch,since htcdev couldnt install the matching kernel for the rom you flashed.

    i would not worry about your wifi on this rom. since you are allready htcdev unlocked,follow the directions in post #2 of this thread to downgrade to a firmware that is supported by revolutionary:

    once you are s-off,you can update your baseband,and flash the rom of your choice,and things will work correctly.

    i would very strongly recomend going thru this effort to become s-off.

    your other options are:
    1)fastboot boot your recovery every time you want to flash a rom

    2)manually install a matching boot image with fastboot commands every time you want to flash a rom

    1 is easier than 2,but both will require you to be hooked to a PC to flash a rom OR restore a backup.

    holler if you have questions :)
    nilk007 and TheAtheistReverend like this.
  5. nilk007

    nilk007 Member

    Hi Scooty,

    Thanks for your reply and tips. I followed the same procedure given on the link. it returned the below error while flashing.

    C:\Android\miniadb_inc2>fastboot flash zip RUU_Vivo_W_Gingerbread_S_VERIZON_WWE_
    sending 'zip' (292817 KB)... OKAY [ 52.204s]
    writing 'zip'... INFOadopting the signature contained in this i
    INFOzip header checking...
    INFOzip info parsing...
    FAILED (remote: 99 unknown fail)
    finished. total time: 58.110s

    C:\Android\miniadb_inc2>fastboot reboot
    finished. total time: 0.156s
  6. TheAtheistReverend

    TheAtheistReverend Anybody want a peanut? VIP Member

    Hey Scotty, what was it that gave away that he was Dev Unlocked? I saw the s-on just now (wasn't actually looking for that stuff before), but I would like to know what gave it away for you?
    scotty85 likes this.
  7. scotty85

    scotty85 Guides Guide

    Sounds like your bootloader did not relock. What does hboot show? Unlocked,or relocked?
  8. scotty85

    scotty85 Guides Guide

    The talk of tokens,s on,and simply seeing similar posts in other forums.

    The ability to flash roms from a permanent recovery with htcdev is commonly misunderstood
    TheAtheistReverend likes this.
  9. nilk007

    nilk007 Member

    HBOOT shows unlocked only... I tried to place on SD card and tried to boot inoreder to go back to original ROM... but no luck on that too.. I am really messed up now and running with same TSM 5.0 rom with no wi-fi... :(
  10. scotty85

    scotty85 Guides Guide

    you will need to relock the boot loader.

    Did you miss this command in the directions:

    Fastboot oem lock
  11. nilk007

    nilk007 Member

    Thanks for reminding friend, I had relocked and now it's downgraded.

    But still its S-ON only.. How can I make it S-OFF and I am really cofused with revolutionary and I dont have any Recovery image installed... Please guide me thru friend... :)
    scotty85 likes this.
  12. scotty85

    scotty85 Guides Guide

    Revolutionary will install s off and a custom recovery. You can search the all things root subforum for info on Revolutionary. I can give you more details later, if you are still confused(I'm currently at work) :)
    nilk007 likes this.
  13. nilk007

    nilk007 Member

    Hey Friend,

    Bingoooo... Its up and running now.... S-OFF done, Aro recover installed and Superuser too... really thankfull for your support...
    Sorry to disturb you on the work.

    Now its time to have a nice rom to be loaded on my phone. Please recommend one when you are free...

    Have a nice day :)
    Love you so much....
    scotty85 likes this.
  14. scotty85

    scotty85 Guides Guide

    sorry for the short replys earlier,its hard to go into much detail on my phone ;)

    the module/kernel mismatch is common,when a rom similar rom is flashed,wich can use the current kernel to boot. the user thinks the rom installed successffully,and doesnt notice the kernel didnt chagne,resulting in errors. very different roms simply wont boot,casuing not only fustration,but panic ;)

    awsome! glad you got it sorted. :cool: unfortunately,the inc 2 hasnt been my daily driver for quite some time,so im pretty out of touch with available roms.

    i personally dont care for htc sense,and am about having the latest and greatest,so at this point id be looking at AOSP jelly bean based roms,like cm10. but they may still be missing some functionality,its all about your personal preferance,and what you have to have,and can live without.

    best bet is to read thru the roms modifications,buglist,and look at screenies if availble. pick a few you think you might like,and give each one a few days. you can always nandroid backup to a particular one if youd like.

    there are some very knowledgeable users in the inc2 forums,like bberry and ahtiestrev,that can likely be a lil more helpful when it comes to rom specifics :)
  15. TheAtheistReverend

    TheAtheistReverend Anybody want a peanut? VIP Member

    I tend to stay on my favorite CM7 rom by CondemnedSoul. Check the last page for working links to version 1.4 or 1.5 as they are the most stable and fully functional. I get amazing battery life and speed out of that one (I recommend flashing aeroevans .8bfs or .8cfs kernel after installing for extra butter).

    If you must have CM10 or Jellybean I recommend Darkstunna's here. It is one of the most stable JB roms you will find. ICS, check out this one, I hear good things but haven't tried it myself.

    Understand we still don't have the source for ICS or JB, so they are almost never as solid as a Gingerbread/2.3 rom like the CM7 I mentioned earlier, or this near-stock with some nice tweaks by one of the more active Devs for the DInc2.

    I don't mean to speak ill of an amazing rom, but i would recommend staying away from the Viper Rom just for now. There have been some issues with some people (including me) being unable to run any ICS or JB rom after having flashed the Viper Rom. Keep your eyes out for news there.

    Have fun.
    scotty85 likes this.
  16. nilk007

    nilk007 Member

    Hi ,

    I had tried to upgrade for CM 7, so I gone into bootloader usb mode and given following commans and returned with error as shown below. I believe I am missing some comments or doing junk work... please let me know the procedure or the guide to do the same.

    Please don't hesitate to reply, as I am new to this bit confused...

    C:\Android\miniadb_inc2>fastboot erase cache
    erasing 'cache'... OKAY [ 0.125s]
    finished. total time: 0.125s

    C:\Android\miniadb_inc2>fastboot oem rebootRUU
    ... OKAY [ 0.141s]
    finished. total time: 0.141s

    C:\Android\miniadb_inc2>fastboot flash zip
    sending 'zip' (99113 KB)... OKAY [ 18.360s]
    writing 'zip'... INFOzip header checking...
    INFOzip info parsing...
    FAILED (remote: 24 parsing android-info fail)
    finished. total time: 26.157s
  17. scotty85

    scotty85 Guides Guide

    files have to be of the correct format to be flashed that way from the bootloader. all the rom downloads will be flashed in recovery,as you did before.

    -place on root of sd
    -boot to recovery
    -make backup
    -full wipe(cache,dalvik,data/factory reset)
    -install rom

    some AOSP roms will have a seperate flash of google apps(gapps) that youll need to do immediately after the rom flash.

    CS is a great developer,his roms are awsome,im sure youll be happy with it. im not sure right off,however,if he has incorporated gapps into the main rom flash. if its not mentioned in the roms OP,then they prolly are allready built in :)
  18. nilk007

    nilk007 Member

    Oh My God - I am playing around too much it seems.. I had installed Initial step itself - its asking to activate my mobile with Verizon wireless. But I had unlocked it and using it in India. Now I am not getting network and not able to go for wi-fi.... I am ??????????????
  19. scotty85

    scotty85 Guides Guide

    I assume you're using it on a GSM network with a sim card?

    Just flash a stock rom,or run an ruu for now,more info later :)
  20. nilk007

    nilk007 Member

    Yes scooty, you're right.. I am using GSM with Sim card - India.

    Wi-fi connects at home but not able to use in office... hmmm lots of stuff need to learn... I will... and waiting for you guys comment... Thanks.
  21. scotty85

    scotty85 Guides Guide

    unfortunately,cm/aosp roms do not seem to be set up for gsm usage,despite the inc 2's world phone capabilities. i have used my inc 2 on t mobile,and i cannot get cm7 or cm9 to work either,so the prollem is not anything youre doing wrong.

    you will likely just have to stick with stock,or stock based,roms in order to get a gsm signal. when i was experimenting with it,i found stock GB to work fine.

    did wifi used to connect at your office? there are different types of wifi,if its never worked there,then maybe its jut the signal.

    prolly my recomendation would be to run a stock ruu. there isnt one for th newest software,but you can OTA. heres the steps i would take:
    -run an ruu. doesnt matter awhole lot wich one,you can even use the one you used to downgrade.
    -do a factory reset from hboot
    -use the phone normally untill it OTAs all the way tothe current build 6.01.605.5.(dont worry,s off wont disapear)
    -once the phone is current,install recovery as a PG32IMG,or using the fastboot flash command,like when you first rooted
    -install superuser in recovery,like when you first rooted

    now run the phone 2 or 3 days,and make sure everything functiuons competely normally. assuming that it does,start trying custom roms again,using at first ones that are based on stock.

    hopefully that will help make your falshing experiences a lil more enjoyable :)
  22. TheAtheistReverend

    TheAtheistReverend Anybody want a peanut? VIP Member

    I don't think it will OTA if it is unlocked and being used in India on a gsm network.

    How about the Sense rom I posted by Nitsuj17? That should still have global capability intact. There is a global CM10 I linked to as well, though being CM10 it isn't FULLY functional. I think it is Daily driver capable though. I guess I would say go with the ruu like scooty said, or the Sense one I linked to for the safer routes.
    scotty85 likes this.
  23. scotty85

    scotty85 Guides Guide

    My inc 2 is unlocked and otaed on t mobile ;) the simlock state doesn't have any impact on the ota,nor does the carrier. If its on a completely stock Rom,stock recovery,and get to the internet,it can check vzw servers for updates. I've had plenty of unactivated phones ota over WiFi :)

    Even if it doesn't ota,no biggie... Main suggestions are to factory reset from hboot with a stock recovery in place(not the same to wipe data/factory reset from clockwork),then run the stock software for a couple days so we have a good baseline for Wat works ans Wat doesnt in India,that we can compare custom roms to :)

    The sense world Rom you linked looks like an.awesome suggestion :cool:
    TheAtheistReverend likes this.
  24. TheAtheistReverend

    TheAtheistReverend Anybody want a peanut? VIP Member

    Hehe, oops.

    Thanks for that, I had no idea! I have been under the wrong impression for some time now. Other than when I flashed an ruu on my DInc2 recently, I have never had an OTA. Even when I ran "stock" ROMs that hadn't modified anything like the otacerts file everyone seems to blame, I never got a prompt. Maybe I got an OTA without knowing it some night?

    Thanks Scotty!
  25. nilk007

    nilk007 Member

    HI Sccoty and Athiest,

    Let me go back to stock rom and try the same what you guys told.... Do I need to flash any latest radio on my phone... when I make a call, opposite side fellow is getting echo always.... Is it something known problem or what.... I believe I need to start from scratch....

    Regarding wi-fi, now no problem as its an problem in my office wi-fi router from the day I flashed and tried connecting thru mobile.... :)

Share This Page