My Facebook for Android app won't work anymore?

Last Updated:

  1. Lazer77

    Lazer77 Well-Known Member

    I keep getting an error message when i try to load notifications or the recent news feed, it says:
    Cannot retrieve notification. Please try again later. Error message: [601/parser error: unexpected '-'at position 64.]

    I try to reinstall it, but it doesnt show up on my uninstaller app, and i can only uninstall updates through my application manager, i cannot actually uninstall the entire app.

    Does anyone know how to fix this? Its for an EVO 4G.

  2. G.Armour

    G.Armour You know you want to. VIP Member

    It is still working fine on my moto Droid. Try going into your accounts, sign out of Facebook and sign back in. I have had a similar problem but it was just because my phone was roaming. You could also just try to reboot your phone, that may fix it. Hope this helps.
  3. Lazer77

    Lazer77 Well-Known Member

    I have already tried both of these, no luck :[
  4. Lazer77

    Lazer77 Well-Known Member

  5. Lazer77

    Lazer77 Well-Known Member

  6. Lazer77

    Lazer77 Well-Known Member

    Can anyone help please?
  7. ShelleyD1

    ShelleyD1 Member

    Mine doesn't work either. Put I just got a Fascinate yesterday and thought it was because I didn't know what I was doing. Twitter works though. I can get on facebook in some areas, but others say to logon on a computer. So frustrating.
  8. wrestlingnrj

    wrestlingnrj Member

    I've got the same issue with my Incredible. Notifications hasn't updated since I upgraded to 2.2 and the news feed updates whenever it randomly feels like it. So far, I've yet to find a solution.
  9. twilighter

    twilighter Well-Known Member

    Having the same problem on EVO. I just want to uninstall it completely and just use fbook instead.
  10. G.Armour

    G.Armour You know you want to. VIP Member

    The only way I know to take a factory installed app off is to root your device and uninstall it that way. I figured signing out and back in would fix. Try signing out, reboot your phone, and sign back in.
  11. Lazer77

    Lazer77 Well-Known Member

    I did the signing out and rebooting, I tried those types of fixes. But I cannot figure out how to uninstall. I have never rooted a phone (I have other things), I'm worried I'll brick it.
  12. Lazer77

    Lazer77 Well-Known Member

    So there are no fixes for this?
  13. twilighter

    twilighter Well-Known Member

    I don't think this was a factory installed app. If I remember correctly, I had installed it from the android market. But, It won't allow me to uninstall. Only uninstall the updates....I might be wrong though.
  14. I got the same issues. Perhaps they need to update the Facebook app to fully function on 2.2?

    Oh, I run a Desire...
  15. brownhornet

    brownhornet Well-Known Member

    Im to the point now that I dont even use it anymore
  16. twilighter

    twilighter Well-Known Member

    Don't know if this has anything to do with it, but I had facebook as one of my bookmarks and when I deleted it, it appears that I don't have the facebook for android problem anymore....I don't get how bookmarks had anything to do with it....
  17. vegasfergie

    vegasfergie New Member

    I have the exact same problem, on a Droid. I did the signout and reboot to no avail. And this has only happened since I got the OTA 2.2 update. Before that it worked perfect. Hopefully someone will get a patch out or something soon.
  18. Lazer77

    Lazer77 Well-Known Member

    On my HTC Evo 4G it was a factory installed map.
  19. NexuSix

    NexuSix Well-Known Member

    While acting on the side of caution is always reasonable and prudent especially when rooting there is an easy way to root without losing your warranty:

    1-click root
    [APP] [ROOT] 1-click root for N1 (Latest ver: 1.6.2 beta 5) - xda-developers

    Then us Titanium Backup to remove the undesirables, I highly suggest acquiring the donate version to have extended abilities, like the ability to freeze apps:


    Also note, I tested my facebook app and it is running without event as per usual. ;-)

  20. Rensy

    Rensy New Member

    what works for me when i get this error is deleting the cache in "manage my applications" under settings. if it doesn't work, try logging out if you're logged in anywhere. restart the facebook app after deleting the cache.
  21. suible

    suible New Member

    Yes! Erasing cache and restarting Android - worked. Thanks!!
  22. bigbadwulff

    bigbadwulff Well-Known Member

    The Fix: Friend Caster. In the Market. Works much better than the official FB app. No chat however, if that is a big thing to you.
    No goofy "status wheel" like the new FB app. I hate that thing.
  23. kim king

    kim king New Member

    i really need my facebook fix on my android phone. made by: zte model no.: 930d

Share This Page