Support My fascinate is very laggy and slow to the touch

Discussion in 'Android Devices' started by andonakis, Dec 6, 2010.

  1. andonakis

    andonakis Well-Known Member
    36

    Oct 5, 2010
    159
    6
    36
    I'm not complaining just want some advice. Every time I open an app whether it be messaging, the phone, etc, it takes more than 5 seconds and it's becoming very annoying for a phone of this nature. Especially my camera when I need to take that special moment and i have to wait like 5 seconds or more like its thinking what button I pressed. I mean i had this with my BB but android? So can anyone give me some advice or do we just wait for the next major update? :thinking:
     

    Advertisement

  2. nitsuj17

    nitsuj17 Well-Known Member
    213

    Aug 16, 2010
    4,648
    654
    213
    NJ
    the "lag" on the fascinate is a well known issue. short of rooting and running custom kernels like some of us do, your best bet it to uninstall programs you dont use that may be running in the background and turn off sync for facebook and other widgets
     
  3. NOsquid

    NOsquid Well-Known Member
    78

    Sep 11, 2010
    634
    65
    78
    what are you running? LP? Lots of screens? Widgets? Maybe an app is running in the background. I would start by taking off my widgets one at a time. Then if that doesn't help look for something weird running in the background in a task manager.

    If you're counting 5 real seconds to open a system app that's not normal.
     
  4. miyooper

    miyooper Well-Known Member
    43

    Nov 1, 2010
    208
    29
    43
    Upper Michigan
    5 seconds sounds way to much and happening all the time is wrong. I'll have a lag stutter once in awhile. Under settings-applications-running services I turn off everything but talkservice,syncservice,swype and my known widgets. Also use task manager to make sure apps are off. Looking at your battery use under about phone also may show an app you don't want running.
     
  5. seanatsb

    seanatsb Well-Known Member
    43

    Sep 7, 2010
    123
    25
    43
    Before I rooted, I had a similar problem. Sometimes with camera, and sometimes other programs. It was definitely several seconds, but it did not happen all the time.

    I've now rooted and am running JT's 11/11 non-voodo kernel, and JT's superclean ROM. I have more apps and widgets than I did before I rooted, yet I no longer have that huge lag (granted I did remove some switch widgets, and replaced with beautiful widget switches). I'm using Launcher Pro with 7 home screens.

    So if you cant find a particular widget or background app that's causing the lag, I vote for you to join the root club.
     
  6. sdgdean

    sdgdean New Member
    5

    May 22, 2011
    1
    0
    5
    I had the same problem. Disabled or deleted the Feeds and Updates widget and it fixed the problem. See if it works for you.
     

Share This Page

Loading...