My Google Play apps won't updateSupport

Last Updated:

  1. adcockj

    adcockj Member

    About a week ago, my Google Play apps stopped updating. I can still get to Google Play, and it knows which apps it wants to update, and it starts into the downloading dialog, but it never gets anything downloaded. (Looking at the network monitor, it shows that nothing's being downloaded.) Right now, I have about a half dozen apps that want to update, and that process starts every time I turn on the tab, but no joy. I can stop the auto updater, and click on just one of the apps to update, and I get the same (non) thing.

    Everything else works fine...My Amazon apps update automatically, I can download maps/etc in Google Maps, Gmail works, etc. It's just the Google Play updates that won't work.

    I'm on ICS, which was updated (automatically) about a month or so ago. No root or anything like that -- strictly "stock". I was, however, in a slow data area (1x on my hotspot) at the time the problem started -- back on 4G now, using a Verizon mifi and/or Samsung S3.

    Any ideas? Thanx/Jerry

  2. adcockj

    adcockj Member

    One more data point...
    While Google Play will do search for new apps, it will not load new apps either.

    I'm not sure how it would even update itself if a fix/update comes out. ;-(
  3. lowlyworm

    lowlyworm Well-Known Member

    Did your battery get completely discharged at some point? I have had this happen twice to me recently. If my battery goes completely dead, after recharge, everything works except the Google Play Store. I tried deactivating and reactivating my Google account and that wouldn't work. The only thing that did work was a full factory reset. I just sent it in for warranty service. I don't really expect that to solve the problem, but I only have a few weeks of warranty left and figured it was worth a shot.
  4. lowlyworm

    lowlyworm Well-Known Member

    I got my 7+ back from repair about 2 weeks ago and it seems to be working fine. I deliberately killed the battery to see if the problem was fixed. It worked fine after the recharge.

Share This Page