My hero keeps dropping its wifi signal help


Last Updated:

  1. sniper1977

    sniper1977 Active Member This Topic's Starter

    Joined:
    May 5, 2010
    Messages:
    27
    Likes Received:
    0
    Hi my new htc hero is having trouble with my wifi/router, it conects if i turn the router off than on but then the conection drops, i then go to search for my modem and it says signal is strong but yet when i click on conect nothign happens, im sure its a setting on the router itself as my blackberry had the same trouble

    my router is -


    siemens gigaset SE587WLAN dsl


    thanks
     

    Advertisement
  2. Jaffa

    Jaffa Well-Known Member

    Joined:
    Nov 16, 2009
    Messages:
    1,185
    Likes Received:
    91
    Thius is a know issue, and there is a HUUUUGE thread... read it and hope for the best, sorry thats all I can offer, but my router works, I had the issue at the Parents house this weekend, but I ignored it because it seemed likea mission to fix it..
     
  3. sniper1977

    sniper1977 Active Member This Topic's Starter

    Joined:
    May 5, 2010
    Messages:
    27
    Likes Received:
    0

    yeh also read somewhere wlese its my router which has a known problem, what router should i buy so it works, i dont mind buying a new one as it crazes me :(

    somone said netgears work fine, what one would u suggest?

    thnaks
     
  4. Squiggy

    Squiggy Well-Known Member

    Joined:
    Mar 2, 2010
    Messages:
    360
    Likes Received:
    18
    I haven't experienced that problem. I'm on a 4-year old Belkin 54G.
     
  5. Jaffa

    Jaffa Well-Known Member

    Joined:
    Nov 16, 2009
    Messages:
    1,185
    Likes Received:
    91
    I think older units are better, or ones without N capabilities, not sure what mine is, its provided by my ISP.
     
  6. daveybaby

    daveybaby Well-Known Member

    Joined:
    Sep 21, 2009
    Messages:
    919
    Likes Received:
    105
    Try disabling n-mode in your router (limit it to 802.11 b & g only).
     
  7. astria

    astria Member

    Joined:
    Dec 28, 2009
    Messages:
    12
    Likes Received:
    0
    works well with my D-Link DI-524 (already 4 yrs old, 802.11g only)

    not so when using Connectify on my laptop with Atheros AR928X (802.11n 2.4GHz)
     
  8. amnesia

    amnesia Well-Known Member

    Joined:
    Jan 7, 2010
    Messages:
    72
    Likes Received:
    1
    I have a Netgear N router... works fine for my laptop, XBOX360 and Hero but my wife's laptop won't connect, even though it can see it.

    weird.
     

Share This Page

Loading...