My internal-SD was goneSupport

Last Updated:

  1. imjohnson

    imjohnson Member

    I can't access my internal-SD anymore after doing something for my i7500.
    Could anyone help me?

    I describe the story here.
    1. I upgrade i7500 to Gaosp Nightly (Android 2.2.1) successfully
    2. I copy the files on internal-SD to PC and replace back to internal-SD again. Something happen.
    I can't access internal-SD anymore, but the system still alive.
    3. I tried to format internal-SD using windows7, the internal-SD can't mount on Android anymore, and I can't enter "recovery mode" by now.
    4. I found some article in the forum and tried to fix it in "download mode" and "doing Odin".
    The system can boot again, but the internal-SD still can't be shown while connecting i7500 with PC.

    Could anyone help me on that? How can I rescue my internal-SD? Should I use external-SD instead of it if it's broken?

  2. Rastaman-FB

    Rastaman-FB Well-Known Member

    can you not format the internal sd from within the android os by going to settings> sdcard and storage.
    if the internal sdcard is unmounted then you should see an option to format
  3. bisanu

    bisanu Well-Known Member

    i have a similar question. i can acess internal card but i cannot see my media files (music) and i can see my pictures only in blur mode not clear
  4. imjohnson

    imjohnson Member


    The issue has been fixed after I use "odin" and replace boot loader.
    I can access internal-SD correctly after "reset to factory default".
    Let me describe the steps I did

    1. using "odin". : replace all SW part including boot loader.
    2. rest to Factory default
    3. Format internal-SD
    4. Mount internal-SD again

Share This Page