1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

My new "unlocked" g1 was factory reset, whats next?General


  1. Macabre

    Macabre Member

    So I purchased a g1 "unlocked" off ebay, and the owner said she/he performed a factory reset just before mailing it to me.

    I do not have a sim card that has a data plan, nor a t-mobile sim card.

    So as far as I know, I cannot tell if this phone as been unlocked.

    I can power it on without the sim card, and after reading about forcing it to start up depending on the rc30 something something something, I typed "<enter>reboot<enter>" at that screen and nothing happened (the guide claimed that typing that would cause it to work without a sim after being factory reset;).

    How to register the T-Mobile G1 without a sim or data plan - WebNetta

    I put my sim card in to it, but it then tried to make a google act for me (I do not have one), but it couldn't connect since my sim didn't have a data plan.


    I'm praying that since it attempted to connect and make a google act with an AT&T sim, that the phone is still unlocked after the factory reset was performed.




    My end goal is to use this phone as a mere wireless tool, without a sim, hopefully with Cyanogenmod 6

    I was going to follow this guide;
    Dream:Rooting - CyanogenMod Wiki




    I just want to have an application device that can also web browse at times (my friend has a g1 without a sim in it and somehow has it working as a web browser if there is wifi?)

    I was also told that Cyanogenmod 6 is the best option for my desire, is that correct?


    Thanks in advance for any help!

    I'm hardly intelligent when it comes to technology, so I'll probably need someone to hold my hand threw that guide as I progress.



    edits; I found this thread;
    http://androidforums.com/htc-hero/8...-hero-would-reset-cancel-unlock-revert-t.html
    That talked about an android hero, hopefully that applys to my g1 as well.



    edit edit; this is a trinket fun-phone, a mere wireless online device that I want to emulate my friends itouch and android phone's use.

    I'm actually in the market to buying a new phone, as my at&t contract is up in a few months (2, and i'm counting...).

    I was also wanting to know if there were any strong opinions on the htc aria vs android incredible, as I'm liking both phones - the aria is cute and small, the incredible superior, but i'd have to switch to verizon.

    Advertisement
    :
  2. kejlyCZ

    kejlyCZ Well-Known Member

    It means you probably have version newer than RC29, which has this security hole fixed. In RC29 typed text was executed in background, in newer it's fixed. You can check your version under Settings / About phone / Build number, Android version and if some unofficial mod is installed also Mod version.
    The procedure is also well described here:
    http://androidforums.com/g1-support/6564-activate-stock-g1-over-wifi.html
    I've downgraded, rooted, activated over Wi-Fi and installed CM6 according to this thread with no problems in 1,5 hour:
    Dream:Rooting - CyanogenMod Wiki
  3. Macabre

    Macabre Member

    Thanks for the link!

    Were you able to do all that without using a sim from the start? Or will I need to borrow a friends data-plan sim and actually get the phone started up past the "google account register" screen?
  4. Swizz

    Swizz Well-Known Member

    The entire point of the guide to activating over wifi is so you can avoid registering with a data package.
  5. Macabre

    Macabre Member

    I've been getting stuck on the guide at #10ish

    The phone asks me for SIM network unlock PIN, which I'm still assuming that my phone is unlocked?

    For me to proceed to the "touch the android" screen, i can "dismiss" this by pressing the on screen button, but according to the guide, one shouldn't be touching the screen at all cost during this setup.

    Am I going to have to find someone with a tmobile sim for me to do this? Or is this message perfectly ok to dismiss?



    precisely where i am; i can use the trackball to select dismiss, but now when i type in the long string from 9b, it is in the emergency call screen, and it does give me the desired error message.

    But now when I type "adb" in either the main touch-android screen, or emergency call screen, it just gives me an error message saying 232 is not an emergency number.


    ... i hope the message doesn't indicate that my phone is locked :confused:



    edit; I'm assuming that step 11, I'm not supposed to be running adb.exe just yet? I tried with and without running it at this step, and am trying to redowload everything just incase. Its ok to put all of this in one folder? (using a netbook with windows vista for this)



    edit edit; i researched a bit on vista conflicts since the drivers were listed for other windows OS, and have confirmed that my drivers are up to date and working properly. I'm able to access the phone directly threw My Computer and use it as a mass storage device (as other threads / people have claimed). So... yea stuck on #12.
  6. Swizz

    Swizz Well-Known Member

    Step 9 is where you get the phone to talk to the computer. You should be able to type it in regardless of what screen you are at, milage and colors always vary. Boot the phone up, type the string, if it was typed correctly you'll be able to communicate with your phone via adb and finish the process.
  7. Macabre

    Macabre Member

    So when you type "adb" in step 12, thats on your computer, not the phone?

    In that case, I am having OS conflictions (vista...) with the adb interface, as it merely runs and closes the prompt box immediately, there is nowhere for me to type.
  8. Swizz

    Swizz Well-Known Member

    The guide assumes you have a working knowledge on navigating and manipulating the command prompt. I would suggest googleing some tutorials on that subject.
  9. Macabre

    Macabre Member

    I'm good with cmd prompts.

    I looked over another site and their guide has an extra tid-bit that made a difference on my end;

    How To: Activate the G1 Without a Data Plan | TheUnlockr

    Their part IIIb #4, typing "telnetd" after the initial string, worked for me and I was able to get threw the guide.

    Almost...

    My phone wouldn't connect to my wireless network (which is SILLY and ANNOYING since my friend has the same phone and can connect to my network).

    So I went to a place across the street (a student center at the college I attend), that has free wifi, and the phone connected just fine.

    But...

    When registering my google acct, it refused to proceed with the setup.

    (I did have the wireless connection signal at the top of the screen, so I was defiantly connected).


    It kept saying that possibly my sim has no data plan (which obviously it doesn't).



    This is frustrating, I'm stuck on the last step.
  10. Baggy

    Baggy Well-Known Member

    //SIM network unlock PIN//

    sounds locked to me
  11. bimmernator

    bimmernator New Member

    At step 5, where it says to Hit <enter>, then type "reboot" and hit enter again. When I hit enter on the keyboard, it goes into emergency dial box. So I can only input digits at this step, instead of letters. Am I missing something here?
  12. bimmernator

    bimmernator New Member

    Never mind, I figure it out. I'm suppose to see the digits when typing in the word.
Loading...

Share This Page