My odd WiFi issue on my captivateSupport


  1. BMJENNAR

    BMJENNAR New Member

    New to this. I did a search but no one seems to be having the same problem I am.

    My wife and I just got a pair of captivates. I set up both of our phones on our home wifi network. Hers works just fine. Mine however, has the issue. When I connect to wifi with my phone, it says I'm connected on my phone and my router. When I try to do something over the internet it says I'm not connected. I've reset the router. I've done a master reset on my phone. I've connected to outside routers. No matter where or what I connect to my browser and the android market both say I'm not connected even though in the wifi settings it says I am. When I turn off my wifi on the phone I get my 3g service back and then I can use the browser and the market. I contacted att but they were useless with their lack of wifi knowledge. I sent an email to samsung requesting assistance but they haven't responded. I'm open to trying all avenues to remedy this. Please help if you can.


    Thanks
    a0810285-5422-4e4d-a47e-a483bb1ab0d8
    1.03.01

    Advertisement
  2. Emcnelly

    Emcnelly Member

    So you can't connect to any wifi networks? If this is the issue I'm unsure how you would fix this its very strange and I've never heard of it. You can usually connect to some wifi networks. I've searched it a little and you may not be obtaining and IP address even though it says your connected. I'll tell you if i find anything else.
    BMJENNAR likes this.
  3. BMJENNAR

    BMJENNAR New Member

    That's just it though. My phone says Im connected and gives me the same ip my router gives. It stays connected for about 10 seconds id say. Then whatever needs internet says Im not connected anymore. Does that make sense?
  4. Emcnelly

    Emcnelly Member

    Not at all its very strange though I've had similar issues with like Xbox and laptops but they could always be fixed with reseting the router or the computer or the wireless adapters. Unfortunately however great wifi is I've found its can be a pain sometimes and always has some kind of issue either on one end or the other that must be resolved. Ill keep looking though with how strange this is hopefully someone has figured it out.
  5. Emcnelly

    Emcnelly Member

    BMJENNAR likes this.
  6. BMJENNAR

    BMJENNAR New Member

    Excellent! I can't believe I didn't think of that. Thanks thanks thanks!!
  7. Carnivore

    Carnivore New Member

    I'm having the same problem. If I reboot the phone it works again for a while, then stops transferring any data over wi-fi even though it still says it's connected. My wi-fi sleep time is set to "never". Wireless router security is WPA2. No trouble with any other wireless devices around the house;
  8. BMJENNAR

    BMJENNAR New Member

    I'm not sure if it will help but you might try port forwarding.
  9. GaryS

    GaryS New Member

    The reboot worked for me, Thanks!
  10. BookLover

    BookLover Well-Known Member

    Try this in turns...

    1) Pull your simcard and surf on your phone for the same "while" as you indicated in your note above. Does it stay connected longer? If yes, maybe the simcard is bad. If same problem then try:

    2) Pull SD card. Put simcard back in. Surf for a while. Can you do this longer or shorter than (1) above? If longer, then possibly bad SD card. Or phone is just not liking how your SD card is interacting with it. In this case you should copy the SD card contents over to your computer and then reformat the SD card via the phone. Don't put things back on your sd card right away, but try Wifi again and see how long (if at all) you can stay connected. If you stay connected, then transfer content back to your SD card.

    If after 2) above resolves the issue and then you disconnect again, you probably have a bad app on the SD card.

    Report back after you've done some troubleshooting and if still probs, you might have to factory reset. Hope you can avoid this!
  11. rocketcuse

    rocketcuse Member

    I think I am having the same issue. Wifi actually works great at home. But what happens is when I go to work, it will reconnect me to my office wifi, but won't transmitt data, even though it says signal strenght excellent. Only way to get the wifi to work is to reboot the phone. Sometimes i will have to reboot when I get home.

    Very annoying! I had the phone for almost 4 weeks and it has just started happening the past 3-4 days. I have 2 more days left on my 30 day return period. Should I return it?
  12. BookLover

    BookLover Well-Known Member

    I had this prob yesterday.

    Try rebooting the wifi router instead.

    That cleared my prob.
  13. rocketcuse

    rocketcuse Member

    It would seem the Captivate has trouble switching to a different wifi signal. if that makes sense???

    I did a little mini test. If I turn off wifi before leaving home and turn it back on at the location I want wifi, it works correctly. a little pain in the *** but at least it's not a phone reboot.
  14. t-readyroc

    t-readyroc Well-Known Member

    I'm having the exact same issue. Every time I arrive home, Y5 kicks in & connects me to my home wireless network just fine - but though I'm connected, I can't access any data functions (GTalk, browser, etc).

    Yes, rebooting the phone does resolve the issue, but rebooting the dang phone every time I get home is quickly becoming a pain. Especially with the glacially slow start up process....

    *Edit -

    Just did some more searching & found this post in another thread. I think my issue is this one:
    I'm going to see if I can find an update for my dd-wrt distro when I get home.
  15. maerlim

    maerlim Well-Known Member

    I've had a little experience with Wi-Fi problems on my Captivate. It looks like under certain circumstances the USB interface on the Captivate can pick up the IP address 192.168.0.254. If your home wireless has the range 192.168.0.x, then you have a problem. That problem being that your phone will have an IP on usb0 of 192.168.0.254 (which may actually be your router's IP) and an IP from your wireless on eth0 of 192.168.0.x. If you end up with 2 interfaces on the same network in Linux, it won't know which interface to send the traffic through.

    Long story short, if your home wireless is in the 192.168.0.x range, try changing it to 192.168.2 or 192.168.anything-other-than-0. (Because you can't change the IP it gives usb0.)
  16. EarlyMon

    EarlyMon The PearlyMon Moderator

    Welcome to the forums!

    As a great tool, I highly recommend Wifi Analyzer - free, in the Market.

    Many have found their router is sharing the channel with a nearby neighbor and that can cause really weird conflicts on a wifi-sensitive phone. A simple fix on the router by specifying a free channel rather than "auto" has cleared up a lot of problems for people.

    As for rebooting the phone or the router - yes!

    Odd, regardless of router or phone maker - that also works for a LOT of Android users.

    Hope this helps!
  17. reventon

    reventon Member

    Thank you mod

    I won't be able to make any changes to school router. So what's the best way for that? I got the home internet working just fine.

    No amount of restart or any mods is working. If 2.2 will solve the problem i can do that too.
  18. EarlyMon

    EarlyMon The PearlyMon Moderator

    My pleasure, hope I can help.

    If it's a channel conflict or signal issue, Wifi Analyzer will help show it - I have a friend in IT support at a school and if others are like her, they'd welcome you showing them the results and they'd fix the problem. Hope that's so in your case.
  19. reventon

    reventon Member

    i have downloaded wifi analyzer. will come to know how it works in a couple of hours.

    thank you. appreciate it.
  20. EarlyMon

    EarlyMon The PearlyMon Moderator

    The trick to know is that you swipe the screen left or right - Wifi Analyzer has several screens, and shows a lot of info.
  21. Copronymous

    Copronymous Well-Known Member

    I'd been having all these same problems. Sometimes a reboot would do it.
    I continually had to reconnect to my work wifi (Cloudpath).

    I researched and found Wifi Fixer on the market: Wifi Fixer for Android

    It has, for the most part, taken care of my issues.
    EarlyMon likes this.
  22. smead

    smead New Member

    I used to have a similar problem, more with my ps3 than the phone and would have to reset both router and device to regain internet. Phone somehow fixed itself after a couple days, on the ps3 I finally set a static IP and it solved the problem.
  23. b534202

    b534202 Member

    Got another Captivate last week but was't able to connect at home, so I started turning computers off 1 by 1 until I get to the PS3. Instant connection.

    Somehow PS3 causes IP conflict or something with the Captivate WIFI. So I guess no WIFI for me when I play games :eek:

Share This Page