My phone has to be defective...Support

Last Updated:

  1. Bmxant

    Bmxant Well-Known Member

    5kbps down
    62kbps up

    Wait for it....

    2222ms Ping

    Tech support said the towers in my area are good...

    What's the chance of having a bad radio in the phone? This is disappointing :p

  2. Puddin422

    Puddin422 Well-Known Member

    That sucks. Take it back. That doesn't appear to be the norm AT ALL.
  3. BigCiX

    BigCiX Well-Known Member

    Wow......that's super slow!
  4. Bmxant

    Bmxant Well-Known Member

    I returned the phone.....AND..

    Same damn network issues PLUS


    The new phone has a white burn in spot on the number 7 if you were looking at the keypad :mad::mad::mad::mad::mad::mad::mad:
  5. KMPrenger

    KMPrenger Well-Known Member

    No problems here. 4.18 down and 1.58 up are the best tests I've seen thus far. Happy with that considering where I live.
  6. LeeRoc

    LeeRoc Member

    Mine only gets

    87 ping
    1.53 Mbps - down
    0.86 - up

    I'm thinking it should be allot faster giving that the area i'm in has excellent reception.

  7. Puddin422

    Puddin422 Well-Known Member

    Hate to say it, but take that one back, too. That stinks. :(
  8. Bmxant

    Bmxant Well-Known Member

    Just exchanged the phone for a new one, so hopefully the screen is fine. It's charging as I type..

    As for the data issue, I've been on the phone with techs for HOURS, they are finally calling me back at 7pm est to fill out a network problem report.
  9. BigCiX

    BigCiX Well-Known Member

    have u guys checked the bionic forums about their speeds. They are hitting 15, 20, 22 mbps. The highest i've gotten was 4.62 mbps. I guess that's all at&t has to offer us for now.

Share This Page