1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

"My Phone Number" showing as UnknownSupport


  1. KiwiLDA

    KiwiLDA New Member

    Can anyone tell me how to change the "unknown" my phone number under settings in the Ideos. Thanks!

    Advertisement
    :
  2. pogs

    pogs Active Member

    Same thing with our IDEOS, so I'll be interested to hear the answer to your question.
  3. olbriar

    olbriar Moderator Moderator

    It sounds like something pretty simple.. if you only knew lol. I'm sorry but I've never used your device and lack an answer. I would like to welcome you to AF and I hope an Ideos user here will soon come forth with an answer. I hope you enjoy the forums.
  4. foobah

    foobah Member

    Settings - Call Settings - Additional settings - Caller ID
    pogs likes this.
  5. pogs

    pogs Active Member

    Thanks for that foobah, must have worked as I did as you suggested and now can't even find where it said "unkown number", LOL. Cheers, Paul
  6. bbaa1376

    bbaa1376 New Member

    The likely issue is that your carrier doesnt program the number to your sim card and most androids dont have the option to set it. I put my sim in an older model flip phone, went into call register, MY Number and programed my number to the sim.. Put back in my Ideos and there it was....
  7. nu2andy

    nu2andy Well-Known Member

    I have the same problem as kiwiLDA and the suggestions don't work.
    I use 2Degrees Network and carried over my Telecom number and this does not show in > Status > My phone number. I tried putting the SIM card into 2 Nokia phones but there is no provision to enter the number.
    More Ideas please.:(
  8. pogs

    pogs Active Member

    I'm on 2Degrees using a 2Degrees SIM and number provided.

    I feel a bit stupid but looked on the U8150 just now and can't find "> Status > My phone number".

    Could you tell me where to find that?

    Cheers, Paul
  9. pogs

    pogs Active Member

    Hey, had to do some searching but I just found it - its actually under:

    Settings > About phone > Status (Phone number, signal etc) > My phone number (Unknown).

    so, as you said, sure enough it still says "Unkown". How strange...
  10. nu2andy

    nu2andy Well-Known Member

    An update for "My phone number". I've been in contact with 2 Degrees and there is a method to check your number in the phone. Touch phone (as if to make a call) Dial keyboard shows > Star + 001 + Hash > touch phone to make call > ussd > your mobile phone number is: 0274xxxxxx appears on screen.
    I have also contacted Huawei to see if they are working on an Update to the Ideos U8150 software to recognize My phone number.
    I'll report if there is any progress from them. Cheers Neil.;)
  11. pogs

    pogs Active Member

    LOL, good luck with trying to get any response from Huawei. I did have a response from them about stuff months ago (January I think) when we bought the phone, but I think customer service has been discontinued or is pretty much non-existant. Never had a reply to any question since then.

    I tried several times through a Huawei Australia/New Zealand hub as well but they could care less about replying to customer questions. I was going to be cheeky as suggest that they could possibly save a couple of bucks by deleting any webpages or links to customer support.

    Maybe you'll have better luck than me. Doubt there will be a software upgrade (like ever), but would be interesting if they do reply with a solution.

    Cheers, Paul
  12. nu2andy

    nu2andy Well-Known Member

    Hi Paul, Funnily, I have had replies to 2 previous emails I sent to Huawei. I Downloaded and installed Hi Suite which kept opening automatically when I started my comp.
    They told me to go to Tools > Settings > and uncheck Load at startup.
    It wasn't checked!!! I emailed them again and got the same reply.
    I sent them a reply referring them to their first instruction and what I had done to fix it. I installed a program called Autoruns which showed Hi Suite as an auto start - I deleted it and all's back to normal. (I had tried msconfig and unchecked all entries to HiSuite and Huawei which didn't stop it from opening).
    I am hopeful that they will supply an update to correct this issue just like we get KB's from MS. Cheers Neil.:D
  13. nu2andy

    nu2andy Well-Known Member

    Just received an email from Huawei apologizing and they say they will fix it in their next Version. Cheers Neil.;)
Loading...

Share This Page