My Samsung Nexus S won't turn on even after pulling out the battery


  1. coldplay01

    coldplay01 New Member

    Hi,

    I know this has been a common problem for most samsung nexus S users, and I have read the other threads but none of the solutions are working. My phone randomly turned off last night while I was chatting on Whatsapp and it wouldnt turn back on. I puled the battery out and put it back on, and no change. I tried putting it on charge using the wall charger and USB and the battery screen wouldn't show up. So i googled it and read a couple of threads about removing the battery, putting the USB cable in and replacing it...tried that and did not work. Lastly, I tried to reboot it using the volume up and down + power button and that also did not work. I have had this phone for two years now, it has been working perfectly fine despite the lagging from the Jellybean upgrade. It is not water damaged, just a couple of chips on the screen and general wear and tear. I did not drop it in the past couple of weeks either. i feel helpless and I really want my phone to just power on. Can anyone help? Maybe I am doing something wrong.

    Advertisement
  2. Rush

    Rush {<>}~{<>} Guide

    Hi coldplay01,

    Welcome aboard.

    Thread moved to its support forum for assistance. :)
    coldplay01 likes this.
  3. Chad

    Chad Active Member

    I'm pretty much in the exact same boat, except in my case I let the battery drain to empty over the weekend, which put the phone into an endless boot loop. It actually would load the OS and lock screen, but as it was preparing USB storage it would reboot itself after a few seconds.

    I turned it off for a few days (I was away from home), and after finally accessing the fastboot recovery I tried clearing the cache... but it didn't help. I let it boot loop a few more times as I tried to access settings before it rebooted (no luck), and after one final battery pull it just stopped turning on or showing a charging icon on the screen.

    I took it to a sprint store hoping it was just a bad battery, but they said the phone was toast. Thankfully I had dropbox automatically uploading photos to the cloud, and my contacts are all in gmail.

    I hope you have better luck than me!
  4. coldplay01

    coldplay01 New Member

    thanks chad, it feels so much better knowing that I'm not alone in this one. I was actually so scared I thought I did something wrong but I guess this happens to many people with this phone. The problem is that there is no way to fix it unless I do send it back to samsung, which hopefully won't cost me too much....

    Or I can just buy a new phone...I don't think I can get all my pictures and what not back, since the phone is all internal memory and I didn't have it backed up (stupid me).

    But thanks for sharing!

    I am currently trying to find an estimate on how much the repair would cost, if it is possible.
  5. Chad

    Chad Active Member

    I did end up taking mine apart last night and verified that all ribbon cables and such were still plugged in. I thought maybe a power button cable had come loose after reading another thread where a guy said a loose ribbon cable was the culprit. Unfortunately for me, everything was plugged in, and no amount of unplugging and replugging seemed to help.

    If you want to open it up yourself, ifixit.com has good walkthru's and pics of the process. However, if you're considering paying to have it repaired, they may not want to do it if it's been opened up already. (I have no idea, really)

    I still would like to try a new battery in mine just for kicks, but I doubt that'll help. I probably will just bite the bullet on this one since I do have an old phone to use until I upgrade to the upcoming HTC One. I'm a bit bummed that I can't send in this Nexus for a buyback discount, but oh well.
  6. pkvats

    pkvats New Member

    exactly the same experience while chatting on whatsapp. no leads to solve the problem. tried all unbricking utilites and black magic....just stuck with a dead black beauty.


Share This Page