My SD Card has used space even after formatting it??


  1. Athar93

    Athar93 Member

    This is a very wierd problem, i really dont understand what is wrong with my 16GB Class 4 SanDisk Memory Card. The data on my memory card has stuck, Niether I can delete it nor i can add, copy, paste anything into it.. But I can copy the data in it to my PC..
    I tried to format it with my android phone Dell Venue (Cyanogen Mod 7.2) but no use.. I tried to format it through the recovery still no use... When i format it in my PC it shows format is complete and when i open the memory card in my PC it appears empty, but as soon as i stick the mem card back into my phone the data appears again... The 7.7GB in my mem card are used and i cant delete it...
    I tried different softwares like SDFormat for formatting my mem card bt all in vain..
    I used Command prompt to format it took around 20 mins to format but still the data was back.. Im frustated because i cant find any solution to it..:confused:
    Please help me out.. !!! :(

    Advertisement
  2. SUroot

    SUroot Well-Known Member Developer

    Sounds like your phone still shows the data even though its not there. If it doesn't show data in other devices, the card should be fine.

    When you format a card, the file system is simply a reference to the location of each file. Sounds as if your device is providing that reference...

    Would be interesting to see what other cards show
  3. XplosiV

    XplosiV Master X is Watching You VIP Member

    You could try formating through your pc using swissknife

    SwissKnife 3.34 Download | Hard Disk Utils

    Maybe change to a different file system then change it back to its original? Not sure if it'll help or make a difference though.
    Athar93 likes this.
  4. Athar93

    Athar93 Member

    I inserted a different 2GB micro SD card into my dell venue and it showed the original data that it had in it.. What does this mean???
  5. SUroot

    SUroot Well-Known Member Developer

    Its hard to say.

    I assume you cant take a nandroid backup of the device if you can't write to SD?

    My initial thought (and this is literally a stab in the dark) would be that the device would benefit from a factory reset and the card formatted elsewhere. I think its a device issue rather than a card issue, though your test does nothing to prove this.
  6. MacFett

    MacFett Well-Known Member

    I would do a nandroid backup and then reflash the ROM.
  7. Athar93

    Athar93 Member

    Did that already reflashed the rom formatted he card else where.. Still its no use!
    I guess i should buy a new one.. I tried every damn method i could... Goofled for hours and tried their methods but still its no use.. :(
  8. SUroot

    SUroot Well-Known Member Developer

    But the card works fine in a pc?
  9. Satires

    Satires Well-Known Member

    I use ubuntu. I manually delete all the partitions and make a new fat32 partition. This happened when I had a "Truecrypt" partition on an sd card I decided to use in a smartphone. The only way I could delete that partition was using a disk manager in ubuntu linux.
  10. Speed Daemon

    Speed Daemon Disabled

    If this is one of those cards that has Windows apps stored in a hidden location, and copies them to the FAT partition whenever you plug it into a Windows machine, you need to go to the maker's website for a utility that allows you to change the hidden part. For everything else, you can use just about any Linux "live boot disc" to get a Linux environment up on any PC w/o the need to install it, find the device that's the flash drive. (Use lsscsi if it's available.) Find it again to make certain, and use this simple command:

    dd if=/dev/zero of=/dev/sd?

    where the ? above is the letter (usually b, c or beyond) of the flash drive. What you'll end up with is a flash drive with nothing at all on it. Youshould be able to build a new partition table and filesystem like normal if it's not broken.

    If that doesn't work, check for any tiny lock switches on the device (I have a couple like that) or contact the manufacturer for help in resetting it.

    I bricked my first SSD when I tried to do a firmware upgrade on it, and brought it back to life with the help of the drive's OEM. It never hurts to go to the source and ask.

Share This Page