Mytouch 3G stuck on splashing screen


Last Updated: 2011-08-11 16:37:54
  1. cminusa

    cminusa New Member

    Guys,
    I am in desperate need of some help here. I am not an expert in android devices hence please be as clear in directions as possible. I really appreciate you guys taking time out to read and post a reply.

    I got a friend's mytouch 3g to use...but when i insert my sim card, it past the green mytouch 3g screen and got stuck on splashing colors screen. I removed the battery, reinserted and its doing the same thing. I even did a factory reset but still no luck. I did some search and found the hboot and fastboot (did factory reset using the fastboot) so i dont think its bricked yet...
    These are the setups it shows from hboot

    SAPPHIRE PVT 32B ENG S-OFF H
    HBOOT-1.33.2005 (SAPP30000)
    CPLD-10
    RADIO-2.22.19.26I

    Any and all help is appreciated.

    Thanks in advance!

    Advertisement
  2. Raven198

    Raven198 Well-Known Member

    Is the phone rooted? How long are you letting the splash screen play for, before pulling the battery?
  3. cminusa

    cminusa New Member

    Not sure if its rooted. He didnt tell me that...I let it run for like 10 minutes or so hoping it will go past that screen but then i removed the battery. I tried pulling the sd card out and put back in but still no luck
  4. dasudevil

    dasudevil Well-Known Member

    i had this issue once. I let it run for 2 hours and still nothing.

    Take out your sim card. Boot up. Keep the card out. Should start up after a while. Give it 10 minutes if it works (should mine did) reboot it without sim card. Make sure it boots up again. Then play with the phone for a bit. 10 minutes. Play a game or something. Then reboot again, (NO SIM)

    If it boots with no sim card its your sim. After the 3rd time of booting and rebooting i inserted my card back in then everything seamed to work. I dont know what it was or what was causing it but it did not do it again.


    If none of that works you need to find out if your rooted or not before we proceed.
  5. cminusa

    cminusa New Member

    Thanks for the reply...

    I tried doing this...let it ran for almost 2 hours...but no good.


    How can i say if its rooted or not as i am not able to log into settings or any other function.

    TIA
  6. cminusa

    cminusa New Member

    Any takers on this?
  7. Raven198

    Raven198 Well-Known Member

    Try booting into recovery. To do that with the off, hold the home button and to power button until you see it say "booting into recovery". If it does that, then you are rooted and might need to flash a new rom. Try that and let me know, we can get you into a new rom easily after that.

    Also let me know what recovery it has, if it has one.
  8. scarlet84

    scarlet84 New Member

    A quick little trick to get unstuck in a pinch is to power the phone on and hold the power button and the center button (the touchpad button) until the phone cycles. It's worked for me everytime! Hope this helps.

Share This Page