1. 2015 is going to be a great year for Android! Why wait??
    Samsung Galaxy Note 5 | Samsung Galaxy S6 | HTC One M9
  2. New Forum Created: Samsung Gear VR!

Mytouch 4g boots into safe mode


  1. roypeled

    roypeled Member

    I have a rooted s-off mytouch 4g with JellyBelly ROM. The other day it rebooted into bootloader and the volume keys were unresponsive. It was next to bricked. Than miraculously they became responsive and I could reboot. BUT it reboots into safe mode and I have no access to many apps. At some point I gave up and did a 'factory reset' assuming that would help and I will then go and reinstall my apps. But even after the factory reset, it still boots into safe mode. Driving me nuts.

    Any ideas?

    Many thanks,

    Roy

    Advertisement
    :
  2. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    i moved you to the mytouch 4g root forum where folks with your device can help you better.

    do you have a recovery? did you make a nandroid backup? you can try and wipe dalvik cache and cache and re-flash your rom.
  3. roypeled

    roypeled Member

    Thanks, I will look there, I'm not very fluent with all of this so I wouldn't know how to re-flash my ROM. I tried wiping cache and dalvik cache. I don't know what a nandroid backup is.
  4. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    a nandroid backup is a way to back everything that is on your device. it will back the rom, kernel, and all of the data and settings on your phone. it is like a save point in a game. if you were to mess up or something like this happens you can always go back to the nandroid backup.

    what recovery do you have? keep in mind that i do not have your device, but most recoveries are very similar.
  5. roypeled

    roypeled Member

    i don't know if this answers your question - ClockWorkMOD Recovery v. 5.0.2.0

    Many thanks,

    Roy
  6. scary alien

    scary alien not really so scary Moderator

    Hey Roy, I've read many times that a device does unwanted boots into safe- mode because of stuck keys/toggles.

    Have you checked for debris or broken keys that might account for this?

    Cheers!
    roypeled and ocnbrze like this.
  7. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    ok clockwork mod is your recovery....cool beans.

    so all you would need to do is:

    1. make a nandroid backup first (this is more for practice for you as the rom you are on as of this moment is not working correctly). this can be found in the backup and restore option.

    2.go back to the main menu when done and select wipe, i believe (its been a while since i have been on CWM) and wipe dalvik cache(found in advanced on the main menu, i think), cache, factory reset, and system....i would wipe all 3x to make sure you have a clean install.

    3.hopefully you have a rom on your sd card. if not download a rom of your choice and move to the sd card. i'm not sure if you can do that in safe mode or not. if not then you can mount the sd card through recovery. i believe it is under mounts and storage. there should be a mount usb iption there. once mounted, you can then move the file over to the sd card. DO NOT PUT IT ANY FOLDER, JUST ON THE CARD. it makes it easier to find in recovery.

    4.back in the main menu there should be install .zip from sd card option. select that and then scroll down and find the rom file and select it.

    now you have just flashed a rom!!!!!!!:D

    hope this helps.
    roypeled and scary alien like this.
  8. roypeled

    roypeled Member

    Thanks, Scary Alien, that's interesting because I had an issue with the volume keys and thought something might be broken there, but now they're responsive and work perfectly normal as do all other keys.

    Ocnbrze, how do I know if I have a ROM on my SD card? The only files in the root directory are very small files one .ndif one .config_c38 and one qf. all the rest is in directories. So i don't think I have one.
    ocnbrze and scary alien like this.
  9. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    you have to download one. here is a list of roms you can try:http://androidforums.com/mytouch-4g-all-things-root/481321-mytouch-4g-all-things-root-guide.html

    or you can go to xda to find more roms:
    http://forum.xda-developers.com/forumdisplay.php?f=796

    this one looks pretty cool, if you like sense:
    http://forum.xda-developers.com/showthread.php?t=2140831
  10. roypeled

    roypeled Member

    ok, I'm going for it. Keep your fingers crossed for me.

    What about GAPPS? I see I have to dl that too, when do I install it? after step 4?
  11. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    which rom are you going to flash? the one i linked is a sense rom and there is no need to flash gapps.
    roypeled likes this.
  12. roypeled

    roypeled Member

    No, I am about to Flash Jellytime, just caused it seemed to be very new and has 4.2.1. I don't know what sense is. Does it matter which I flash?
  13. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    no that is up to you which one you want to flash. and if it says to flash gapps then that is what i would do.

    so here is what you do:
    1.download rom and gapps files
    2.move them to the sd card
    3.make a nandroid backup
    4.wipe dalvik cache, cache, factory reset, and system
    5.flash rom
    6.flash gapps
    7.reboot

    done!!!!!!
    roypeled and scary alien like this.
  14. roypeled

    roypeled Member

    ok, you're not going to believe this. I did the whole thing. I went well, everything works. I'm still in Safe Mode :(
    ocnbrze likes this.
  15. scary alien

    scary alien not really so scary Moderator

    Have you tried a battery pull?

    A few sites that I Googled suggested this (didn't see this mentioned before...).
    roypeled likes this.
  16. roypeled

    roypeled Member

    if you mean pulling the battery out for a while and putting it back in place, then yes, dozens of times for any period between 1 second and 12 hours. I now have another problem, back to the bootloader screen with the volume keys unresponsive. What I noticed earlier, which may seem strange, is that some time they respond if I press them while connecting the USB cord (it's charging from my desktop). This make me think in the direction you suggested earlier (pressed key), but still, when the phone is on and running all the keys seem to operate normally.

    Sorry for being such a difficult case...

    Roy
    scary alien and ocnbrze like this.
  17. ocnbrze

    ocnbrze DON'T PANIC!!!!!!!!! Moderator

    its not you, its your phone. weird i'm not sure what you can do next. it might be a hardware issue then. i have seen this a few times but flashing a rom usually takes care of the issue.
    roypeled likes this.
Loading...

Share This Page