N1 wifi Issues solved with Gingerbread


  1. Mostly Harmless

    Mostly Harmless Well-Known Member Contributor

    I have always had an issue with the wifi on my N1 when trying to connect to my router at home. Getting a connection use to be hit or miss, I would often try connecting over and over again with no success. Even when I did connect it would drop out as soon as the phone when into standby.

    Well to my surprised after downloading/installing GB I went to attempt to get on wifi and it connected right away. I was shocked to say the least. I turned it off and tried it again and it connected again. Then I put the phone in stand by and it still stayed connected. Then I had to run to the store and left wifi on, when I got back to my apartment it connected again, no issues. This is completely awesome!

    Advertisement
    :
  2. Cudda

    Cudda Well-Known Member

    If that's true, that is completely awesome. Can anyone else confirm? I hate having to turn off and on the wifi because it doesn't reconnect itself when it loses connection.
  3. chimphappyhour

    chimphappyhour Well-Known Member

    Nope, it didn't fix my problem connecting to the wifi at work. Still says connecting until it retries.
  4. NunyaBidnez

    NunyaBidnez Well-Known Member

    So far it looks as if the wifi disconnect problem is gone.
  5. ap3604

    ap3604 Well-Known Member

    I'd have to agree. I haven't had a single issue with the wifi once I upgraded to Gingerbread.

    Before I would turn the screen off and even if I set the wifi sleep policy to "NEVER" it would still lose connection and I would have to turn the wifi off and on in order to reconnect.

    With Gingerbread though the Nexus One seems to have finally been fixed from this problem :D
  6. Dolmangar

    Dolmangar Well-Known Member


    Did the manual update on friday and my WiFi issues aregone too. I've got a mac address with 00 issue.

    If you're still having issues verify that your router has the latest firmware. That solved an issue we had with my wife's iPad's wifi when we got it last year.
  7. droid_nexus

    droid_nexus Well-Known Member

    wifi is working great now for me
  8. JDlawyer

    JDlawyer Well-Known Member

    Just downloaded Gingerbread. So far so good. I've had wifi issues with my N1 from day 1. I just uninstalled WiFi Fixer. This would help but did not completely resolve my problems. We'll see if Gingerbread fixed the problem.
  9. JDlawyer

    JDlawyer Well-Known Member

    Have not noticed any problems with my wifi connection since last night. It looks like Google finally solved the wifi issues with the N1 with Gingerbread. That's great news because this was the only complaint I had with this phone.
  10. Cudda

    Cudda Well-Known Member

    My problems are gone too!
  11. theartfullodger

    theartfullodger Well-Known Member

    Seems to connect easier & stay connected better. Thanks (finally...) Google...
  12. skdyer

    skdyer Active Member

    I too was pleasantly surprised to discover that the wifi issue "appeared" to have been solved. But upon further investigation I think we are being duped. Yes, under gingerbread we no longer have the issue where it will appear to disconnect and not reconnect after sleep BUT it isn't actually staying connected when asleep. Here are two easy ways to verify this? #1 Put your phone to sleep, wait 20-30 minutes, and then ping your phone's IP address. 100% of packets will be lost. #2. Same thing, put your phone to sleep, wait 20-30 minutes, and then send yourself an email. You will not receive a new email notification and in fact your new email will not show up until you turn on the phone and manually sync your gmail. What first tipped me off to this problem is that when I woke up in the morning I NEVER had new emails waiting for me on my phone's gmail client (even though I had received emails over night).

    Bottom line, though it may appear that this issue has been fixed due to the wifi indicator appearing in the notification bar after waking from sleep, the phone really is not maintaining a functioning wi-fi connection while asleep. This is VERY disturbing because this means we are unknowingly missing new email notifications when our phones are asleep. At least the way it was working before the wifi would disconnect and it would fall back to 3G for email checks.

    Can others investigate this on their phones and see if you are experiencing the same behavior?

    I CANNOT believe this issue is still not fixed.
  13. Rusty

    Rusty Well-Known Member

    That's odd, even if wifi is getting turned off during sleep, you should still get emails through mobile data.

    Unless because wifi is set not to sleep, mobile data doesn't turn on, perhaps.
  14. skdyer

    skdyer Active Member

    I believe that is exactly what is occurring. The Wi-Fi is in some strange idle state where it is on but not active so the cellular data connection doesn't take over.

    And yes, I have the wifi policy set to never sleep.
  15. Dolmangar

    Dolmangar Well-Known Member

    I get my emails at night, sometimes more than once, on multiple accounts. I generally have WIFI on but perhaps my phone is failing over to 3G more gracefully. It's also plugged in on my nightstand so that may cause it to stay awake even though the screen is off.

    The only way to really test this would be to pull the SIM or go to airplane mode then turn on WIFI. Probably should test with both GMAIL (push) and Yahoo (Pull) email accounts to see if there is a difference.
  16. Soupdragon

    Soupdragon Well-Known Member

    Not sure if I'm helping, but incase it adds to the info pool; I leave the house - my phone goes onto 3g and if I encounter a wifi network then it lets me know ( I have that option enabled) and then when I return to the house it automatically connects to my wifi (but on the notification bar BEFORE I unlock the phone it shows 3g and then as I unlock it the 3g symbol goes and is replaced by the wifi one). After that, even before unlock, it remains on wifi until I, once more, move out of range of my home wifi.
    I do receive emails and market updates overnight and anytime the phone is "asleep" whilst in the house - the symbols (new email & updates available) are visible in the notif bar before unlocking, and I'm assuming these have come via wifi.
    So, for me, the situation skdyer reports (Quote =You will not receive a new email notification and in fact your new email will not show up until you turn on the phone and manually sync your gmail. Unquote) isn't the case.
  17. Soupdragon

    Soupdragon Well-Known Member

    I should have added that I used to, sometimes but not every time, have to turn off/turn on my wifi because it was still on 3g even tho I had returned to my house.
    Now I'm not sure if it's since ginge or since I switched on "notify me when wifi is available" but it's been no problem recently.
    Do you guys have the notify enabled? It would make sense to me that by switching this on you are saying to your phone that you'd like it to use wifi if it could, so then when you get to a place where it recognizes and (thru saved passwords etc) can connect without your assistance it then does so.
    I know, it all sounds a bit anthropomorphic or whatever the tech equivalent is, and, if course, the theory falls apart if you are using that setting but still having issues.
  18. Mostly Harmless

    Mostly Harmless Well-Known Member Contributor

    Well all I am going to say it that the performance of wifi post-GB is 100% better then pre-GB. I walk into my apartment and turn on my wifi, it connects and stays connected, if I leave it alone and come back to it 4 hours later it still works. Pre-GB my phone would connect to my network maybe 20% of the time, and that is on the high side. It would often just sit and try to connect. What ever is happening with the phone I am very pleased with it and can cross one thing of the list of issues I have with my N1 (a short list).
  19. blisterpeanuts

    blisterpeanuts Active Member

    I have not noticed much difference between 2.2.2 and 2.3.3.

    Wifi still disconnects when phone is hibernating, but it usually reconnects ok. But when entering a different wifi hotspot, it sometimes needs to be told to reconnect to a known service instead of reconnecting automatically. This seems to happen less often than it did under Froyo.

    I still get 4 bars but no service in my office building, some kind of weird Nexus radio/antenna/tower issue in this neighborhood that will never be solved. I'm on my 4th N1 and 2nd SIM and all have had the identical issue, ever since at least 2.1 OS. I can take the SIM out and put it in a Blackberry and have full service here :(

    The can't-update-apps-on-SD problem went away with Gingerbread, which is nice; don't have to move the app from SD to phone, then update, then move it back to SD anymore.

    Aside from my radio glitch which no one else seems to have, the N1 has been nearly perfect. Wifi performs very well and the phone seems a tiny bit more stable in Gingerbread than Froyo.

    Can't wait to see what 3.0 will be like on the N1!
Loading...

Share This Page