Native Mail App - HTML Images Not Showing in Email Using Exchange ActiveSyncSupport


  1. RFclipse

    RFclipse Active Member

    I'm having an issue where inline images in emails sent to my Exchange account are not displayed in the body of the email. There's only a white space shown where the image should be. If I select "reply" or "forward", the image is properly displayed. On occasion, the "Display Images" button is displayed at the top of an email, but this only appears maybe 20% of the time. The remaining times, the images do not appear and there is no option to make them appear.

    I first noticed this issue after updating to ICS via the OTA update. I've confirmed that images display properly with other mail clients such as K-9. I tried deleting my Exchange account and re-adding it, and I've also tried clearing the cache in the mail app. Neither has solved this issue. Has anyone else experienced this or have any advice on how to resolve it? I'd like to avoid a factory reset if possible since I don't have time to reconfigure everything and can't use Titanium Backup due to lack of root.

    Thanks!

    Advertisement
  2. acejavelin

    acejavelin Well-Known Member

    Hmmm... my first thought is to open the mail client and then press Menu->Settings->Send&Receive and increase the Mail Size Limit to 50KB or Maximum Size (use this one with caution), Message Format is set to HTML, and Auto Download Message is checked.

    If this doesn't seem to fix the issue, go to Settings->Apps->Mail and clear data then resync. If all this fails, a factory reset is probably in order... remember that anytime you make a major OS change, such as from GB to ICS, a factory reset is recommended. Without root, using MyBackup is a handy tool, but you should not backup/restore the applications themselves when changing from GB to ICS, they should be each reinstalled from the Play Store or you potentially will just be restoring a problem.
  3. Ted1Jones

    Ted1Jones Well-Known Member

    See my earlier thread, ICS Exchange Email Hyperlinks Don't Work. I still have the problem and I believe it is caused by some obscure setting in our Exchange Server 2003 that doesn't work well with ICS, since you're the only other person to say they have the same issue. I've even tried installing certificates. I am hoping it will get fixed by an update or when we move to Exchange 2010 (next few weeks). In the meantime I continue using the native email app and just open K9 if I want to follow a link.

    Note that none of the things mentioned by acejavelin worked for me. ICS/Rezound/Exchange will not allow you to set the message format to "HTML".
  4. RFclipse

    RFclipse Active Member

    Tried all suggestions but nothing resolved this issue. Finally did a factory reset as a last ditch effort. Brought up an email with embedded images without loading any other apps, and the issue is still present. :mad:

    Looks like ICS does not play nicely with my Exchange server.
  5. acejavelin

    acejavelin Well-Known Member

    A few other users have noted this as well, there is a flag in the Exchange Server that can be toggled to allow images to be displayed in ICS, it is ignored in GB that is why you had no issues. I am not sure if it is a user-level flag or something on the domain or a higher level, no one at my company has had that issue so I never dug into the server to find it and figure out what it is called, would be somekind of ActiveSync settings I would imagine though.
  6. RFclipse

    RFclipse Active Member

    Thanks for the info! If anyone know's how to configure this, please let me know. Unfortunately I assume my IT department won't do it anyway since they're not happy that I have business email tied to my personal phone. All I know is I'm never going back to BB, even at work!
  7. acejavelin

    acejavelin Well-Known Member

    Yeah... IT can be real pain... try large quantities of chocolate candy or varying amounts of chocolate chip cookies, Mountain Dew, and/or pizza, it tends to make the rules fuzzy and get things to go your way in the IT world, I know it works on me. :D
  8. Ted1Jones

    Ted1Jones Well-Known Member

    I think the problem is with HTC's implementation of ICS. I had the same problem on the new Incredible 4G (one reason I returned it) and I still have it on the Rezound. I did not have the issue when I tried the Samsung Galaxy S III. Very few Exchange users (you and I) have reported it.
  9. Sambo01

    Sambo01 New Member

    Well add me to this list-= exact same problem. It is my wife's Rezound actually. My Incredible and her DroidX (before it died) all worked fine. Maybe it is an ICS problem with the Rezound, but it is extremely annoying and I wish someone could address this.:mad:

    She is not a happy camper, and of course that makes life hard on her live-in tech support...me.
  10. RFclipse

    RFclipse Active Member

    Strange thing is that I've recently tried this out on 4 different phones since I've had 3 replacements in the last two weeks (don't ask). This issue was present on two of them, but not the other two. All running the same software. Definitely not an issue with my company's exchange server. Weird...
Loading...

Share This Page