NATPC Corrupt. Freezes on start up

Last Updated:

  1. KevinMaguire

    KevinMaguire New Member This Topic's Starter

    Jan 24, 2013
    Likes Received:
    Hi folks I have a NATPC ( New Android Tablet PC ) it is the M010S and is ModelType 'MID'

    It freezes after about 10 seconds on start up and i can only power it off by holding the power button down.

    When i tried to hold the power and volume up button on start up to do a factory reset, I get the picture of the green android lying down with a red triangle and exclamation mark on it.

    I have tried some methods to reboot from an sd card to try and reflash or reload the os but no luck.

    Would anyone know of any working software which will allow me to reboot from an SD card and reinstall the android os?

    The current android version is 4.0.4

    Many thanks

  2. DonB

    DonB ♡ Spidey Sense !! ♡ ™ Moderator

    Nov 30, 2009
    Likes Received:
    We do not have a section for the tablet, so I will move it to the general tablet talk section, so you can best be served.

Share This Page