navigator with droid issues - help please?


  1. Jerry-rigged

    Jerry-rigged Well-Known Member

    Howdy gang -

    I fired up the Google navigator today for the first time at lunch (had to find a goverment building). the good thing is it found the building, and it was in a part of town I knew, but the bad - the droid would not follow my car.

    I just though "Eh, buggy app". Then I get back from lunch and see the thread about the Engagit polls, and what do you know, the Droid with Google Navigator is #1 by a WIDE margin. So I am guessing I am doing something wrong or have a wrong setting on my phone.

    It did find the correct location.

    It did map an accurate route to the location.

    In the Map Screen, It would not lock GPS - said "searching for GPS" the whole 15 minute drive.

    the normal google map "My location" was suddenly off by about 1/2 mile - I knew where I was and I was almost out of the circle that "My Location" puts on the map. Usally "My Location" is accurate to about a city block.

    Anyone have a clue what I am doing wrong?

    Oh - and the phone is stock - no root, extra OS, theme, etc...

    Thanks,
    Jerry

    Advertisement
  2. Gunner

    Gunner Well-Known Member

    Make sure the GPS radio is turned on under Location settings, or use the Power widget to make sure it's on.

    If this was the 1st time you used GPS (and it was turned on), it can take a few minutes to get satellite lock. The phone will generally get sat lock faster if you're out under open sky, and not moving during lock acquisition. After the 1st sat lock, subsequent sat locks will happen much faster.
  3. Jerry-rigged

    Jerry-rigged Well-Known Member

    Thanks-

    I just checked under locations - GPS is turned on...
Loading...

Share This Page