Need a little WIFI help.


Last Updated:

  1. Moondonkey

    Moondonkey Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    13
    Likes Received:
    0
    I can't get on the internet at school. When you first bring a new device onto their network, a screen should pop up for you to enter your user name and PW. This does not happen on my Droid. I am fairly tech savy, and have poked around with all the network settings on the phone.

    Anyone had a similar issue and found a resolution? I was wondering if there was an app that could resolve my problem? I installed a # of them from the market, but none of them helped.

    Thanks in advance,

    Moon
     

    Advertisement
  2. CRPercodani

    CRPercodani OFWGKTA VIP Member

    Joined:
    Oct 24, 2009
    Messages:
    2,940
    Likes Received:
    564
    If you have WiFi turned on then I don't know why it isn't showing you the available networks. You can use the power control widget to easily turn it off and on, if it won't find your WiFi at school maybe you can try at home or somewhere else and if it works then you know it is a problem with the school network. If not then you most likely have a hardware problem and should return it for a new one.
     
  3. Moondonkey

    Moondonkey Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    13
    Likes Received:
    0
    It don't have any problem connecting to other networks. At school, It see's the network connection, but internet connection does not happen, I'm guessing, since the authentication screen does not come up. I even ran a network analysis app, and the device is seeing over a dozen connections of the schools network mesh.

    So I am pretty sure it is not a hardware issue of the phone.
     
  4. CRPercodani

    CRPercodani OFWGKTA VIP Member

    Joined:
    Oct 24, 2009
    Messages:
    2,940
    Likes Received:
    564
    What kind of security is the school's network using? I would imagine Android is capable of using all types but that could be a issue perhaps.
     
  5. mooshu47

    mooshu47 Active Member

    Joined:
    Nov 7, 2009
    Messages:
    28
    Likes Received:
    0
    Have you already tried manually configuring the network? Under Wifi settings if you long click the network and click Connect, you should see a dialog where you can configure security and enter a username / password. If you don't see that for your particular network, tell the phone to forget the network, then click Add a Wifi Network and try it again.
     
  6. Moondonkey

    Moondonkey Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    13
    Likes Received:
    0
    Maybe I don't know how to long click, but when I hold down for a bit on the school network, the only option it gives me is to forget.

    I tried to manual configure the network. using, none, WEP, WPA/WPA2 PSK and 802.1x Enterprise, and nowhere in any of these did I see a place for a username.

    Have you seen a screen that asks for username?
     
  7. mooshu47

    mooshu47 Active Member

    Joined:
    Nov 7, 2009
    Messages:
    28
    Likes Received:
    0
    Yes, it was on the "Add Wifi Network" dialog and I had to fill it in for my company WiFi to work. Admittedly the UI is not really very friendly. What would be nice would be the ability to select an existing network and have a "Configure" option. Anyway, I just walked through it again and I can give you more exact steps:

    1. Open Wifi Settings
    2. Click "Add a Wifi Network"
    3. Enter the SSID and click the security Drop down.
    4. Select your security Method. (I selected 802.1x Enterprise. This is probably the only security option that presents you with the additional inputs needed.)
    5. After selecting that option the dialog will change and will include the following options:

    EAP Method
    Phase 2 Authentication
    CA Certificate
    Client Certificate
    Identity (i.e. network username)
    Anonymous Identity
    Wireless Password (i.e. your network password)

    For my network, I had to select PEAP, then MSCHAP for the Phase2 Auth. I left the certificates blank, since our Wifi does not require them. I then entered my domain username for the "Identity" field. I left "Anonymous Identity" blank and entered my network password under "Wireless Password". I was then able to connect successfully.

    Hope this helps!
     
  8. Moondonkey

    Moondonkey Member This Topic's Starter

    Joined:
    Nov 13, 2009
    Messages:
    13
    Likes Received:
    0
    Cool thanks Moo, I will give that a try on Monday!
     
  9. Canefan

    Canefan Active Member

    Joined:
    Dec 11, 2009
    Messages:
    26
    Likes Received:
    0
    I have a very similar problem at work. I can connect to the router with a strong signal but the network requires you to go to a screen where you can accept the terms and conditions of the open network. My browser will not take me to that screen. My previous MinMo phone and my laptop work fine. I am also very tech savvy and have tried just about everything but I just can't make it work.:mad:
     
  10. clos1084

    clos1084 Well-Known Member

    Joined:
    Nov 11, 2009
    Messages:
    187
    Likes Received:
    8
    can you just get the URL to accept the terms and conds and type that on the Droid browser?
     

Share This Page

Loading...