Need APN Help,No data/MMS, Straight Talk, Captivate CM10, 4.1.2


Last Updated:

  1. hefftone

    hefftone Member

    I just activated my Straight Talk sim, in my Captivate with CM10, JB v4.1.2.

    I set up the APN for straigt talk, calls and SMS work fine.

    But I can't download MMS content (just says downloading in my messaging panel) The cellular internet access is completely non-existent. I also seem to have a weaker signal than before (same area, still AT&T)

    Can someone help me with the settings (currently):

    Name= StraightTalk ATT
    APN= att.mvno
    Proxy= proxy.mvno.tracfone.com
    port= 80
    username= not set
    Password= not set
    Server= not set
    MMSC= http://mmsc.cingular.com
    MMS proxy= 66.209.11.33
    MMS port= 80
    MCC= 310
    MNC= 410
    Authentication type= not set
    APN type= default,supl,mms
    APN protocol= IPv4
    (APN Enabled= check marked and grayed out)
    Bearer= Unspecified

    Advertisement
  2. DragonSlayer95

    DragonSlayer95 Resident Air Bender Moderator

    Did you root your captivate while on the att network?

    A possible reason why this is happening, cm10 that your running is meant to be for the att network and not the straight talk/track phone network.

    But I'll dig deeper and see what I can find.

    DS
  3. sdrawkcab25

    sdrawkcab25 Well-Known Member

    agentc13 and DragonSlayer95 like this.
  4. teddyearp

    teddyearp A guide with guides

    Yess, you must make sure the MMSC settings are changed as well like in the second thread linked above.

    good luck
  5. nunie3308

    nunie3308 New Member

    hi i have an htc one x with straight talk AT&T NETWORK i tried some different apn with half of what straight talk says and some setting from att you might try this one it worked for mine
    name=straight talk
    APN= ATT.mvno
    PROXY= proxy.mvno.tracfone.com
    PORT=80
    NEXT 3 SPACES= NOT SET
    MMSC= mmsc.att.net
    MMS PROXY=proxy.mobile.att.net
    AUTHENTIC TYPE=not set
    APN TYPE=default,admin,fota,mms,supl,hipri
    bearer = unspecified

    also if you have the byop and using the net 10 sim card it should be the t-mobile apn and not the at&t. thats the thing at&t and straight talk split that's why you cant get them anymore straight talk/AT&T sim cards only the t-mobile net 10 and in some areas t-mobile service is not good at all HOPE THIS HELPS
  6. nunie3308

    nunie3308 New Member



    TRY THIS APN
    hi i have an htc one x with straight talk i tried some different apn with half of what straight talk says and some setting from att you might try this one it worked for mine
    name=straight talk
    APN= ATT.mvno
    PROXY= proxy.mvno.tracfone.com
    PORT=80
    NEXT 3 SPACES= NOT SET
    MMSC= mmsc.att.net
    MMS PROXY=proxy.mobile.att.net
    AUTHENTIC TYPE=not set
    APN TYPE=default,admin,fota,mms,supl,hipri
    bearer = unspecified

Share This Page