NEED HELP! Android Market Error - "App Name" could not be downloaded due to an error. (404)Support


Last Updated:

  1. AndroidUser23

    AndroidUser23 New Member This Topic's Starter

    Joined:
    Jan 5, 2012
    Messages:
    1
    Likes Received:
    0
    I have a Sony Ericsson Xperia Play.

    When I try to download apps through WiFi, it works... When I try with my Data Connection, it doesn't.

    When I open Market with my Data Connection and try to download an application, an error pops up saying:

    " "App Name" could not be downloaded due to an error. (404) "

    I cannot seem to figure out what the solution for this prolem/error is... I've tried many solutions that people have suggested but I still can't download apps on Market through a Data Connection. Only WiFi.

    Yes, my Data Connection does work... I can use the Browser, YouTube, Facebook, even apps that i've downloaded through Market (thanks to WiFi for letting me download it)

    Failed Attempts:

    "Clearing Cache/Data"
    "Settings Reset"
    "Factory Data Reset"
    "Setting up E-Mail on phone in sync to my Google Account"
    "Uninstalling Market Updates"
    "Turned phone off, took Battery and SIM Card out then put it back in, turned phone on"
    "Updated my Sony Ericsson Xperia Play"

    Etc, Etc, Etc...

    Please, if you can help me out with this problem, I would greatly appreciate it.
     

    Advertisement
  2. Digital Jester

    Digital Jester Well-Known Member

    Joined:
    Apr 3, 2011
    Messages:
    76
    Likes Received:
    12
    Sounds like it could be some issue with your carrier. Who are you with?
     
  3. pcbroch

    pcbroch New Member

    Joined:
    Feb 18, 2012
    Messages:
    1
    Likes Received:
    0
    Have you had any luck fixing this? I find I have exactly the same problem with my Galaxy Nexus. Works over wifi but not 3G!
     
  4. Unforgiven

    Unforgiven -.. --- - / -.. .- ... .... Moderator

    Joined:
    Jun 23, 2010
    Messages:
    31,658
    Likes Received:
    28,655
    While I have not seen that error personally or in the forums, you could try wiping data and cache for the Market. This seems to help a lot of market issues.

    Goto Settings | Apps | All | Market and you should see the buttons there. I hope this helps.
     
  5. lantern20

    lantern20 New Member

    Joined:
    Aug 10, 2011
    Messages:
    2
    Likes Received:
    0
    Not sure if you got this solved, but I found this post and reselected my account in Google Play and that solved the problem. I'm on 2.3.7 and it worked for me.
     
  6. Arkza

    Arkza Member

    Joined:
    Mar 8, 2012
    Messages:
    15
    Likes Received:
    1
    I had the same problem and a power cycle fixed it
     
  7. Arkza

    Arkza Member

    Joined:
    Mar 8, 2012
    Messages:
    15
    Likes Received:
    1
    Edit: never mind, I was being stupif
     
  8. Responder

    Responder New Member

    Joined:
    Jun 17, 2012
    Messages:
    1
    Likes Received:
    0
    I also had the same problem and searched for a solution. The problem appeared after upgrading to Android ICS. All the above proposals did not work. What resolved the problem is clearing the PROXY in the APN settings. If you're on ICS, do the following. Open the Settings > More... > Mobile Networks > Access Point Names > [Your APN Name] > Proxy - clear this field.

    Hope this helps someone.
     
  9. eyalmat

    eyalmat New Member

    Joined:
    Jun 17, 2012
    Messages:
    1
    Likes Received:
    0
    This is the solution: go to System Settings > "More..." in Wireless and Networks > Mobile Networks > Access Point Names (APNs) >press the menu button, inside the menu press "Reset to default“ > now another option will appear called "Internet 3G" (modem) , besides the "Portal 3G". Choose the new option "Internet 3G" and you are done! =] here's a screenshot:
    http : / / i47 .tinypic .com / 2njbv2u. png (delete spaces)
     

Share This Page

Loading...