Need help rooting 2.1-update1, Unable to update to 2.2. Camera not working.

Last Updated:

  1. livelifescott

    livelifescott Member

    Hi guys, been looking on the forums for a few days now and couldnt find anything that was relating to my issue. So hear goes.

    I got my Evo 4G a few days ago. I went home a tried to root it.
    Somehow I went from 2.2, to 2.1-update one.
    I have no idea how, I should have read more.
    So the automatic upgrade on the phone says everything is up to date, which it's not since I'm not on 2.2
    When I try to root it, I keep getting the BOOTLOADER - BYPASSED thing and it is refusing to root. (At least that's why I think it is)
    When I try using Unrevoked, it just says it failed and asks: Root Failed: Are you using a newer firmware?
    I'm not really sure what I should do about it. And help would be great.
    By the way, I have tried wiping the phone a doing everything blah blah blah.
    Oh, and my camera also doesnt work after I "rooted" it. It just shows a black screen.

    Also, here is my phones info:

    Firmware Version:

    Baseband Version:

    Kernel Version:
    htc-kernel@and18-2 #1

    Build Number:
    1.32.651.1 CL171253

    Software Number:

    Browser Version:
    WebKit 3.1

    PRI Version:

    PRL Version:

    Thanks again for any help.

  2. Matlock

    Matlock Well-Known Member

    What method did you use to ROOT the first time?

    Once ROOTed, you can't receive an OTA, so your device is tricked thinking it is up-to-date.
  3. akazabam

    akazabam Well-Known Member

    It shouldn't be too hard to get you back on track. Turn the phone off, then turn the phone back on while pressing and holding the volume down button. That will take you to hboot. What hboot version do you have, and does it say s-on or s-off at the top?

    Also, please answer Matlock's question. It will certainly be helpful.
  4. livelifescott

    livelifescott Member

    Thanks for the quick help guys.

    The first method I used to Root was Unrevoked.
    My HBoot version is 2.02.0000
    And at the top it says S-Off
  5. akazabam

    akazabam Well-Known Member

    Did you try to unroot (RUU or PC36IMG) at any point? I'm not sure exactly how you ended up with 2.1 without knowing more details about what you did. In any case, you still have the hboot you had before (I assume that's what you started with), and it's s-off, which is good. When in hboot, if you select recovery, does it take you to clockwork?
  6. livelifescott

    livelifescott Member

    I havent tried to Unroot yet I don't think. When I ran RUU it asked for a backup (I think) and I didnt have it.
    When I go into recovery I get the black screen with the Phone and <!> on it.
    The last time I was here I pressed the Volume Up button and the Power Button, but this time that does not seem to be doing anything.
  7. akazabam

    akazabam Well-Known Member

    So, wait, did you at any point try to run a RUU (exe from the computer) or follow any instructions that had you put a file named on the sdcard and flash it from hboot? When you ended up with 2.1, I assume you lost all apps/data, is that correct?

    Let's do this. You can boot up fully, correct? Let's make sure you actually have root in the ROM (a good possibility you don't at this point). Install a terminal emulator from the market:

    Android Terminal Emulator - Android app on AppBrain

    Open it, and type "su" without quotes, then enter. If the prompt changes from $ to #, then install ROM manager. At the top, you have the option to flash Clockwork recovery. If you got a permission denied error back at the terminal, download the following file, and make sure it stays named, exactly:

    Connect your phone to your computer and make sure you select the option to mount it as a disk drive. Put the file on the root of your sdcard (not in any folders). Reboot into hboot like you did before (turn the phone off, then turn it back on while holding the volume down button). You should be prompted to flash the

    Once either of the above two options are done, reboot back into hboot if you aren't already there. Select the option for recovery. Had you done the ROM manager method, you should have Clockwork recovery. If you did the PC36IMG method, you should have Amon RA recovery. Either way, it will be a black screen with menus.

    Let's just get that far, then I'll give you more instructions if it works. I don't want to give you too much at once. It can get confusing, I know.
  8. livelifescott

    livelifescott Member

    I ran it, got confused because I saw Windows Mobile stuff, and closed it. (Kinda gave up quick on tha one, it was 4am).
    Yes my phone can fully boot up (looks like I got one thing going for me.)
    When I typed "su" in the terminal it did change from $ to #
    When I was in ROM Manager, I did get that error.
    I already have on my PC, so I'll just put that right on the Root of my SD card.
    HBoot did it's thing with the blue bar right off the bat as soon as I turned the phone back on holding the 2 buttons.
    It asks me if I want to start the update, so I pushed YES
    [2] BOOTLOADER - Bypassed
    "Can not roll back hboot version"
    And everything else went fine and I rebooted the device.
    I cant get back into HBoot because as soon as I go back into that menu, it tries to update it again instantly and does not give me a chance to click anything else.
    Should I boot into disk mode and remove the zip file?
  9. akazabam

    akazabam Well-Known Member

    1) Do you have superuser installed? Install it if you don't:

    Superuser - Android app on AppBrain

    I forgot to ask before, but you do have root, so that's good. Once you do that, try to open ROM manager again. You should get a prompt to grant it su permissions. If that works, proceed to flash recovery as I instructed above. Remove that PC36IMG file from the root of the card, by the way. If that does not work, proceed to the next step (read it anyway, there's valuable information)

    2) You're luck that PC36IMG file didn't work. It's the contents of a RUU (probably an old one). It would have wiped everything. It probably has something to do with how you got 2.1 in the first place. That being said not all PC36IMG files are equal. It's a generic file name used to flash things from hboot. It can have anything inside. Every time you boot into hboot, it will try to flash it. So, delete that one you have, download the one I linked to (they are very much different things), put that one on the root of the card, then flash it from hboot like the other one.

    Assuming either of the two above options are successful, check recovery as instructed in my previous post.
  10. livelifescott

    livelifescott Member

    Ok I installed and did whatever I had to do with Superuser
    I then flashed with Clockwork in ROM Manager
    And thanks, I was unaware that the PC36IMGs could be different.
    I checked the PC36IMG that I had, compared to the one that you gave me, and yes, they were 2 completely different things.. like.. no even close haha.
    I went into the HBoot menu and it just went on it's own (a lot faster than the last one that I had.)
    And then it prompted me to rebbot the Evo so I've done that.
    What now? :)
  11. akazabam

    akazabam Well-Known Member

    Oh, you ended up doing both things? Sorry, I meant to do one or the other :). No biggie. At this point, I think the easiest thing for you to do would be to unroot and get everything back to where it should be. Once that is done, you can reroot without messing with the ROM version. You could also just flash any old ROM you want right now, but you'd have to update your radios manually.

    So, let's just do this. Boot back into android, and flash Clockwork through ROM manager again. You probably overwrote it with RA, but it's not a big deal. Once that is done, download this:

    Put it on the root of your sdcard like you did with the PC36IMG files (do not rename this one). Boot back into hboot, then select the option for recovery. You should have clockwork, now. If you don't for some reason, stop and let me know. Otherwise, select the option to flash a zip, and select the unrevoked forever zip. Once it's done flashing, reboot back into hboot. You should have s-off. If you don't for some reason, repeat the steps to flash unrevoked forever until it does read as s-on.

    Now, download this PC36IMG file:

    MEGAUPLOAD - The leading online storage and file delivery service

    You must rename it to (as I'm sure at this point you've done before. This one just comes named a little different). Do the same exact thing you've done before to flash files in hboot. You must use this file exactly. WARNING - it will wipe everything, so if you haven't backed anything up, do it before you flash this.

    Once that is done, and you reboot, you should be at square one. If that's all successful, go to software information (where I know you've been before), and let me know what you see (updated baseband, hopefully).
  12. livelifescott

    livelifescott Member

    Ok then, sorry about that :p
    So I flashed the Evo with the Clockwork thing in ROM manager
    I put the file directly on the root of the SD Card still in its zip format
    I removed the old zip file and added the new one and renamed it as you instructed
    So I currently have 3 Zip files on my SD Card Root.
    1) Update
    2) PC36IMG
    3) Unrevoked-Forever
    I booted holding down the buttons and once again the HBoot just went right into it.
    Everything went smooth with that.
    My current Baseband is and I am back on 2.2, thanks a lot!
    Also my camera works again, is there anything else I should do?
  13. akazabam

    akazabam Well-Known Member

    Ah, sorry, I totally gave you the wrong file. I meant to give you the s-on tool, not unrevoked forever. Jeez, sorry about that. It doesn't really matter, as it seems everything worked, but you should still have s-off. Sometimes it causes problems, but everything seems ok. At this point you probably have android 2.2, no custom recovery, but still s-off (my fault). It doesn't matter too much though. Just go ahead and run unrevoked. I'm not sure what went wrong before as I didn't get many details on it, but if you follow the instructions here, you should be fine:

    That will:

    a) Give you your custom recovery back
    b) Root your current Rom

    It may or may not give you errors when it flashes unrevoked forever since you already have s-off. Assuming that finishes, you will be where you need to be - custom recovery, s-off, and a rooted ROM.

    Now that I'm reading what you did, did you even flash unrevoked-forever (wouldn't have done anything) or did you just flash the PC36IMG file?

    OH, one more extremely important thing. Before you run unrevoked again, remove that PC36IMG file from the sdcard. It will most definitely interfere with the process. Every time you go to hboot, it will try to flash.
  14. livelifescott

    livelifescott Member

    I don't think that I did anything with Unrevoked now that I think about it.
    Oh well, it seems like everything is working fine for right now.
    Should I even bother doing anything with Unrevoked?
  15. akazabam

    akazabam Well-Known Member

    Yes, you should, but go ahead and verify these things really quick just to make sure:

    1) You now have android 2.2 with SW version 3.30.651.3
    2) When you boot into hboot (after having removed the PC36IMG file), you have s-off and hboot 2.02 still
    3) In hboot, if you select recovery, see if you have a custom recovery
    4) Boot back up normally, and do the root test again by install a terminal emulator and typing su. My guess is it will say permission denied.
  16. livelifescott

    livelifescott Member

    Yep. All that software stuff matches up with what I have.
    I remove the PC36IMG and now I just have the and in there.
    My HBoot version is 2.02.0000
    In HBoot when I go to recovery I just get that black screen with the Little Cellphone and the <!>
    And I did get the "Permission Denied" when I did the SU Test
  17. akazabam

    akazabam Well-Known Member

    Yep, you're exactly where I thought you'd be. Run unrevoked3 following the instructions in the rooting for dummies thread. You have no more need for PC36IMG files now.
    livelifescott likes this.
  18. livelifescott

    livelifescott Member

    Thanks for all your help buddy, there's no way I would have ever got this done on my own haha.
    If you don't mind me asking your personal opinion, what is a good ROM to run in terms of battery life and performance?
    I mean, I see a lot out there, and they all kind of say that they have the same things included. I do like the HTC Sense overlay though, should I just keep with the Stock ROM and just do a Root?
  19. akazabam

    akazabam Well-Known Member

    It's really up to you whether or not you want a custom ROM or want to stick with stock. Custom ROMs have the benefit of having bloatware removed already generally, being more efficient most of the time, allowing you to theme, etc. If all you want is to run root only apps and nothing more, you have no need for a custom ROM. It's up to you.

    Here's a good post on some of the more popular ROMs:

    The rooting for dummies guide is an excellent guide for flashing which ROM you choose. Personally, I have myn's warm right now, but I will be trying out a few others such of Mikfroyo. You really just need to find what you like best. Always remember to make a nandroid backup, and you can get back to where you were before if you don't like a particular ROM.
  20. livelifescott

    livelifescott Member

    Ok I'll have to give that a shot. I'll look on YouTube for how to make a backup
    Real quick though, I am following that guide that you posted for me and I have downloaded the drivers for the Phone, how do I go about installing them, there is not a setup.exe or anything like that.
  21. akazabam

    akazabam Well-Known Member

  22. livelifescott

    livelifescott Member

    This was happening to me before, when I go to Device Manage, where it SHOULD say Other Devices > Android 1.0, instead I get Android Phone > Android ADB Interface along with Android Bootloader Interface, how do I know which one I should use?

Share This Page