Need Help Rooting ZTE Majesty


  1. Sparkster691

    Sparkster691 Guest

    I just bought a new ZTE Majesty from Straight Talk. It arrived just yesterday and ever since I got it, I've been trying to find ways to root it... but to no avail. I've tried several different methods such as doing it manually, Superoneclick, and this one way I found on Youtube (How to Root Android 4.1.2 (Jelly Bean)(Universal Method)). Now, the one on Youtube actually kind of WORKS, but the problem is that it doesn't stay... and when you try to run a root program, it says something like "Superuser cannot request super authority" or something like that. After a restart, the Superuser disappears from the phone.


    I do realize this is a new phone and all... and what makes it worse is that it is Android 4.1.2. There has got to be someone out there who has cracked this already. If there is, please do help. My brain is melting from trying to figure this stuff out XD

    Does anyone think it has to do with the bootloader at all? I'm not sure if my bootloader can be unlocked or not because I can't enter the service menu. Hmmm...

    Thanks so much you guys.

    Advertisement
    :
  2. redjama

    redjama Guides Guide

    Welcome to Android Forums.

    The only thing I can tell you is to become a member here on Android Forums and just keep watching for a thread. I searched the net myself and found nothing on this phone. Its just a matter of time before a dev or someone else starts messing with the phone and starts posting stuff.
    scary alien likes this.
  3. scary alien

    scary alien not really so scary Moderator

    Hello there! :)

    Some comments and notes:

    - In researching this, I believe that found your thread over on AC ([Help] ROOTING a ZTE Majesty - Android Forums at AndroidCentral.com).

    - That led me to find the thread on XDA:

    [APP][ROOT] Android 4.1.2 Rooting Universal Method - xda-developers

    - I believe the language the app is written in and for is Chinese (Simplified Han, according to Google). The link for that download site is: RooMaster (I used Chrome's offer to translate it into English for me); also, here is their change log: RootMaster UpdateLog

    - there are many subtle tasks that you need to make sure you properly complete as described in the video. I'm guessing that missing even one of them would have a similar effect to what you are seeing about it half-working, although its still entirely possible that this method does not work for your device. So, make sure you've very carefully followed all of the steps mentioned in the video.

    - You might also want to try or investigate Framaroot:

    [ROOT] Framaroot, a one-click apk to root some devices - xda-developers

    I don't have any direct knowledge or experience with your device or the above rooting methods (especially RootMaster), so keep in mind that there are always risks involved in root-related activities and especially ones where the things that are going on behind-the-scenes (i.e., in RootMaster) where the methodology is opaque, is a bit scary (i.e., know the risks and that you assume full responsibility for anything that goes awry).

    The folks over at the XDA threads would be the best for answering any additional questions about the above two rooting methods.

    Best of luck and safe rooting!

    :)
    Spil and Sparkster2691 like this.
  4. Sparkster2691

    Sparkster2691 New Member

    Wow thanks for the comments guys! :) I did try those 2 but they wouldn't quite work. RooMaster... If I unplugged my device before it shut my device down. it installed the SU for a short period of time and would disappear. I think I might need to be patience... but I'm so use to having root access! Its tearing me apart lawl

    Edit: Oh and I've searched XDA for a solution but I couldn't find one. I was starting to think it had to do with boot loader or fast loader.... or something.
    scary alien likes this.
  5. thelology

    thelology New Member

    I found a way to root it with impactor, its not permanent, but easy to do. lasts for at least 30 mins and can use root apps still working on permanent root though, but just figured this process out today.

    1. power off phone
    2. hold power button and both volume buttons on boot, to enter safe mode
    3. plug phone in to pc
    4. start impactor.exe
    5. click start to install superSU
    6. once finished check device is rooted with terminal or basic root checker app
    7. reboot phone out of safe mode
    8. run impactor again
    9. check root
    10. complete steps 1 - 9 if start getting mount:read only system error.

    There are other options on the impactor i havent tried yet, but i can confirm that barnacle wifi tether works with it while rooted, really my only reason for needing root. If anyone knows a way to get more options to show under MORE..., than just vp settings please let me know what needs to modified. this works on ZTE Majesty 4.1.2 jelly bean.

    here is the download for the Impactor, i'll leave it up for a couple days!

    http://www.geekquo.com/ feel free to download it
    jwilke101 likes this.
  6. jwilke101

    jwilke101 Member

    I have tried the above steps and they work temporarily.. Has anybody successfully rooted a zte majest Z796c yet?
  7. dogdayz

    dogdayz Well-Known Member

    Its pretty weird how the stock recovery looks like
    *wipe data/and factory reset
    *partition cache
    *select update.zip file from external storage
  8. unknown002us

    unknown002us New Member

    Any way to replace the factory reset with some sort of different type of flash or some other setup by the way I'm new to the Linux and the Android and the root topics just an old PC tech that would like the same freedoms on my zte majesty
  9. dogdayz

    dogdayz Well-Known Member

    Yea sum sort but any ways when I go to settings where it says *update..it says download update package to sd-card...well I heard Dis zte android phone is unable to be rooted its really not bad of a phone I Haven't had problems wit it
Loading...

Share This Page