Need help to root HTC desire (Android 2.2.2)


  1. robertboyl

    robertboyl Member

    Hi, everyone

    I want to root my wife's HTC desire (bought from amazon.com unlocked) - HTC A8181 Desire Unlocked Quad-Band GSM Phone

    1) Is there any chance for someone to help me if I pay some fee? Via chat or something, as I dont have any rooting experience?

    2) The phone gives me just 137 MB available RAM after a fresh reset... Is that normal? Its very little space for my wife to add her apps, etc. always running low, my major intent to root is to be able to delete some apps that come with it that she doesn't use, so she has more space...

    3) I followed this FAQ on using Revolutionary, which seems to be the best way to go, based on other posts of users using Android 2.2.2.

    http://androidforums.com/desire-all...ry-windows-published-4th-november-2011-a.html

    I imagine I did something wrong, as when I get to the part of loading Revolutionary, it says "waiting for device" and doesnt detect it (although I can see it mapped as a drive, I also tried other options that phone gives me such as HTC Sync, USB tethering, etc).

    Pls, any ideas? Here are the phone specs:

    hboot-0.9.4.0001
    android 2.2.2
    pvt3

    sw 2.33.161.6
    build # 2.33.161.6 CL345089 release-keys
    kernel 2.6.32.15-g2633d94
    webkit 3.1
    baseband 32.49.00.32u_5.11.05.27

    Thanks!

    Advertisement
  2. Hadron

    Hadron Well-Known Member

    Hi robertboyl, and welcome to AF :)

    Right, let's see if I can complete this before Firefox crashes again...
    If you mean internal storage rather than RAM, then sadly that is normal, and was a stupid thing for HTC to do. The good news is that you can fix this if you are rooted, so this is the correct first step. The bad news is that deleting pre-installed apps won't help at all! The reason is that those live in a different storage partition, so removing them won't give you any more space in the /data partition, where user apps and data live.

    So once you are rooted, the next thing to do is to read the Root Memory FAQ, which is linked in the All Things Root Guide sticky post. Then we'll be able to advise on the options.
    Now I've never used revolutionary, and don't use Windows for managing my phone, so there's going to be an element of guesswork in my suggestions.

    First thing: have you got USB debugging enabled? Look in menu->applications->development. I think this is the most likely problem.

    The phone should not be connected in disk drive mode - try "charge only" if that's an option (haven't had HTC software on mine for > 18 months), but certainly not disk drive, and I wouldn't expect HTC Sync to be the right mode either.

    Have you got HTC Sync installed? If so, uninstall it (but leave the drivers). Also did you install the hboot drivers? These are both in step 1 of the guide, so I assume this is done, but best to check. And did you install the fastboot drivers from the revolutionary documentation page (I don't think that's the issue here, but you'll need them later)?
  3. robertboyl

    robertboyl Member

    Dear Hadron,

    Thanks a lot!!! I just need to find some time to do this. A colleague also recommended cyanogenmod ROM.

    Im just a bit afraid to brick phone and my wife kill me :)

    Now the phone has 137 available RAM without any app installed by her. If I root it, then from the FAQ you mentioned, Id still have to flash some ROM to it, correct? Then I can use app2sd and move basically all apps to SD, so a Id have a lot of free space for apps, if sdcard has 1 gb, 1 gb of apps? :)

    The procedure on cyanogenmod seems very similar to the one on the sticky that I mentioned here on the forum, I guess only difference is it also explains how to flash their ROM, something I understand Ill also have to do... HTC Desire (GSM): Full Update Guide - CyanogenMod Wiki

    Although I see some positive posts on cyanogenmod site, I see some people having issues like no sound after flashing that rom... Is there some recommended ROM that's really safe? Im basically changing the software the phone is running, still android, but customized, etc and I see this risk of crashes and other problems arising.

    Anyways, Ill try the procedures again and follow your tips soon.

    Thanks again!
  4. Hadron

    Hadron Well-Known Member

    The a2sd thing is a little more complicated than that. Have you read the root memory faq, linked from the All Things Root Guide sticky post? The a2sd they refer to there requires you to partition the sd card, then apps are stored in a second (linux format) partition on the card - it's not the same as the "move to sd" option you already have.

    Once rooted the first thing you should do is take a backup from the (now customised) recovery. A recovery backup, aka a nandroid backup, backs up your ROM, apps and data, so if something goes wrong when you change ROM, or if you just don't like it, you restore the backup and everything's back how it was before. So there's no risk in trying CM7 and seeing how you get on with it, because you can undo it in a couple of minutes. Other non-Sense ROMs that are currently popular round here are MildWild's themed/tweaked CM7 and Oxygen based ROMs, Oxygen itself, and dGB. The last however is probably slightly advanced for a first ROM, since to get the most from it you need to make some further changes to the phone.

    I've not used a Sense (HTC software) ROM for more than 18 months, so can't give personal recommendations on those.
  5. robertboyl

    robertboyl Member

    Hi,

    Yes, I did read the root memory faq. It seems the ROMs let you decide where to store, if on the ext partition or elsewhere (at least from screen shots of the MildWild ROM you mentioned which I was checking out and looks neat).

    I can nandroid and backup even before rooting, then theres almost no risk of bricking the phone, correct? Or I can only nandroid and backup the ROM after rooted?

    Risks of bricking device in such procedures exist in which cases?

    I will try to find time to do this or perhaps ask a colleague of mine who already has done similar processes. I did only 1 first attempt when I posted the message to you, will see if I try a bit more and follow your advice tomorrow... :)

    Thanks.
  6. shauny13

    shauny13 Well-Known Member

    you can only nandroid backup after root, as the rooting process installs a custom recovery which allows you to do this.
  7. robertboyl

    robertboyl Member

    Guys,

    Phone rooted and backed up :) Now Im trying to follow the root memory FAQ, part about partition...

    I made a Live CD for Gparted, followed instructions to plug in USB only at keyboard mapping part (BTW what should I choose here, leave keyboard mapping untouched?), it detects the phone...

    The thing is, when choosing SD and asking to resize, it does not let me change space after which is set to 0... Free space = 0, New size = 7576 and Free space after = 0 (and I cant click on top arrow to increase size).

    Please advise?

    Also, these ROMs like Wildfire all have a2sd+? I was hoping to get some ROM that already has it.

    Also, if you can kindly guide me to some guide on how to flash the ROM...

    BTW, when I ran revolutionary, after it did its procedures, it requested if I wanted to install Clockworks recovery, I informed yes. So that part of procedure I didnt follow guide as it offered it to me. I rooted it, backed it up, all ok...

    Im just having problem to resize the partition... Can I go directly to this process Flashing Cynanogen Mod with Clockwords? http://wiki.cyanogenmod.com/wiki/HTC_Desire_%28GSM%29:_Full_Update_Guide

    Thanks a lot!!!

    Update: if I ask for info in Gparted it says cant open /dev/sdb1, cannot initialize drive...

    Not possible read contents of file system and says cause can be a missing package, and for fat32 it says dosfstools and mtools are needed. How can I install that considering Im using LIVE CD?
  8. Hadron

    Hadron Well-Known Member

    Technically that's not true if you use Revolutionary. The sequence is:

    * S-Off
    * Flash custom recovery
    * Use custom recovery to flash root files

    So it's actually possible to take a nandroid backup after installing the custom recovery but before rooting! Of course people usually don't, but the option is there.

    With unrevoked you had to be rooted first, because as you say both the recovery and the rooting were done at the same time.
  9. shauny13

    shauny13 Well-Known Member

    ah yes. I was referring to unrevoked.
  10. robertboyl

    robertboyl Member

    Hi, guys

    Please, can someone give me some help so I can try to flash the ROM? Here trying to figure it out... Why it didnt mount SD card (SD card is on phone). What am I doing wrong?

    Thanks

    UPDATE: the gparted video helped :) I see for some reason I wa trying to do things on recovery screen, but I have to actually load up android on the phone and when plugging it in choose Disk drive connection method. Now I can change FAT size. How much is recommended if I have 8 GB SD card? 2 or 3 GB to ext2 more then enough, correct?

    Will continue trying...
  11. Hadron

    Hadron Well-Known Member

    Is the sd mounted on the computer? You may have to unmount it before you can edit the partitions.

    Make sure you have backed up the content of the card first though - repartitioning will erase the data.
    I don't know "Wildfire", but most ROMs have a2sd scripts in them. CyanogenMod is one exception (you need to add the a2sd afterwards), dGB is another (not intended to use a2sd). But most have.
    You can flash CM without a2sd, just won't have much more space available than with the stock ROM.

    You should always check the first page of a ROM's thread (e.g. at XDA-developers) for any specific intructions or requirements. Otherwise the general procedure is described in the rooting faq. Backing up apps and data first, and taking a nandroid backup before trying this, are the essential things.

    Just seen your update. I'd not bother making the partition larger than 1GB, and choose ext4 or ext3 rather than ext2.
    robertboyl likes this.
  12. robertboyl

    robertboyl Member

    Hi, Hadron

    Thanks for all your help.

    Installed Wildfire based on Oxygen (Gingerbread) which comes with app2sd.

    Only 1 problem for now, in the storage settings, it shows SD-Ext - total and available space = not available...

    If I try to choose preferred location for installation and choose sd-extra it says quickly "sd-ext disabled using auto"

    Pls advise? Perhaps I have to reformat partition using Gparted?

    Update: found solution at XDA...

    solution


    setting / apps / Development /SD-EXT hack

    Re-Boot

    trying...

    SOLVED.

    Thanks, Hadron... Really appreciate it! :) I have lower internal memory now 90 MB, but Android 2.3.7 and it seems 1 GB of space to install apps, just FANTASTIC!!!

    Already installed several apps to EXT and set that as default.

    1 question, I think Ill wait for wife to install all apps she wants. Then of course 1 more backup via recovery, that backs up ROM and all apps also or I need other tool to backup apps/data?
  13. Hadron

    Hadron Well-Known Member

    Glad it's working.

    The recovery backup backs up everything, but it can only be used to restore everything as well. So it's great if you have a corrupt ROM, but doesn't allow you to restore an individual app or move apps & data between different ROMs. That's why most of us use both types of backup.

    The commonest app/data backup tool is Titanium Backup. If you want to change ROMs you'll find that a separate backup for messages is needed (I use SMS Backup+), and contacts should either be backed-up with google or exported to SD card. The reason for this is that the way these are stored is as part of the system data, which are usually incompatible between different ROMs, so while Ti Backup can keep them backed-up while using the same ROM it's not able to move them between different ROMs.
  14. robertboyl

    robertboyl Member

    Hadron,

    Thanks again and congrats on great work here in the forum, really wife is super happy with rooter phone, installing tons of apps :) I noticed Whats app didnt recognize contacts, had to install only that 1 to internal memory.

    I use Exchange ActiveSync, so not a big deal about msgs, I just resetup account and sync. I guess most important is I have her ROM backed up after having rooter her phone.

Share This Page