Need Help with my (supposedly) rooted phone.


  1. peejaygee

    peejaygee Member

    I've got a T-Mobile MyTouch 3g (USA), which was re-rommed last year, making it a HTC Magic with CyanogenMod-6.0.0-DS on it (which I know there is an update available, hence finding I've got problems)..

    So, here's what I find, I can't SU, permission denied.. so I use titaniumbackup to backup first and remove terminal from the system/apps (using Root Explorer) and try to re-install it, re-install new version fails.hhhmm..

    So, I use titanium backup to try to restore terminal, it says it's done and yet it's not showing in my app drawer...

    I've tried using SuperOneClick and it tells me my phone is rooted? I've got Superuser App on there which works with apps, asking me permissions, etc..I've even tried 'Fix Permissions' on Rom Manager.

    I've tried with USB debugging on and off and debated trying to do stuff from PC to phone using putty (but I don't want to make matters worse at the mo) I've tried with the SD unmounted, I've even tried with the Sim card out...

    And this all stemmed from trying to update my rom and googleapps which are sitting on my SD card, but I can't get into the recovery option to access the SD card and update as I think I've got a faulty recovery rom. I've tried using RomManager and putting either Clockwork Recovery 2.5.0.7 and/or RA Recovery v1.7.0h and no matter what, either back and power on, vol down and power on or home and power on, I can't get to the point to install from SD card.. I'm able to get to the point with the 3 little guys on the skateboards, but that doesn't help me...the only thing I see on the screen other than that is the HTC Magic Logo and Fastboot USB in red, top left

    I'm stumped, so have turned to here for some help, is there any more information I can give to resolve my issue, I really, really don't want to have to wipe my phone and start again, but If I have to, I'll do that on the *last* resort..

    My phone is showing as : -
    Sapphire PVT 32A Ship S-ON G
    HBOOT-1.33.0013 (SAPP31000)
    CPLD-13
    RADIO-2.22.23.02
    OCT21 2009,22:33:27

    if that information is any help.
    Thanks in Advance.
    Regards

    Cross posted to Need Help with my (suposidly) rooted phone. - Droid Forum - Verizon Droid & the Motorola Droid Forum

    Advertisement
    :
  2. skilaufen

    skilaufen Well-Known Member

  3. peejaygee

    peejaygee Member

    Ended up installing Android Commander, Android SDK and managed to get the recovery rom on there, gonna be fully backing up my phone and wiping it to the lastest rom...
Loading...

Share This Page