Need help with upgrading Skyrocket to ICS with Kies!Support

Last Updated:

  1. CMiller

    CMiller New Member

    Hello, a little background of my problem. I rooted my phone to the unofficial ICS a few months ago but had problems so I flashed back to stock. Every since then there has been an AT&T update on my phone to 2.3.6 (I have 2.3.5 now) it will DL no problem but when it installs it gets stuck @ 25% and says unable to install. I have tried this multiple times over LTE and wifi still no success with the AT&T update. Where my problem lies is that the baseband version on my device is I727UCALC4 and is not I727UCKK1, I727UCKJ2 or I727UCLA3 which are compatible with the official 4.0 ICS threw kies. When I try to update with kies it says "Your device does not support software upgrading via Kies. I am at a loss. If anyone has any suggestions I would greatly appreciate it. This is my first post so go easy on me thanks! :D

  2. mdanderson

    mdanderson Active Member

    One thing that helped me was uninstalling Kies and then reinstalling it and then do the update to latest version of Kies and then on the ics. There may also be a server overload of Kies going on at the present time so keep trying.
    CMiller likes this.
  3. CMiller

    CMiller New Member

    I will try that out see what happens and post the results.
  4. 509eagle

    509eagle New Member

    I have the same exact issue as C Miller.

    Any solution???
  5. CMiller

    CMiller New Member

    I uninstalled Kies, downloaded the latest drivers for the GS2 Skyrocket from Samsung on their web site, then reinstalled Kies from Samsungs website after that I did what another post said to go to the firmware option drop down menu in Kies and type in your model # "SGH-I727" and your S/N which is found behind the battery DL the update then follow the on screen directions . I now have 4.0.4 but it is slower than 2.3 and my battery life is actually worse if you can believe it. Also I am using twice the RAM
    Any ways I hope this helps anyone that was having this same problem.

Share This Page